HP LaserJet Pro MFP m127fn Printer/Scanner, Can't find drivers

I will start with this:

 ╭─amandaaf@amanda in ~ as 🧙 took 5s
[🔴] × sudo garuda-inxi
[sudo] password for amandaaf:         
  Kernel: 6.9.4-AMD-znver3 arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
    clocksource: tsc avail: hpet,acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-amd-znver3
    root=UUID=32401c16-3240-4e70-a67c-f1a33f8eebd2 rw rootflags=subvol=@
    quiet rd.luks.uuid=2df672f8-1830-47ab-9e32-5fa99904996b
    resume=/dev/mapper/luks-1036344b-37ac-4953-a6f1-b8bb2ac2ce74 loglevel=3
  Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 wm: xfwm4 v: 4.18.0
    with: xfce4-panel tools: xfce4-screensaver avail: xautolock dm: LightDM
    v: 1.32.0 Distro: Garuda base: Arch Linux
  Type: Laptop System: HP product: HP Laptop 15-ef1xxx v: N/A serial: <filter>
    Chassis: type: 10 serial: <filter>
  Mobo: HP model: 8706 v: 99.42 serial: <filter> part-nu: 12B99UA#ABL
    uuid: 30444335-3932-3633-3544-443639324435 UEFI: AMI v: F.52
    date: 09/22/2021
  ID-1: BAT0 charge: 22.9 Wh (66.0%) condition: 34.7/34.7 Wh (100.0%)
    volts: 11.0 min: 11.6 model: Hewlett-Packard Primary type: Li-ion
    serial: N/A status: discharging cycles: 312
  Info: model: AMD Ryzen 3 3250U with Radeon Graphics socket: FP5 bits: 64
    type: MT MCP arch: Zen/Zen+ note: check gen: 1 level: v3 note: check
    built: 2019 process: GF 12nm family: 0x17 (23) model-id: 0x18 (24)
    stepping: 1 microcode: 0x8108109
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 192 KiB desc: d-2x32 KiB; i-2x64 KiB L2: 1024 KiB desc: 2x512 KiB
    L3: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 1700 high: 2600 min/max: 1400/2600 boost: enabled
    base/boost: 2600/3500 scaling: driver: acpi-cpufreq governor: schedutil
    volts: 1.2 V ext-clock: 100 MHz cores: 1: 2600 2: 1400 3: 1400 4: 1400
    bogomips: 20770
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
  Device-1: AMD Picasso/Raven 2 [Radeon Vega Series / Radeon Mobile Series]
    vendor: Hewlett-Packard driver: amdgpu v: kernel arch: GCN-5 code: Vega
    process: GF 14nm built: 2017-20 pcie: gen: 3 speed: 8 GT/s lanes: 16
    ports: active: eDP-1 empty: HDMI-A-1 bus-ID: 04:00.0 chip-ID: 1002:15d8
    class-ID: 0300 temp: 42.0 C
  Device-2: IMC Networks HP TrueVision HD Camera driver: uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-5.2:8
    chip-ID: 13d3:56c9 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.13 compositor: xfwm4 v: 4.18.0 driver:
    X: loaded: amdgpu unloaded: modesetting alternate: fbdev,vesa dri: radeonsi
    gpu: amdgpu display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
    s-diag: 414mm (16.31")
  Monitor-1: eDP-1 mapped: eDP model: AU Optronics 0x80ec built: 2018
    res: 1366x768 hz: 60 dpi: 101 gamma: 1.2 size: 344x193mm (13.54x7.6")
    diag: 394mm (15.5") ratio: 16:9 modes: max: 1366x768 min: 640x480
  API: Vulkan v: 1.3.279 layers: 5 device: 0 type: integrated-gpu name: AMD
    Radeon Vega 3 Graphics (RADV RAVEN2) driver: mesa radv v: 24.1.2-arch1.1
    device-ID: 1002:15d8 surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe
    (LLVM 17.0.6 256 bits) driver: mesa llvmpipe v: 24.1.2-arch1.1 (LLVM
    17.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
  API: OpenGL Message: Unable to show GL data. glxinfo is missing.
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 04:00.1 chip-ID: 1002:15de class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Hewlett-Packard
    driver: snd_pci_acp3x v: kernel
    alternate: snd_pci_acp5x,snd_pci_acp6x,snd_acp_pci pcie: gen: 3
    speed: 8 GT/s lanes: 16 bus-ID: 04:00.5 chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 04:00.6 chip-ID: 1022:15e3 class-ID: 0403
  API: ALSA v: k6.9.4-AMD-znver3 status: kernel-api tools: N/A
  Server-1: PipeWire v: 1.0.7 status: n/a (root, process) with:
    1: pipewire-pulse status: active 2: wireplumber status: active
    3: pipewire-alsa type: plugin 4: pw-jack type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter
    vendor: Hewlett-Packard driver: rtw_8822ce v: N/A modules: rtw88_8822ce
    pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 02:00.0
    chip-ID: 10ec:c822 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  Device-2: Realtek RTL8153 Gigabit Ethernet Adapter driver: r8152 type: USB
    rev: 3.0 speed: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 bus-ID: 2-1:2
    chip-ID: 0bda:8153 class-ID: 0000 serial: <filter>
  IF: enp4s0f3u1 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Info: services: NetworkManager, smbd, systemd-timesyncd, wpa_supplicant
  Device-1: Realtek Bluetooth Radio driver: btusb v: 0.8 type: USB rev: 1.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-4:4 chip-ID: 0bda:b00c
    class-ID: e001 serial: <filter>
  Report: btmgmt ID: hci0 rfk-id: 1 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: <filter> bt-v: 5.1 lmp-v: 10
    status: discoverable: no pairing: no
  Local Storage: total: 476.94 GiB used: 58.64 GiB (12.3%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKNW512G8H
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: HPS0 temp: 28.9 C scheme: GPT
  ID-1: / raw-size: 466.04 GiB size: 466.04 GiB (100.00%)
    used: 58.64 GiB (12.6%) fs: btrfs block-size: 4096 B dev: /dev/dm-0
    maj-min: 254:0 mapped: luks-2df672f8-1830-47ab-9e32-5fa99904996b
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 728 KiB (0.2%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
    maj-min: 259:1
  ID-3: /home raw-size: 466.04 GiB size: 466.04 GiB (100.00%)
    used: 58.64 GiB (12.6%) fs: btrfs block-size: 4096 B dev: /dev/dm-0
    maj-min: 254:0 mapped: luks-2df672f8-1830-47ab-9e32-5fa99904996b
  ID-4: /var/log raw-size: 466.04 GiB size: 466.04 GiB (100.00%)
    used: 58.64 GiB (12.6%) fs: btrfs block-size: 4096 B dev: /dev/dm-0
    maj-min: 254:0 mapped: luks-2df672f8-1830-47ab-9e32-5fa99904996b
  ID-5: /var/tmp raw-size: 466.04 GiB size: 466.04 GiB (100.00%)
    used: 58.64 GiB (12.6%) fs: btrfs block-size: 4096 B dev: /dev/dm-0
    maj-min: 254:0 mapped: luks-2df672f8-1830-47ab-9e32-5fa99904996b
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: partition size: 10.6 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/dm-1 maj-min: 254:1
    mapped: luks-1036344b-37ac-4953-a6f1-b8bb2ac2ce74
  ID-2: swap-2 type: zram size: 9.65 GiB used: 0 KiB (0.0%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4 dev: /dev/zram0
  System Temperatures: cpu: 43.0 C mobo: N/A gpu: amdgpu temp: 43.0 C
  Fan Speeds (rpm): N/A
  Memory: total: 12 GiB note: est. available: 9.65 GiB used: 2.03 GiB (21.0%)
  Processes: 240 Power: uptime: 57m states: freeze,mem,disk suspend: deep
    avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
    suspend, test_resume image: 3.85 GiB services: upowerd,xfce4-power-manager
    Init: systemd v: 256 default: graphical tool: systemctl
  Packages: pm: pacman pkgs: 1461 libs: 447 tools: pamac,paru Compilers:
    gcc: 14.1.1 Shell: garuda-inxi (sudo) default: Bash v: 5.2.26
    running-in: xfce4-terminal inxi: 3.3.35
Garuda (2.6.26-1):
  System install date:     2024-06-16
  Last full system update: 2024-06-24 ↻
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       No/Undetected
  Failed units:            nmb.service 

So I’m trying to find this printer to install into Garuda on my network, and I can’t find it on the list. I can’t even access the scanner on this system. I tried to install hplib but it seems to be missing. I can’t find my network printer and scanner, and I can’t seem to figure out why Garuda is giving me so much trouble about it.

I tried following this, but with no luck Installing HP printer driver for Arch Linux - Unix & Linux Stack Exchange

Since Garuda won’t play nice with me on this issue, I was thinking about installing the run file directly from here HP Developers Portal | Version: 3.24.4, but I don’t know what that will cause

I am running a M177.fw
My scanner does not work (as it is broken) but it used to under OpenSuse.
hplip is definitely the way.
Done it multiple times on different distros. (may need a restart after install).
I have found/ used advanced install and network connection, as best solution for myself and this home office.

once you type in the correct network address it should then find the printer and the software to drive it. The garuda assistant can setup everything else but HP will need the hplip (is in the Extra repo of arch so will download with pacman).

as far as specifics I cannot help as I am a user, not an it guy at all.
Hope this helps in a small way.

The problem is, this library is missing in pacman and paru. I downloaded it directly from HP as a .run file, but it doesn’t recognize Garuda and wont install

Unsure from here. It is definitively in the Extra repo.
Someone else may be able to help .
I just deleted and reinstalled .
Once downloaded HP logo should appear in the menu and go to manual discovery.
I am sorry that is the extent of my knowledge.

Oh look at that, thats probably a huge problem right there…No wonder why I couldn’t find it.

I spelled it as hplib not hplip

cool :smile: .
Hope I have helped in a small way.
As I say im a user not a tech guy.

Your the only one who replied, stick around! I may need your help within the hour

Well, I got my document scanner to work, but the ability to print to that printer doesn’t. To be fair, it doesn’t work on MX linux either. My father updated the firmware in it, and ever since then, it sees the printer but it hangs up when you try to print a test page. Not sure if that is a linux issue or not

It should be, but just in case: have you installed cups?


Yes, cups is installed, I have other printers that work just fine, it’s just this printer that will let me use the scanner, but won’t let me print. I have the print driver installed, but it hangs when you try to print to it.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.