How would I change the default audio output device in Garuda?

Hi y'all, Garuda likes to use "Digital Output" instead of "HDMI" on boot, and I looked up on the arch wiki on how to change that seen here Advanced Linux Sound Architecture - ArchWiki, but when I look for /etc/asound.conf Garuda informs me that it doesn't exist, and I'm not sure where Garuda keeps it's sound configuration file. I've also tried looking on YouTube. Any help in resolving this would be amazing. Thank you for your time.

Relevant Info:
Audio: Pipewire/PulseAudio
Distro: Garuda KDE Dra460nized

For most things (while running KDE), there are DE tools available, use them. You're looking at legacy information, as you're running Pipewire. You can probably find what you want in System Settings/Audio.

I found the settings you mentioned and I have sound, however if I reboot it defaults back to "Digital Output" and gives me no sound, and I have to manually change it back to "HDMI". I'm hoping to change the default audio device to "HDMI". And I installed Pipewire, but alsamixer says it's using pulseaudio for some reason.

So I found the issue. Garuda Settings Manager didn't uninstall Pulseaudio and install Pipewire correctly. Going into Pamac and reinstalling Pipewire fixed the issue. :grinning_face_with_smiling_eyes:

2 Likes

Pipewire transition was this year...so maybe still a bit umm unrefined.

Can you provide more details about what was incorrect? If it's a bug then it needs to be fixed.

5 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.