How to use the nvidia driver on my asus 1 gb gt540m laptop?

Hey everyone!

I am new to garuda (but have used linux since 2007), and like every other distro that is not Ubuntu, I can't find out how to activate the nvidia driver for the life of me.

I have an older but ridiculously fast still (with 250 gb ssd) asus laptop with an i5-2410m, 6 gb ram, and a dedicated 1 gb gt540m geforce gpu, the intel hd 3000 drivers work great, so everything but gaming is perfect, but I want to use the geforce card with the propietary nvidia drivers for games like sattelite reign and left 4 dead 2 and shogun 2 and the like.

I managed to install them, I think, and it installed a ton of other dependencies, but how on God's green Earth do I get it to use the nvidia drivers instead of only the intel hd 3000 dirvers? How to make it use the gt540m for 3d games (linux or wine)?

Don't think. Know! :stuck_out_tongue_winking_eye:
How did you install?
Which config/driver?
Maybe this?

Welcome to Garuda!

I believe the easiest way of switching, I may be wrong, is by changing the output device in the bios, if you're like me and the bios doesn't have that then you need to edit a file, I'm not going to link it since I can't test it and don't know for sure it'll work, but there's an article about nvidia optimus in the arch linux wiki

Thanks for the reply!

See my updated new post, optimus is not the problem, it still says the driver simply isn't loaded. :smiley:

I dont have that in the bios.

I think I am going to "solve" it by simply installing kubuntu and the latte dock, I think I should be able to get the same transparent and wobbly windows and 3d task switcher there since it also uses kde and plasma right, just like dragonized?

I can't take an OS that has me waisted 6 hours so far trying to get a GPU to work that is one click in ubuntu...

1 Like

Wise choice !
I wish you all the best!

oh didn't realize you made a new thread, unserstandable I've been stuck for the past few days trying to get my computer to boot after installing the drivers

Do not create duplicate help requests!!!

Topics merged below:

1 Like

So, I found the option to install propietary drivers in hardware configuration.

It still doesnt work. This has cost me 4-5 hours so far and I am about to have to reinstall the entire system again. I love how pretty everything is and the wobbly window effects and such, and the setup manager after install, the package manager etc, it all makes it super easy, I dont want to go back to ubuntu and lose the pretty colors, but I swear to god, after reinstall I will have spent 6-7 hours just getting my gt540 m to be used for games. I dont have much free time...

One last chance. How can I get the hybrid intel hd 3000 and nvidia package crazy enough to actually load in the nvidia driver, running nvidia-settings with optimus makes no difference, it still says the nvidia drivers arent loaded.

Which magic button or command do I need to get my gpu to work?????????

Everything else is easy and fast and I love it, but in ubuntu, I put a checkmark in a box and press apply and reboot and my GPU WILL work. here.. I just cant get it too, and I hate it, I realy wanna keep using this distro.

Any ideas? How to get it to work? I already tried running the drivers from nvidia site with both dkms and without dkms, setup fails everytime...

Does the dragonized GAMING version (this is normal I am trying) enable them out of the box?

How to get them to work?

So games are work for you :upside_down_face: ?
Invest some of your valuable time into searching the forum for nvidia-intel and optimus.
Then rephrase your questions/requests... :man_shrugging:

There is no such thing here. Users should be able and willing to think.
I suggest you try that :man_shrugging: . Don't be shy!

4 Likes

Hahahha let me rephrase, i want to spend my limited time on playing the games, not 7 hours making it possible :stuck_out_tongue:

And actually the annoying thing is, there is a button for it. In hardware configuration, there is a button to auto install the prop. drivers. It just doesnt work. It tells you it installs them succesfully, but then they dont work on reboot. Thats the annoying thing. I have used the default nvidia drivedr installer a100 times since 2007, but it does something that makes that one fail, too.

Its especially annoying since everything else in the distro works great, the setup manager, installing extra apps, etc, it's all easy to do via the GUI. I literally didnt have to open a terminal untill then and I installed steam, games, discord, 8 emulators, telegram, and more. You guys did a great job - its just as easy to use as windows 10 if not more so. Except that @$**[email protected][email protected][email protected][email protected] driver. :confused:

But I do really need that GPU. and optimus doesnt help, like I said, the drivers simply arent loaded. And the error messages dont help either.

Now to be honest, deepin also works perfectly for me , EXCEPT the nvidia drivers.

Since 2007, the ONLY distro I have ever gotten those things to work on as they should, by just clicking "install" , every time, is ubuntu. EVERY other distro has problems with them. So its not really your fault or anything, but as I said.. it does make me wanna try if I can get those same fancy effects in kubuntu.

Because while users should be able to think (and I do have a computer science master degree), it should not be REQUIRED. wherever possible, the os should just work, or as Linus put it "I don't use any of the difficult distros, I need my computer to just work without problems or thinking about it". Mood.

Or my job, I help people with tech problems at their house, usually old grandmas and such, its super fun, off course for people like that it just needs to work and be easy. I still often install lubuntu for them - its just as easy as windows 7 and works just as reliably. I like that :stuck_out_tongue:

Simple, no more Nvidia, never again Nvidia.

Then better you talk to Nvidia why they do not like Linux and use only closed software.

Solution: It's just money.

Okay, the fix for me was using the linux kernel, not lts, zen, either install it during setup or download it with sudo pacman -S linux , boot using linux kernel, and install the drivers, and I'll let you figure out how to switch between integrated and discrete, and maybe let me know how so I can try it on my laptop

1 Like

Oh sure, except this is a LAPTOP :stuck_out_tongue:

and on my desktop, I just dual boot with windows 10, so it doesnt really matter. I do find that nvidia cards usually have a bit more exclusive features and a bit better support from games...

But yeah, the problem is nvidia, true. However, distro size also matters. I remember a few years back when AMD drivers were still shit, there was half a year or so where amd users could literally only use ubuntu as canonical had made a deal with AMD specifically to support ubuntu LOL. And it took months for other distros to support them again.

Sometimes, linux or not, being a big multi-million dollar company just works :rofl:

(also, imagine if steam machines really took off. How quickly do you think nvidia would sort their linux mess? XD)

oh that should just be prime-run if I understood correctly. But I couldnt try, because they dont work xD

And thank you! I will try that one last time before giving up XD

Return to the topic, or the thread will be locked.

I will slow things down a little by only allowing a single post on this thread per day until next week. When the issue at hand starts being dealt with rather than muck raking I will allow the thread to reopen again in a normal manner.

Don't waste your posts by shoveling dirt on the forum or I'll simply lock this topic and perhaps silence anyone tossing dirt for a while.

Stick to the topic at hand.

Likewise, "One last chance".

4 Likes

Just do this. If no work use Pop OS.
1)Goto Add/Remove Software and type nvidia
2) Search through the results and looks for the driver that says 390 on it. I believe those are the older drivers for older GPUs. Click install.
3) Search for optimus-manager and optimus-manager-qt and install both.
4) Reboot and search optimus-manager in your application menu. Launch and set it to whatever mode you want and whether to startup with the system.
5) Whatever game you run just type prime-run before it to launch. Or add it to steam launch options.

If optimus-manager doesn't work there's always bumblebee. I don't know if the 390xx drivers support prime render offload since I didn't see a package for it but you can try to prepend NVIDIA_PRIME_RENDER_OFFLOAD=1 to the launch options instead to see if it works.

Otherwise you can try to search up optimus solutions specific to your make and model.

2 Likes