How to switch to ntfs3 from ntfs3g?

Hi, I was trying to use the new kernel driver to mount ntfs, I managed to mount it manually, but I wanted it to mount at boot already with ntfs3 instead of older ntfs 3g, but I have no clue about how to do it, also I wondered if it was going to change automatically with a garuda update.
(First time posting here, hope everything is right)

Post your terminal/konsole in- and output as text (no pictures) from:

System:    Kernel: 5.15.2-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=c225b4b5-552f-4d1d-9325-180e06de7ec0
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3 mitigations=off
Desktop: KDE Plasma 5.23.3 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:   Type: Desktop Mobo: Acer model: Aspire TC-780 serial: <filter> UEFI: American Megatrends
v: R02-B2 date: 05/28/2018
CPU:       Info: Quad Core model: Intel Core i5-7400 bits: 64 type: MCP arch: Kaby Lake family: 6
model-id: 9E (158) stepping: 9 microcode: EA cache: L2: 6 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 24000
Speed: 3406 MHz min/max: 800/3500 MHz Core speeds (MHz): 1: 3406 2: 3478 3: 3402 4: 3491
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: vulnerable, SMT disabled
Type: mds status: Vulnerable; SMT disabled
Type: meltdown status: Vulnerable
Type: spec_store_bypass status: Vulnerable
Type: spectre_v1
status: Vulnerable: __user pointer sanitization and usercopy barriers only; no swapgs barriers
Type: spectre_v2 status: Vulnerable, IBPB: disabled, STIBP: disabled
Type: srbds status: Vulnerable
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] vendor: PC Partner Limited
driver: amdgpu v: kernel bus-ID: 01:00.0 chip-ID: 1002:67df class-ID: 0300
Display: x11 server: X.Org 1.21.1.1 compositor: kwin_x11 driver: loaded: amdgpu,ati
unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")
Monitor-1: DisplayPort-0 res: 1920x1080 dpi: 82 size: 598x336mm (23.5x13.2") diag: 686mm (27")
OpenGL:
renderer: AMD Radeon RX 480 Graphics (POLARIS10 DRM 3.42.0 5.15.2-zen1-1-zen LLVM 13.0.0)
v: 4.6 Mesa 21.2.5 direct render: Yes
Audio:     Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: Acer Incorporated ALI
driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a170 class-ID: 0403
Device-2: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] vendor: PC Partner Limited
driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 1002:aaf0 class-ID: 0403
Sound Server-1: ALSA v: k5.15.2-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Acer Incorporated ALI
driver: r8169 v: kernel port: d000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    Local Storage: total: 8.3 TiB used: 3.05 TiB (36.7%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Intenso model: SSD Sata III size: 111.79 GiB block-size:
physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 9B0 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST1000DM010-2EP102 size: 931.51 GiB
block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200
serial: <filter> rev: CC43 scheme: GPT
ID-3: /dev/sdc maj-min: 8:32 type: USB vendor: Seagate model: Backup+ Hub BK size: 7.28 TiB
block-size: physical: 4096 B logical: 512 B type: N/A serial: <filter> rev: D781 scheme: GPT
Partition: ID-1: / raw-size: 111.53 GiB size: 111.53 GiB (100.00%) used: 83.67 GiB (75.0%) fs: btrfs
dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.45%) used: 563 KiB (0.2%) fs: vfat
dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 111.53 GiB size: 111.53 GiB (100.00%) used: 83.67 GiB (75.0%) fs: btrfs
dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 111.53 GiB size: 111.53 GiB (100.00%) used: 83.67 GiB (75.0%)
fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 111.53 GiB size: 111.53 GiB (100.00%) used: 83.67 GiB (75.0%)
fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.58 GiB used: 256 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 38.0 C mobo: 29.8 C gpu: amdgpu temp: 56.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 3
Info:      Processes: 290 Uptime: 2m wakeups: 0 Memory: 15.58 GiB used: 3.01 GiB (19.3%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: 1932 pacman: 1924
lib: 479 flatpak: 8 Shell: fish v: 3.3.1 running-in: konsole inxi: 3.3.08~~~
# Without it, you will not receive any help from the Garuda team or your topic is likely to be closed without notice.

"Since Linux 5.15, ntfs3 provides read and write support for the file system. All officially supported kernels with versions 5.15 or newer are built with CONFIG_NTFS3_FS=m and thus support it."

Ref: NTFS - ArchWiki

4 Likes

I haven't tried this myself because I no longer have any ntfs partitions to test with but it probably depends how you are mounting the device. If you are mounting it in /etc/fstab, it should be as simple as changing the mount options there.

I don't know what the plans are here but it seems like a fairly bad idea to change this globally since there is no guarantee that the end-user is running kernel 5.15 or later.

5 Likes

I'm hoping there will be a kernel regression introduced in a few months (that will trigger on April 1st) resulting in all NTFS drives being wiped. :crazy_face: :rofl:

4 Likes

Thanks for the nudge to shuffle the data around to reformat my external 1TB HDD to Btrfs that I've put off for ..... I can't recall how many years.
I thought it was just stupid right-wingers who fell for obviously made-up fearmongering, apparently this <<< left-winger is also that stupid! :sob: :sob: :sob:

1 Like

I am not sure how I am mounting them, I think it's from the settings, removable devices, automount removable devices at logon, but there's nothing in fstab, any idea on where it is writing that setting?

Install, if needed, gnome-disk-utility.

If you are automounting them, the easiest solution by far is going to be to add them to /etc/fstab unless they are thumb drives and you have a bunch of them. If they are external drives, use systemd-automount units.

after some search I think I found what I should add:
/dev/sdc1 /run/media/tabris/Seagate\040Backup\040Plus\040Drive/ ntfs3 auto,rw,user,exec 0 0
is it correct?

I don't remember the formatting for fstab, however I would recommend using UUID as the identifier rather than /dev/sdx. Less worrying about devices changing order (like when adding/removing drives or failing cables etc).

2 Likes

thanks, it seems it's working without problems

this was just added to AUR today:

https://aur.archlinux.org/packages/ntfsprogs-ntfs3/

replaces ntfs-3g and works perfectly.

3 Likes

For a manual mount (e.g. removable drives):
$ udisksctl mount -b /dev/sdX -t ntfs3

2 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.