How to stop auto-changing of wallpaper?

My desktop wallpaper (background) is changing all the time. I think it's like once every 5 min or so. I want to turn off the constant changing of wallpaper, so I go to the desktop settings by writing "desktop" in the menu and selecting the app with the same name. I have unchecked "change the background". But it still changes wallpaper anyway. How can I permanently select a single wallpaper instead of having it change all the time?

inxi -Faz

System:    Kernel: 5.10.60-1-lts x86_64 bits: 64 compiler: gcc v: 11.1.0 
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts root=UUID=8d05eb79-30ef-4c21-92f0-c8c7c8baee18 rw 
           [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
           systemd.unified_cgroup_hierarchy=1 loglevel=3 
           Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1 vt: 7 dm: LightDM 1.30.0 
           Distro: Garuda Linux base: Arch Linux 
Machine:   Type: Laptop System: Acer product: Aspire A315-56 v: V1.15 serial: <filter> 
           Mobo: IL model: Sleepy_IL v: V1.15 serial: <filter> UEFI: Insyde v: 1.15 date: 07/13/2020 
Battery:   ID-1: BAT1 charge: 47.6 Wh (100.0%) condition: 47.6/47.8 Wh (99.5%) volts: 12.5 min: 11.2 model: LGC AP18C8K 
           type: Li-ion serial: N/A status: Full 
CPU:       Info: Dual Core model: Intel Core i3-1005G1 bits: 64 type: MT MCP arch: Ice Lake family: 6 model-id: 7E (126) 
           stepping: 5 microcode: A6 cache: L2: 4 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 9523 
           Speed: 1154 MHz min/max: 400/1200 MHz Core speeds (MHz): 1: 1154 2: 1200 3: 1143 4: 1200 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel Iris Plus Graphics G1 vendor: Acer Incorporated ALI driver: i915 v: kernel bus-ID: 00:02.0 
           chip-ID: 8086:8a56 class-ID: 0300 
           Device-2: Quanta HD User Facing type: USB driver: uvcvideo bus-ID: 1-7:3 chip-ID: 0408:a061 class-ID: 0e02 
           Display: x11 server: X.Org 1.20.13 compositor: xfwm4 v: 4.16.1 driver: loaded: intel unloaded: modesetting 
           alternate: fbdev,vesa display-ID: :0.0 screens: 1 
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9") 
           Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 143 size: 340x190mm (13.4x7.5") diag: 389mm (15.3") 
           OpenGL: renderer: Mesa Intel UHD Graphics (ICL GT1) v: 4.6 Mesa 21.2.1 direct render: Yes 
Audio:     Device-1: Intel Ice Lake-LP Smart Sound Audio vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel 
           alternate: snd_sof_pci bus-ID: 00:1f.3 chip-ID: 8086:34c8 class-ID: 0403 
           Sound Server-1: ALSA v: k5.10.60-1-lts running: yes 
           Sound Server-2: sndio v: N/A running: no 
           Sound Server-3: JACK v: 1.9.19 running: no 
           Sound Server-4: PulseAudio v: 15.0 running: yes 
           Sound Server-5: PipeWire v: 0.3.33 running: yes 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Acer Incorporated ALI driver: r8169 
           v: kernel port: 4000 bus-ID: 01:00.0 chip-ID: 10ec:8168 class-ID: 0200 
           IF: enp1s0 state: down mac: <filter> 
           Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter vendor: Lite-On driver: ath10k_pci v: kernel 
           port: 4000 bus-ID: 02:00.0 chip-ID: 168c:0042 class-ID: 0280 
           IF: wlp2s0 state: up mac: <filter> 
           IF-ID-1: anbox0 state: down mac: <filter> 
           IF-ID-2: wg-mullvad state: unknown speed: N/A duplex: N/A mac: N/A 
Bluetooth: Device-1: Lite-On Qualcomm Atheros QCA9377 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-10:4 
           chip-ID: 04ca:3015 class-ID: e001 
           Report: bt-adapter ID: hci0 rfk-id: 2 state: down bt-service: enabled,running rfk-block: hardware: no software: yes 
           address: <filter> 
Drives:    Local Storage: total: 238.47 GiB used: 94.78 GiB (39.7%) 
           SMART Message: Required tool smartctl not installed. Check --recommends 
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: RBUSNS8154P3256GJ1 size: 238.47 GiB block-size: 
           physical: 512 B logical: 512 B speed: 15.8 Gb/s lanes: 2 type: SSD serial: <filter> rev: E8FK12.3 temp: 45.9 C 
           scheme: GPT 
Partition: ID-1: / raw-size: 238.21 GiB size: 238.21 GiB (100.00%) used: 94.78 GiB (39.8%) fs: btrfs dev: /dev/nvme0n1p2 
           maj-min: 259:2 
           ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) used: 562 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 
           maj-min: 259:1 
           ID-3: /home raw-size: 238.21 GiB size: 238.21 GiB (100.00%) used: 94.78 GiB (39.8%) fs: btrfs dev: /dev/nvme0n1p2 
           maj-min: 259:2 
           ID-4: /var/log raw-size: 238.21 GiB size: 238.21 GiB (100.00%) used: 94.78 GiB (39.8%) fs: btrfs 
           dev: /dev/nvme0n1p2 maj-min: 259:2 
           ID-5: /var/tmp raw-size: 238.21 GiB size: 238.21 GiB (100.00%) used: 94.78 GiB (39.8%) fs: btrfs 
           dev: /dev/nvme0n1p2 maj-min: 259:2 
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) 
           ID-1: swap-1 type: zram size: 7.56 GiB used: 1024 KiB (0.0%) priority: 100 dev: /dev/zram0 
Sensors:   System Temperatures: cpu: 27.8 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 293 Uptime: 4h 32m wakeups: 6 Memory: 7.56 GiB used: 2.75 GiB (36.4%) Init: systemd v: 249 
           tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1749 lib: 385 Shell: Bash v: 5.1.8 
           running-in: xfce4-terminal inxi: 3.3.06 

See if you have variety installed. If you do, uninstall it.

6 Likes

I mark-it-solved ! :slight_smile:

3 Likes

Right-Cick desktop
Seect 'Configure Desktop and Wallpaper'
Click on the option 'Slideshow" (its the second pull down)
Make your selection, Apply and exit.
Your problem should be sorted

You should consider reading the actual post before you respond.

  • The OP clearly stated they already checked the DE settings
  • Your instructions are for plasma/kde, the OP is running xfce
4 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.