How to remove the system info that at top of terminal window

Trying to figure out where to remove the system info at top of Gnome terminal window.
On a laptop it takes up way to much room.
I would have thought it would be in the view.

:warning: Missing information requested in the template may result in not receiving assistance

Make sure you have done the following before you post:

Issue still unresolved? Then:

  • ONE issue per topic.

  • Describe your issue in detail. The more we know, the better we can help

  • Show us the results of your searches, and what you’ve tried

  • After rebooting, post the FULL output of garuda-inxi in the body of the post (not linked externally, or collapsed with the β€œhide details” feature)

  • Format terminal output (including your garuda-inxi) as a code block by clicking the preformatted text button (</>) , or put three tildes (~) above and below the text

Without garuda-inxi this request will be moved to 412 Precondition Failed

                   .%;888:8898898:                keith@Lenovo-Flex3
                 x;XxXB%89b8:b8%b88:              ------------------
              .8Xxd                8X:.           OS: Garuda Linux x86_64
            .8Xx;                    8x:.         Host: 80R4 Flex 3-1580
          .tt8x          .d            x88;       Kernel: 6.6.9-zen1-1-zen
       .@8x8;          .db:              xx@;     Uptime: 1 min
     ,tSXXΒ°          .bbbbbbbbbbbbbbbbbbbB8x@;    Packages: 1435 (pacman)[stable]
   .SXxx            bBBBBBBBBBBBBBBBBBBBbSBX8;    Shell: fish 3.7.0
 ,888S                                     pd!    Resolution: 1920x1080
8X88/                                       q     DE: Cinnamon 6.0.2
8X88/                                             WM: Muffin (X11)
GBB.                                              WM Theme: Sweet-Dark (Sweet-Dark)
 x%88        d888@8@X@X@X88X@@XX@@X@8@X.          Theme: Sweet-Dark [GTK2/3/4]{?3} {3} [P}
   dxXd    dB8b8b8B8B08bB88b998888b88x.           Icons: BeautyLine [GTK2/3/4]
    dxx8o                      .@@;.              Terminal: GNOME Terminal 3.50.1
      dx88                   .t@x.                Terminal Font: FantasqueSansMono Nerd F2
        d:SS@8ba89aa67a853Sxxad.                  CPU: Intel(R) Pentium(R) 4405U (4) @ 2.z
          .d988999889889899dd.                    GPU: Intel HD Graphics 510
                                                  Memory: 2.23 GiB / 7.56 GiB


 ╭─keith@Lenovo in ~ 
 ╰─λ garuda-inxi
  Kernel: 6.6.9-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=61559364-8d16-4ba6-99f3-cd05e28287bd rw rootflags=subvol=@
    quiet loglevel=3 ibt=off
  Desktop: Cinnamon v: 6.0.2 tk: GTK v: 3.24.39 wm: muffin vt: 7 dm: LightDM
    v: 1.32.0 Distro: Garuda Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 80R4 v: Flex 3-1580
    serial: <superuser required> Chassis: type: 10 v: Flex 3-1580
    serial: <superuser required>
  Mobo: LENOVO model: Flex 3-1580 v: SDK0J40700 WIN
    serial: <superuser required> UEFI: LENOVO v: D3CN39WW date: 06/26/2018
  ID-1: BAT0 charge: 34.2 Wh (95.0%) condition: 36.0/45.0 Wh (80.0%)
    volts: 12.0 min: 11.1 model: SMP L14M3P21 type: Li-poly serial: <filter>
    status: not charging
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M325
    serial: <filter> charge: 55% (should be ignored) rechargeable: yes
    status: discharging
  Info: model: Intel Pentium 4405U bits: 64 type: MT MCP arch: Skylake
    level: v2 built: 2015 process: Intel 14nm family: 6 model-id: 0x4E (78)
    stepping: 3 microcode: 0xF0
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 2 MiB desc: 1x2 MiB
  Speed (MHz): avg: 400 min/max: 400/2100 scaling: driver: intel_pstate
    governor: performance cores: 1: 400 2: 400 3: 400 4: 400 bogomips: 16799
  Flags: ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
  Device-1: Intel HD Graphics 510 vendor: Lenovo driver: i915 v: kernel
    arch: Gen-9 process: Intel 14n built: 2015-16 ports: active: HDMI-A-1
    empty: none bus-ID: 00:02.0 chip-ID: 8086:1906 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.10 with: Xwayland v: 23.2.3 driver: X:
    loaded: modesetting alternate: fbdev,intel,vesa dri: iris gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: HDMI-A-1 mapped: HDMI-1 model: Acer KB272HL H serial: <filter>
    built: 2022 res: 1920x1080 hz: 75 dpi: 82 gamma: 1.2
    size: 597x336mm (23.5x13.23") diag: 685mm (27") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  API: Vulkan v: 1.3.274 layers: 3 device: 0 type: integrated-gpu name: Intel
    HD Graphics 510 (SKL GT1) driver: mesa intel v: 23.3.2-arch1.2
    device-ID: 8086:1906 surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe
    (LLVM 16.0.6 128 bits) driver: mesa llvmpipe v: 23.3.2-arch1.2 (LLVM
    16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
  API: OpenGL Message: Unable to show GL data. glxinfo is missing.
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_soc_avs
    bus-ID: 00:1f.3 chip-ID: 8086:9d70 class-ID: 0403
  API: ALSA v: k6.6.9-zen1-1-zen status: kernel-api tools: N/A
  Server-1: PipeWire v: 1.0.0 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
    vendor: Lenovo driver: ath10k_pci v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 bus-ID: 02:00.0 chip-ID: 168c:0042 class-ID: 0280
  IF: wlp2s0 state: down mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    port: d000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-1: Qualcomm Atheros driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-8:6 chip-ID: 0cf3:e360
    class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 2 state: up address: <filter> bt-v: 4.1
    lmp-v: 7 status: discoverable: no pairing: no class-ID: 7c010c
  Local Storage: total: 931.51 GiB used: 19.36 GiB (2.1%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 870 EVO 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 1B6Q scheme: GPT
  ID-1: / raw-size: 58.59 GiB size: 58.59 GiB (100.00%)
    used: 19.35 GiB (33.0%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
    used: 5.7 MiB (1.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 58.59 GiB size: 58.59 GiB (100.00%)
    used: 19.35 GiB (33.0%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
  ID-4: /var/log raw-size: 58.59 GiB size: 58.59 GiB (100.00%)
    used: 19.35 GiB (33.0%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
  ID-5: /var/tmp raw-size: 58.59 GiB size: 58.59 GiB (100.00%)
    used: 19.35 GiB (33.0%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 7.56 GiB used: 0 KiB (0.0%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4 dev: /dev/zram0
  System Temperatures: cpu: 41.0 C pch: 38.5 C mobo: N/A
  Fan Speeds (rpm): N/A
  Processes: 242 Uptime: 1m wakeups: 0 Memory: total: 8 GiB
  available: 7.56 GiB used: 2.21 GiB (29.3%) Init: systemd v: 255
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
  pm: pacman pkgs: 1435 libs: 418 tools: pamac,paru,yay Shell: fish v: 3.7.0
  running-in: gnome-terminal inxi: 3.3.31
Garuda (2.6.22-1):
  System install date:     2024-01-04
  Last full system update: 2024-01-05
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       Probably (Run as root to verify)
  Failed units:            

i did search here and elsewhere nothing remotely gave information.

Search in .config/fish/ about fastfetch and remove it.


Well that was no help.
Solved=installed a no nonsense Terminal , Qt Terminal.

It would have fixed the issue if you followed the instruction. The call to Fastfetch is in the Fish config.

The reason this β€œworked” is because your new terminal has not been configured to use the Fish shell. That is set up using a custom command in the terminal. If you use Fish in your new terminal, the β€œproblem” will return.

micro ~/.config/fish/

Scroll all the way to the bottom and delete the three lines related to Fastfetch.


Thanks that worked, did have to delete the β€œend” after those 3 lines as well.

We always mark here the solution and not the implementation.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.