How to remove listed applications in application launcher?

Hi everyone, this is not really a massive issue as such but is a huge pet peeve that really bothers me and I just seemingly can't figure out how to correct. Essentially I tried installing some games via WINE and a few of them didn't install correctly but somehow they continue to show up in my application launcher regardless. I've tried out several suggestions that I found online and none of them seem to work so I thought I'd get some extra help from the Garuda folk here to help get this issue solved.

Unfortunately because I'm a new user here, the forum doesn't allow me to post a picture on the matter which makes the issue very hard to show but hopefully this is something that's easily fixable.

System:
Kernel: 5.17.7-zen1-2-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=b359195e-7f80-4045-8f69-cfa2953add39 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.4 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: Tactus product: Custom v: N/A
serial: <superuser required>
Mobo: ASUSTeK model: ROG STRIX X570-E GAMING WIFI II v: Rev X.0x
serial: <superuser required> UEFI: American Megatrends v: 4101
date: 09/10/2021
Battery:
Device-1: hidpp_battery_0
model: Logitech G305 Lightspeed Wireless Gaming Mouse serial: <filter>
charge: 100% (should be ignored) rechargeable: yes status: discharging
CPU:
Info: model: AMD Ryzen 9 5900X bits: 64 type: MT MCP arch: Zen 3
family: 0x19 (25) model-id: 0x21 (33) stepping: 2 microcode: 0xA201204
Topology: cpus: 1x cores: 12 tpc: 2 threads: 24 smt: enabled cache:
L1: 768 KiB desc: d-12x32 KiB; i-12x32 KiB L2: 6 MiB desc: 12x512 KiB
L3: 64 MiB desc: 2x32 MiB
Speed (MHz): avg: 3909 high: 4078 min/max: 2200/5218 boost: disabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3898 2: 3885
3: 3893 4: 4024 5: 3899 6: 3897 7: 3900 8: 3911 9: 3891 10: 3895 11: 3898
12: 3863 13: 3907 14: 4078 15: 3908 16: 3902 17: 3889 18: 3890 19: 3902
20: 3899 21: 3893 22: 3908 23: 3894 24: 3909 bogomips: 187196
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: always-on, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Navi 21 [Radeon RX 6800/6800 XT / 6900 XT] vendor: Gigabyte
driver: amdgpu v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 ports:
active: HDMI-A-2 empty: DP-1,DP-2,HDMI-A-1 bus-ID: 0c:00.0
chip-ID: 1002:73bf class-ID: 0300
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting,radeon
alternate: fbdev,vesa gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: HDMI-A-2 mapped: HDMI-A-1 model: BenQ GW2760 serial: <filter>
built: 2013 res: 1920x1080 hz: 60 dpi: 82 gamma: 1.2
size: 598x336mm (23.54x13.23") diag: 686mm (27") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
OpenGL: renderer: AMD Radeon RX 6800 XT (sienna_cichlid LLVM 13.0.1 DRM
3.44 5.17.7-zen1-2-zen)
v: 4.6 Mesa 22.0.3 direct render: Yes
Audio:
Device-1: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel
pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 0c:00.1 chip-ID: 1002:ab28
class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 0e:00.4 chip-ID: 1022:1487 class-ID: 0403
Device-3: RODE Microphones NT-USB type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-3:2 chip-ID: 19f7:0003
class-ID: 0300
Sound Server-1: ALSA v: k5.17.7-zen1-2-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.51 running: yes
Network:
Device-1: MEDIATEK RZ608 Wi-Fi 6E 80MHz driver: mt7921e v: kernel pcie:
gen: 2 speed: 5 GT/s lanes: 1 bus-ID: 04:00.0 chip-ID: 14c3:0608
class-ID: 0280
IF: wlp4s0 state: up mac: <filter>
Device-2: Realtek RTL8125 2.5GbE vendor: ASUSTeK driver: r8169 v: kernel
pcie: gen: 2 speed: 5 GT/s lanes: 1 port: e000 bus-ID: 05:00.0
chip-ID: 10ec:8125 class-ID: 0200
IF: enp5s0 state: down mac: <filter>
Device-3: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb
v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 06:00.0
chip-ID: 8086:1539 class-ID: 0200
IF: enp6s0 state: down mac: <filter>
Bluetooth:
Device-1: MediaTek Wireless_Device type: USB driver: btusb v: 0.8
bus-ID: 1-6:5 chip-ID: 0e8d:0608 class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
Local Storage: total: 10.01 TiB used: 2.4 TiB (24.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Seagate
model: FireCuda 530 ZP1000GM30013 size: 931.51 GiB block-size:
physical: 512 B logical: 512 B speed: 63.2 Gb/s lanes: 4 type: SSD
serial: <filter> rev: SU6SM001 temp: 43.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 870 QVO 2TB
size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 2B6Q
ID-3: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST2000DM008-2FR102
size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 7200 serial: <filter> rev: 0001
ID-4: /dev/sdc maj-min: 8:32 vendor: Seagate model: ST4000NE001-2MA101
size: 3.64 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 7200 serial: <filter> rev: EN01
ID-5: /dev/sdd maj-min: 8:48 type: USB vendor: Seagate model: Expansion
size: 1.82 TiB block-size: physical: 4096 B logical: 512 B type: N/A
serial: <filter> rev: 9300 scheme: MBR
Partition:
ID-1: / raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 482.84 GiB (51.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 482.84 GiB (51.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 482.84 GiB (51.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 482.84 GiB (51.9%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 62.78 GiB used: 5.5 MiB (0.0%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 53.0 C
mem: 52.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
Info:
Processes: 459 Uptime: 1h 4m wakeups: 3 Memory: 62.78 GiB
used: 4.39 GiB (7.0%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 12.1.0 clang: 13.0.1 Packages: pacman: 1937 lib: 553 Shell: fish
v: 3.4.1 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.15
Garuda (2.6.3-2):
System install date:     2022-04-15
Last full system update: 2022-05-17
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:

What happens when you right-click on that icon in the launcher? Do you see an option to remove it, if it allows you to right-click?

Have you tried a

balooctl purge

And reboot?

Oh yes, I found the save icon in the edit applications menu. Turns out I was trying to remove it without saving my changes, oof! Good to know that's something I can use now that they're not showing up in my application launcher anymore. Are there any other leftover files I should clear up after removing them from the menu via manual deletion or terminal commands or does deleting those entries in the launcher sort that out already?

No I haven't tried that, may I ask what that command does? Being new to Linux full time it would definitely save me hunting down its purpose in the Arch wiki or other forums since I'm still not too familiar with the terminal yet.

This might help Baloo - ArchWiki

CTRL-F for "purge".

2 Likes

Baloo is an indexing daemon, which is used in many searching tools, eg krunner.
I think purging its database could help removing some leftovers, limited to the search box of the launcher, not the links actually...

3 Likes

Ahhh that would be very handy, I'll certainly try that since they do still show up in the search tool. Thanks for the heads up :slight_smile:

I did manage to find the .menu files in .config/menus/applications-merged, sending the ones I didn't need into the waste basket seems to have gotten rid of them in the search results of the application launcher too. Probably a crude way of doing it and I'm sure there's a much cleaner and better way of doing it but it seems like that definitely works. Now I'm just gonna have to see where else other files may persist.

EDIT: Forgot to mention it seems to only work with apps I used with the standard WINE, as it seems apps I installed through Lutris seem to persist in the search results.

Unfortunately the Baloo purge command and removing the .menu files didn't seem to do the trick. But as I am now able to post images and I've still not figured out how to solve this issue completely, here's a couple of images where I have multiple instances of Prodeus and Unreal Gold showing up in my search results in my application launcher.

I attempted installing both games via Lutris, Unreal Gold I never managed to get that working but the PlayOnLinux version works perfectly fine but I eventually got Prodeus running just fine via Lutris. All that's left is getting those dud results removed from my search, hopefully this'll help anybody pinpoint the issue, I'd be very greatful for the help!


Ok let's try this Remove app link from KDE plasma menu - Newbie - EndeavourOS

Follow dalto's post, who btw happens to be a moderator here on the forums.

I have an app shortcut I want to delete and it worked.

Here's how you can do it:

  • Following dalto's above, Right-click on the Launcher's Dragon Menu icon
  • Click EDIT APPLICATIONS - A new window will open
  • Find your shortcuts from the left-hand side list and select one
  • Click DELETE in the top menu
  • Click SAVE in top menu

Changes are live. Worked like a charm for me, so I want to thank you for opening this thread, it made me Whoogle for how to and it works. :smiley:

2 Likes

Delete your .cache and let it rebuild at reboot. You'll lose some other settings, but oh well.

1 Like

Unfortunately that didn't do the trick for me, the invalid links to those dud Prodeus and Unreal executables are still there unfortunately with no way of selecting them or even finding them via the search menu :frowning: I seriously have no clue what to do to resolve this issue, it's very frustrating not being able to find any solid answers on this issue neither.

c00ter's suggestion of deleting the .cache and rebooting also didn't work neither, those dud links continue to persist. I really wish there was a super easy and straight forward right click and remove option that would save everyone the hassle on this stuff.

I did read on a KDE forum that there's a history setting of sorts for the application launcher but I have no clue where that is but maybe that's a lead?

Ok then that means your problem is "behind the scenes" and will probably require more Google digging to find out.

At this point though I would highly suggest you try to post on forum.kde.org.
There are certainly a lot more people there and more chances that someone had the same issue or knows exactly what to do to fix it. :slight_smile:

Seems like it for sure, I had the same issue with Quake 4 but since I attempted to install that via standard WINE it seemed to be an easy one to get rid of. With Prodeus and Unreal Gold, it was either an issue through Lutris or Minigalaxy not installing them correctly so it should hopefully be easy for more experienced users to nail down.

For the time being however I decided to write a comment in those links reminding me they're no good to use with text appearing to their right that they're borked so that should make it easier to deal with for the time being.

I appreciate everyone's help regardless though, it's a shame I seem to have gotten unlucky on this one but I'll gladly post any results and solutions if I end up finding one :slight_smile:

1 Like

Do you have any files in ~/.local/share/applications?

2 Likes