How to remove "blackarch"-Repo?

Hello fellow Garuda users.

I'm using Garuda at least two years now, without a need of reinstalling it even once.
I was tempted to use the blackarch-edition, bc they offered some spezial programs for pen-testing, wich for me sounded very nice as an DevOp-Beginner. Now, after a while I realised didn't need that even once, and read about the discontinued support.

So my question is: How can I manage to remove it, without re-installing it. Is that even possible to accomplisch? I tried a litte by myself, but I'm unsure how deep its going. I tried removing it from the repos and even thougt about uninstalling some apps, but I ran into a kinda similar problem, what "linus tech tips"-Linus had, when installing steam where X11 got removed.

If you wish to remove the installed packages, you can print a list of all packages installed from any given repo with paclist.

paclist blackarch

Then uninstall the unwanted packages.

sudo pacman -Rns <list of packages>

You can remove the keyring with pacman-key.

sudo pacman-key -d <blackarch key>

You can find the keys with pacman-key -l. It's probably not a big deal if you would rather not bother deleting the key. :wink:

Edit /etc/pacman.conf and in the repository section you can delete or comment out the lines for the BlackArch repo. There are probably only two lines, the bracketed repo name and the "Include=" line. Then delete the mirrorlist:

sudo rm /etc/pacman.d/blackarch-mirrorlist

Hmm I got a really big list of programs. Mostly python-related it seems but also a good amount of other packages.

paclist blackarch | cut -dā€™ ā€™ -f1

(after using ā€œ,ā€ instead a newline.)

afflib, afpfs-ng, aircrack-ng, amass, argon2, arjun, arp-scan, autopsy, beef, bind, binwalk, blackarch-keyring, blackarch-menus, blackarch-mirrorlist, bulk-extractor, bully, burpsuite, capstone, cewl, chntpw, ckbcomp, commix, crackmapexec, creddump, crunch, davtest, dbd, dirb, dirbuster, dirhunt, dirsearch, dmitry, dns2tcp, dnschef, dnsenum, dnsrecon, enum4linux, exiv2, exploitdb, faradaysec, fern-wifi-cracker, fierce, fping, gconf, gdb, gdb-common, geoip, gksu, guymager, hash-identifier, hashcat, hashcat-utils, hashdeep, hashid, hotpatch, hping, hydra, ike-scan, impacket, inetsim, iodine, iputils, jhead, john, kismet, laudanum, ldapdomaindump, legion, libgksu, macchanger, magicrescue, maltego, maskprocessor, masscan, metasploit, mimikatz, mitmproxy, mkinitcpio-openswap, msfdb, multimac, mysql-python, nbtscan, ncrack, ncurses5-compat-libs, netdiscover, netmask, netsed, netsniff-ng, ngrep, nikto, nmap, onesixtyone, openssl-1.0, ophcrack, paru, patator, pdf-parser, pdfid, perl-http-dav, perl-net-netmask, perl-net-whois-ip, perl-string-random, perl-xml-dom, pipal, pixiewps, polenum, powersploit, proxychains-ng, proxytunnel, pth-toolkit, ptunnel, pwnat, pyinstaller, pyqt3, python-aardwolf, python-adblockparser, python-aesedb, python-aiocmd, python-aiomultiprocess, python-aiosmb, python-aiowinreg, python-ajpy, python-anyascii, python-arc4, python-asciitree, python-asn1tools, python-asyauth, python-asysocks, python-backoff, python-bitstruct, python-capstone, python-censys, python-cherrypy-cors, python-cli-helpers, python-couchdb, python-cx_oracle, python-dicttoxml, python-diskcache, python-dsinternals, python-exifread, python-faraday-plugins, python-filedepot, python-filteralchemy-fork, python-flask-classful, python-flask-kvsession-fork, python-flask-restless, python-google, python-httpagentparser, python-inflect, python-ipaddr, python-ipwhois, python-limits, python-lsassy, python-masky, python-minikerberos, python-msldap, python-nassl, python-neo4j-driver, python-nplusone, python-pgcli, python-pgspecial, python-plotly, python-pluginbase, python-proxy-db, python-psrpcore, python-publicsuffixlist, python-pyee, python-pygexf, python-pylnk3, python-pypdf2, python-pypsrp, python-pypykatz, python-pysqlite3, python-python-docx, python-python-pptx, python-python-rle, python-python-whois, python-pytsk3, python-pywerview, python-requests-futures, python-restkit, python-secure, python-selenium, python-sgmllib3k, python-shodan, python-simplekv, python-slowapi, python-syslog-rfc5424-formatter, python-terminaltables, python-tls-parser, python-torrequest, python-unicrypto, python-uvicorn, python-w3af-api-client, python-webargs, python-winacl, python-winsspi, python2, python2-altgraph, python2-chardet, python2-dis3, python2-future, python2-idna, python2-macholib, python2-pefile, python2-pycryptodome, python2-pytsk3, python2-pyusb, python2-requests, python2-setuptools, python2-sip, python2-urllib3, qscintilla-qt3, qt3, radare2, reaver, rebind, redsocks, responder, rsmangler, rtkit, ruby-json, ruby-snmp, sakis3g, samdump2, sbc, sbd, scalpel, scrounge-ntfs, seclists, secure-delete, set, sherlock, skipfish, sleuthkit, sleuthkit-java, smbmap, snmpcheck, socat, spiderfoot, sploitctl, spooftooph, sqlmap, ssldump, sslscan, sslsplit, sslyze, statsprocessor, strace, stunnel, swaks, tcpdump, tcpick, tcpreplay, testdisk, thc-ipv6, thc-pptp-bruter, theharvester, tor, torctl, traceroute, udptunnel, unix-privesc-check, upx, veil, veracrypt, voiphopper, wafw00f, wce, webshells, weevely, wfuzz, whatweb, wifite, windows-binaries, winexe, wireshark-cli, wireshark-qt, wordlistctl, wpscan, yara, yay, zaproxy

you think this is safe to uninstall them?

Some of those packages should be provided by other repos. Did you put BlackArch above the other repos in /etc/pacman.conf?

If so, you can try moving it to the bottom of the repo section, then reinstall that whole package list so the packages provided by other repos get installed against the repos you are keeping. Then run paclist again to generate a new list.


No, i think its already on the bottom. Thanks for your help.

In my opinion it is really worth getting rid of all that stuff....
It looks to me like 99% blackarch-related, and after all if you don't see anything that sounds useful you probably don't need it.
For sure something might be needed there, paru for example (strange!). Give again a look and keep that list around for the future, if it will ever be needed...


so, I think I got it removed. I had to use paru/yay to fix some issues, because blackarch equivalents may exists, but the most of it I would say had to be recompiled.

I will describe, what I've did to accomplish this, and what issues on the way exsisted.

  1. I made the paclist blackarch, with those i first tried to remove them like BluishHumility explained, which did not work, I got a lot of errors that I cannot remove a lot of the packages, because they're neede for some of the others

  2. I tried removeing the repo, and use the created package list to "reinstall/update" the packages... this kinda worked, but not in the way I wanted. Because, I got said, the packages didn't exists or something...

  3. I was trying to use yay instead of pacman... yay also had problems at first, where I tried to use the package list for that, but after I just used it without any additional params it listet a lot of the packes in the AUR and so on, it also shows packages not longer needed or "verwaist" (sorry, didn't know the correct term in english here) so I removed them no longer needed others got reinstalled as well... but, before I realy was finished with all that I switched to paru instead, because I got the feeling this works better/reliable... was kinda well

After that I just needed to remove the blackarch-mirrorlist and blackarch-menu packages wich for soem reason hat still been there (and marked as "verwaist")... finaly I got to the point where I did no longer think I messed up my system and was quite happy even if the process was somewhat messy and not like Bluish said...

I'm still a little bit unsecure if what I did was right, but the system boots like before.
I can update everything without errors, I just have these 2 left over, and im not so sure about removing them or something like that:

:: Pakete nicht im AUR: archlinux-appstream-data-pamac paleofetch-garuda

Both are safe to remove. The first has been removed from AUR since a hook in pamac-aur does the same, the latter has been succeeded by fastfetch since quite a while.

  1. OK, thanks
  2. which fastfetch should I use? the AUR oder garuda-git variant?

IIRC, orphan / orphaned :slight_smile:

( 8/13) Orphaned package notification...
=> No orphans found.

I mark your post as solution.

Use what you like :wink: the garuda-git includes the ascii dragon.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.