How to make top bar of dragonized always transparent?

Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.3 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
Mobo: ASUSTeK model: ROG STRIX B550-F GAMING (WI-FI) v: Rev X.0x
serial: <superuser required> UEFI: American Megatrends v: 2604
date: 02/25/2022
CPU:
Info: model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 2
family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701021
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 32 MiB desc: 2x16 MiB
Speed (MHz): avg: 3670 high: 4170 min/max: 2200/4208 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3378 2: 3369
3: 3805 4: 3895 5: 3594 6: 4170 7: 3692 8: 3627 9: 3744 10: 3557 11: 3593
12: 3617 bogomips: 86241
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Retpolines, IBPB: conditional, STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT]
vendor: Sapphire driver: amdgpu v: kernel pcie: gen: 4 speed: 16 GT/s
lanes: 16 ports: active: HDMI-A-1 empty: DP-1,DP-2,DP-3 bus-ID: 09:00.0
chip-ID: 1002:731f class-ID: 0300
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting,radeon
alternate: fbdev,vesa gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: HDMI-A-1 mapped: HDMI-A-0 model: Asus MX239 serial: <filter>
built: 2014 res: 1920x1080 hz: 60 dpi: 92 gamma: 1.2
size: 528x310mm (20.79x12.2") diag: 612mm (24.1") ratio: 15:9 modes:
max: 1920x1080 min: 720x400
OpenGL: renderer: AMD Radeon RX 5700 XT (navi10 LLVM 13.0.1 DRM 3.44
5.17.5-zen1-1-zen)
v: 4.6 Mesa 22.0.3 direct render: Yes
Audio:
Device-1: AMD Navi 10 HDMI Audio driver: snd_hda_intel v: kernel pcie:
gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 09:00.1 chip-ID: 1002:ab38
class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 0b:00.4 chip-ID: 1022:1487 class-ID: 0403
Sound Server-1: ALSA v: k5.17.5-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.51 running: yes
Network:
Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
speed: 5 GT/s lanes: 1 bus-ID: 05:00.0 chip-ID: 8086:2723 class-ID: 0280
IF: wlp5s0 state: up mac: <filter>
Device-2: Intel Ethernet I225-V vendor: ASUSTeK driver: igc v: kernel
pcie: gen: 2 speed: 5 GT/s lanes: 1 port: N/A bus-ID: 06:00.0
chip-ID: 8086:15f3 class-ID: 0200
IF: enp6s0 state: down mac: <filter>
IF-ID-1: wg-mullvad state: unknown speed: N/A duplex: N/A mac: N/A
Bluetooth:
Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 1-5:2 chip-ID: 8087:0029 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
Local Storage: total: 1.13 TiB used: 509.19 GiB (44.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Smart Modular Tech.
model: SHGP31-1000GM-2 size: 931.51 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 41061C20 temp: 52.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Intel model: SSDSC2BP240G4
size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 0410 scheme: GPT
Partition:
ID-1: / raw-size: 97.16 GiB size: 97.16 GiB (100.00%)
used: 19.05 GiB (19.6%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-f67fb17e-b2e2-4b91-9070-bd9fecb58eb5
ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
used: 720 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p6 maj-min: 259:6
ID-3: /home raw-size: 223.57 GiB size: 223.57 GiB (100.00%)
used: 103.32 GiB (46.2%) fs: btrfs dev: /dev/dm-1 maj-min: 254:1
mapped: luks-1193a6aa-4ce9-483a-8bef-63caff32ae67
ID-4: /var/log raw-size: 97.16 GiB size: 97.16 GiB (100.00%)
used: 19.05 GiB (19.6%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-f67fb17e-b2e2-4b91-9070-bd9fecb58eb5
ID-5: /var/tmp raw-size: 97.16 GiB size: 97.16 GiB (100.00%)
used: 19.05 GiB (19.6%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-f67fb17e-b2e2-4b91-9070-bd9fecb58eb5
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.59 GiB used: 1.83 GiB (11.8%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 49.0 C
mem: 60.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 1724
Info:
Processes: 397 Uptime: 3h 6m wakeups: 1 Memory: 15.6 GiB
used: 3.7 GiB (23.7%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 1838 lib: 520 Shell: fish
v: 3.4.1 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.15
Garuda (2.6.2-1):
System install date:     2022-05-08
Last full system update: 2022-05-08
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:

Hello,

Is there a way to make the top bar of dragonized edition always transparent? At the moment it turns black when a window is maximized. I would like to make it always transparent regardless of the window.

Jim

Give a look at this thread. I'm currently on the mobile and cannot check, but I remember it did the trick also for me (but normally I don't use transparency :blush:).
You will find many other parameters to play with.

1 Like

Tried looking for the appearance bar mentioned in the post and my latte does not have a tab like that.

I poked around in there and could not find something similar enough to fit those instructions.

It is there.
Right click on top panel, Edit Panel... (this was missing in the instructions, but intuitive...), Appearence Tab, scroll down (and check in general).
Take note of what you change, if you don't want to reset default config in case of troubles.
Edit:
In my case, for example with:
Prefer opaque background when touching any window unflagged
Hide background when not needed unflagged
Opacity = 0%
Palette = Smart Colors Based on Desktop Background
I have an always transprent panel.
If e.g. I flag Prefer opaque background when touching any window the panel becomes black with maximized windows.

3 Likes

This worked for me. Thank you for your help.

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.