How to keep audio alive?

After a period of time when no audio is playing the audio drops. This stops sending an audio signal through my S/PDIF which causes my DAC/AMP to turn off shortly after. If I have my speakers turned on when this happens a loud pop occurs. Also, when I start playing audio again it takes a couple of second for the DAC/AMP to boot.

I am not seeing any options in audio settings to keep audio alive. Does this option exist or can it be added?

I drop this textfile as "snd_hda_intel.conf" in /etc/modprobe.d on my Intel/Intel machines:

options snd_hda_intel power_save=0

regards

3 Likes

Also check https://wiki.archlinux.org/index.php/PulseAudio/Troubleshooting#Pops_when_starting_and_stopping_playback

1 Like

An ugly workaround might be to install an app like caffeine that may prevent this from happening. Again, not a proper fix, just an ugly workaround if you have no luck fixing things with a proper configuration file.

1 Like

LOL, wouldn't you just know, there's a proper way. :wink:

Thanks, @jonathon :slight_smile:

3 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.