How to install Kite -

I tried to install Kite from octopi and it creates a file in opt/kite/kite-installer
Now how to install kite and configure it to auto-start when login

Currently using Dragonised Version
System: Kernel: 5.14.5-zen2-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=88596ace-f689-4256-b1c5-422752fc3e40 rw [email protected] quiet splash
rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1
resume=UUID=7b78837c-3fa0-452e-971a-929158ca0b41 loglevel=3
Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux

A comment in the AUR says: the actual Kite can be installed via /opt/kite/kite-installer install

1 Like

I tried this also, but didn't work

Any specific error message?

╭─[email protected] in /opt/kite🔒 took 62ms
 ╰─λ /opt/kite/kite-installer install
[installer] no previous kite installation found
[installer] unable to retrieve version information for kite. please make sure that linux.kite.com is reachable
[installer] error: unexpected http status code: 403
[installer] Rolling back installed data...
[installer] removing kite-autostart systemd service
[installer] terminating kite processes
[installer] removing kite-updater systemd service
[installer] removed ~/.local/share/kite

Looks like a network issue or, more likely, a problem with the site. You are getting a 403 error when you are are accessing linux.kite.com

2 Likes

Maybe check here, there seems to be also an installer that can be downloaded from their website.

1 Like

That is all the AUR package does. It downloads the installer from the site.

I suppose it is possible the AUR version is out-of-date but I haven't checked.

3 Likes

I tried wget, but it also didn't work

What error did you get?

I just tested it for you. The AUR package is, indeed, out-of-date.

I was able to download the latest from their site and install it without issue.

6 Likes

how did you install it..

wget https://linux.kite.com/dls/linux/current
bash current
3 Likes
 ╭─[email protected] in ~
 ╰─λ wget https://linux.kite.com/dls/linux/current
--2021-09-18 20:44:57--  https://linux.kite.com/dls/linux/current
SSL_INIT
Loaded CA certificate '/etc/ssl/certs/ca-certificates.crt'
Resolving linux.kite.com (linux.kite.com)... 34.98.96.51
Connecting to linux.kite.com (linux.kite.com)|34.98.96.51|:443... connected.
HTTP request sent, awaiting response... 303 See Other
Location: https://kitedownloadss.b-cdn.net/linux/2.20210610.0/kite-installer.sh [following]
--2021-09-18 20:44:57--  https://kitedownloadss.b-cdn.net/linux/2.20210610.0/kite-installer.sh
SSL_INIT
Resolving kitedownloadss.b-cdn.net (kitedownloadss.b-cdn.net)... 138.199.24.209
Connecting to kitedownloadss.b-cdn.net (kitedownloadss.b-cdn.net)|138.199.24.209|:443... connected.
HTTP request sent, awaiting response... 403 Forbidden
2021-09-18 20:44:59 ERROR 403: Forbidden.

Maybe you can try from their Dropbox.
Please try downloading kite-installer from Dropbox and then running the commands:

bash kite-installer.sh --download
bash kite-installer.sh --install

3 Likes

Visit

https://linux.kite.com/dls/linux/current

in browser. It should automatically download it. Then proceed.

EDIT:
Official website says it is not available for download

I would suggest contacting them.

EDIT(2):

Why don't you install kite from IDE itself? It installs on VS Code, intellij, PyCharm etc. It seems to be best workaround right now.

2 Likes

you need kite for development in which language? If its Python then 'Jedi' done auto-completion work out of the box, no need of kite. I am using Vim for python development using pre-configured .vimrc file. Here is screenshot, with Jedi auto-completion.

2 Likes

Kite isn't just autocomplete, but a more full predictive coding engine. I didn't find it that useful, but I can see why it's growing in popularity.

2 Likes

I know that the kite is not just auto-complete it uses AI to suggest predictive words. But I believe that AI no doubt gives you speed in writing code but killing his or her learning ability.

So I like simple auto-complete in which you have to write one or two letter to complete whole word.

2 Likes