How to instal Play Store apps on Garuda?

Hello to all.
I would like to run a Play Store application inside Garuda. Is there a way to install Google Play Store and safely to run an app, without constrains or been blocked by Google or same app?.
Thanks in advance.
Regards
joejac

There are several virtual solutions available (eg. Genymotion & Anbox). Also there is Android-x86.
Might want to look at the Archwiki pages and do some research :grin:

3 Likes

See also:

https://wiki.archlinux.org/index.php/Android#Use_Android_on_GNU/Linux

Also keep in mind that none of these options are developed by Garuda and therefore Garuda does not provide technical support for their use (or issues you cause by installing them).

4 Likes

Thanks @dr460nf1r3 and @jonathon

  1. Genymotion did not work for me.
  2. Bliss in nice but does not have Play Store and Whatsapp does not work for this reason, I tried and Whatsapp, after installation, it detected that Play Store is not installed and stopped working.
    Bliss OS no Google Play Services | XDA Developers Forums

We clearly state in the Bliss OS thread that Google Play Store is not available and that Bliss OS only comes with FDroid & microG.

  1. Anbox did not work, white screen.
  2. VM with Android-x86 worked but with some limitations :frowning:
  3. VM with Phoenix OS worked but with strong limitations not been able to add new contacts on Whatsapp.
  4. VM with Cr OS is rejected by Google on login into de Play Store, it uses Chromium browser:

You can't access - This browser or the app may not be secure.

  1. Nerveware’s Cloudready does not run the Play Store.
  2. Archon Chrome extension is too old and does not work.
  3. I have tested different extension on different browsers and they does not have all the features and requires to have the phone always connected, Whatsapp nonsense force to have the phone always on and with wifi connection or a data plan.
    Regards
    joejac

What about using Fdroid.

Anbox works for some on Garuda using it in a portable format.

2 Likes

Hello @tbg I used Bliss 11.12 and with the store it has, I do not remember the name of the store I deleted the VM, I was able to install Whatsapp but it refused to run because it did not find the Google Play Store. I installed Android-x86 on VM and have Whatsapp there working with some limitations. And one hour ago I found a video where the youtuber posted the link to download Prime OS, that he was able to run. I am going to test Whatsapp on Prime OS, but I am not going to use Prime OS due to its web page is not available, probably abandoned.
Regards
joejac

1 Like

Theoretically it might work this way, given you have the stuff available:
If you have a rooted phone try running a backup and restore it in the vm if it has root rights (anbox does)
I know this problem myself quite well and was able to run Whatsapp with microG this way (not in the vm, but android without play services)

1 Like

Hello thanks @dr460nf1r3 I did not know about microG. I tried to enter in their website but got:

https://microg.org/ The connection has timed out An error occurred during a connection to microg.org. PR_IO_TIMEOUT_ERROR

A few minutes ago I installed Prime OS on Virtualbox, it is a clone of Android 7, it is easy to install and it is a breath to work with it and it is a beautiful OS, developed for desktops, and Whatsapp runs, I do not know how well, I did not want to drop the Android-x86 that is Android 9. But Prime OS looks much better and easier on desktop, unfortunately their web page is not available. Attached a screen capture. Any one interested, this is the video with the files to download, it is in Spanish 💻 Como instalar Android en PC sin UEFI - YouTube

2 Likes

Another interesting link, just in case someone need this type of solution:

2 Likes