How to enable gkt module on garuda linux Kde dragonized

I have installed Unity on my Garuda Kde dragonized edition and then all the menu were grayed out after asking on many websites I came to know that downloading appmenu-gkt-module will fix that and it did. But after rebooting my PC I saw that it again disabled. I tryed reinstalling appmenu-gtk-module and all the possible of rebooting installing but it didnt work. I think my gtk module is not enabled how can I do that?

There is nothing like enabling or disabling it.
This is what works for me. (workaround)
I'm using Manjaro KDE
.
You can try either "Disable global appmenu in gtk app" or "Blacklist appmenu-gtk-module in UnityEditor":
.
To disable global app menu in gtk app:

  • just remove 'appmenu-gtk-module' package
    (all gtk app will not have a global menu for now...)
    .
    To blacklist appmenu-gtk-module in UnityEditor:
  • you can use either gsetting or dconf-editor (I use dconf-editor).
    in the 'org.appmenu.gtk-module' append the blacklist string "Unity" (found by xprop)
    (Toggle 'Use default value' to off, if you use dconf-editor)
    (This way, other gtk app will have a normal global app menu (except the app in the blacklist) as you can see in the image. transmission-gtk works fine)
    .
3 Likes

I know that you have copied from google, but that didnot workk for me

What do you want me to do? Produce it?

You do realize your kind of behavior is frowned upon and I am a volunteer if I want to help I will its upto me so you better accept the help or just stay shut if you think you are self sufficient and don't need our help if that's the case please don't create topics as 5 out 6 of your topics were solved by you.
Regards

2 Likes

I don't know if there is any language barrier or whatever, but I do agree that this comes across quite rude. Even if you did research yourself and stuff did not work out its a good idea to list things you tried already to not waste time of our voluntary supporters here in the forum. Just imagine it was the other way round and you provided support to someone else. I'm sure that you would be frustrated as well by such an answer :eyes:

Anyway, since this is limited to Unity only (and being a known issue in this forum since some time now) its fair to say that we can't provide support for this application. The right way would probably be to report this at the Unity forum so they fix their application instead of cluttering this forum with multiple threads related to this issue.

5 Likes

Unsupported Software, known bug.
Closed.