How to Disable Xbox Controller emulation for DualShock 4?

Hello. I use DualShock 4 and it works badly, in every game the system is emulating XBOX controller, even if the game supports DualShock4 (I check it on Windows). It is not convenient when you played for 4 years on DualShock and you need to re-learn the location of the buttons. And also some buttons stopped working correctly or do not work at all.
It is strange, but Steam Big Picture recognizes it as DualShock, but even there is no PS icons: square, triangle, circle and cross. Instead of them just a black spot.
How can I do so that the system and games do not emulate xbox, and normally perceived DualShock?

You are experiencing this because of Steam's controller settings. You can easily toggle off the support if you don't want it to be wrapped in Steam's "Steam input" that outputs as an xbox-style controller. HOWEVER, If you are just worried about GUI buttons icons.. sorry but even if you change it, most games don't have PS4 button UI options. Just going to be upfront about that.

If you want to shut off "steam input" for everything ( although I do not recommended this because some games lack native ps4 controller support), the option is in (Steam) Settings > Controller > General Controller Settings > then uncheck the box for ps4 controllers.

If you just want to shut off "steam input" for a certain game instead, right click the game in Steam > Properties > Controller > Disable Steam Input (drop-down option under OVERRIDE)

1 Like

Thanks for the advice, but the main problem is precisely the icons, besides most of the games are not in steam. It seems to me, that the problem is in some driver in the system that emulates xbox.

what game(s)? Like I've said before, MOST games DO NOT have UI buttons for PS4, and changing anything will not fix that as its a game developer side issue.

Also, I have already stated what you were experiencing was Steam Input. All this information is already easily searchable via the arch wiki and steam forums.
From Gamepad - ArchWiki "PlayStation 3/4 controller

The DualShock 3, DualShock 4 and Sixaxis controllers work out of the box when plugged in via USB (the PS button will need to be pushed to begin). They can also be used wirelessly via Bluetooth.

Steam properly recognizes it as a PS3 pad and Big Picture can be launched with the PS button. Big Picture and some games may act as if it was a 360 controller."

1 Like

For example Witcher 3 (from Steam), Detroid become human, death stranding and other games worked on windows 10 with normal PS icons and button bindings. It is very strange that they all work as on xbox, from this I conclude that the system forcibly emulates xbox.

If you want help, first thing you need to do is listen and search. If somehow you don't believe me or the arch wiki, I don't think I can help you anymore.

.... I am going to try one last time though, and I am going to put it in a way that should be 100% clear. Just be sure to read it this time.

Steam does the Steam Input (not the system by default). the arch wiki says steam picks it up as a playstation controller and then uses Steam Input. I use a ps4 controller myself...

Now, if your games from steam are having issues displaying PS icons that they normally should be doing just fine; then the game most likely has native playstation controller support. Turn off the Steam Input per that game as I have listed above and it should work fine. Other games have Playstation button icon display in the game options (though rarely).
If somehow none of this works but it should be showing PS buttons as the game does support displaying it, try and see if force running the game with Proton-GE support fixes it as regular Proton sometimes has issues with devices. Toggling between Proton or Proton-GE per game is good practice in general as it can be a better gamepad experience with one Proton over the other depending on the game.

I didn’t say that I don’t believe you or archwik. it's just that these games supported ps buttons on windows, but do not work on linux, I don't understand why. And since the games not only do not work, but emulate xbox, i think there may be a problem in the os software. If this is not true, please explain me, whats wrong.

read my edit.

Dude, I'm sorry, but it doesn't work ... I did everything as you said, but nothing changes

Since you said some buttons aren't working in your opening post:

Are your using an official playstation 4 controller?

Was it the same controller you tried with windows?

Is it plugged directly into a motherboard's USB? If so, try a different USB on the motherboard and a different USB cord.

If none of that works possibly the controller is broken is some way so test another PS4 controller that you know for sure works just in case if you can.

Yes, I am using the official playstation 4 controller

Yes, it was the same controller that i use in windows

The controller is working properly, the buttons do not work due to problems with emulation, for example, in detroit become, I can open compass mode with some probability, but I can’t get out of it at all. Similar problems in other games too

what buttons do not work? Are you running it via USB?

Detroit Become Human should show PS icons if the gamepad is plugged in (not wireless) to a USB and Steam Input per that game is shut off ( source: PS4 controller :: Detroit: Become Human General Discussions )

Witcher 3 can have issues displaying PS icons. Yet again the controller has to be wired via USB for it to work right (and have steam input off yet again per game of course). If there is an issue still with it, a work around was posted a few years ago here on post #9 might help: PS4 Controller Button Prompts in Witcher 3 :: The Witcher 3: Wild Hunt General Discussions

Hi. I solved the problem. Before that, I ran games through steam and lutris, today I tried to launch games through PortProton and everything works fine, the games understand that this is Dualshok and the buttons work fine, thanks for the help.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.