How to disable the BEEP when I logout and for other commands?

I understand the censorship of my previous post ( logout/36991/), but I think a right to reply was useful and necessary.

In response to BluishHumility, who responded to my censored post:

Sorry. I recognize my mistake regarding the tone. But I didn’t insult anyone. I was stressed because, after the first installation of Garuda, the system did not work properly. I had to reinstall it and, subsequently, for reasons that do not find their place in this post, my external hard drive --that I use for storing my documents-- was no longer readable. I got it back up and running thanks to Testdisk.
Thank you for your help or attempt to help. I will follow your instructions, but I have not found the solution. On the contrary, the problem has increased: now both Thunderbird (for the new mail) and other programs like Firefox (for the unsolved search) notify with a beep.
To imagine the frustration of the time wasted looking for the solution for a “little” problem like this, I want to quote the reflection of another person who encountered the same problem (quote from one of the posts you linked in response to my censured post):
“I’ve used search & google, I’ve tried the old way of ‘blacklist pcspkr’ in /etc/modprobe.d/blacklist, Ive tried !pcspkr !snd_pcsp in /etc/rc.conf, I’ve even tried the deprecated method of MOD_BLACKLIST=(pcspkr), and still I have the system beep driving me crazy ! At the moment I’m just using rmmod pcspkr to kill it every time I login, but I want to kill it stone dead, permanently.” ((SOLVED) System Beep / Newbie Corner / Arch Linux Forums)
The solution to the problem is not the same for every device and distro used. This is what I deduced from reading the posts and testing the suggestions, also for the ones I had already searched for and read for hours and the ones you linked to me.

so what you are saying is a beep bugs you :rofl:

As this is a new post can you provide your


as per the forum template

Thank you


Yes, all the time and for many applications and commands.


  Kernel: 6.6.31-2-lts arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
    clocksource: tsc avail: acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-linux-lts
    root=UUID=85d3adfb-b865-49a6-8b52-13ff6b101c79 rw loglevel=3 ibt=off
  Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 wm: xfwm4 v: 4.18.0
    with: plank,xfce4-panel tools: xfce4-screensaver avail: i3lock,xautolock
    vt: 7 dm: LightDM v: 1.32.0 Distro: Garuda base: Arch Linux
  Type: Laptop System: LENOVO product: 82H9 v: IdeaPad 3 17ITL6
    serial: <superuser required> Chassis: type: 10 v: IdeaPad 3 17ITL6
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0T76465 WIN
    serial: <superuser required> part-nu: LENOVO_MT_82H9_BU_idea_FM_IdeaPad 3
    17ITL6 uuid: <superuser required> UEFI: LENOVO v: GGCN54WW
    date: 03/10/2023
  ID-1: BAT0 charge: 43.6 Wh (95.0%) condition: 45.9/45.0 Wh (102.0%)
    volts: 12.1 min: 11.1 model: LGC L20L3PF0 type: Li-poly serial: <filter>
    status: not charging cycles: 26
  Info: model: 11th Gen Intel Core i3-1115G4 bits: 64 type: MT MCP
    arch: Tiger Lake gen: core 11 level: v4 note: check built: 2020
    process: Intel 10nm family: 6 model-id: 0x8C (140) stepping: 2
    microcode: 0x36
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 160 KiB desc: d-2x48 KiB; i-2x32 KiB L2: 2.5 MiB desc: 2x1.2 MiB
    L3: 6 MiB desc: 1x6 MiB
  Speed (MHz): avg: 658 high: 1023 min/max: 400/4100 scaling:
    driver: intel_pstate governor: powersave cores: 1: 1023 2: 400 3: 812 4: 400
    bogomips: 23968
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
  Device-1: Intel Tiger Lake-LP GT2 [UHD Graphics G4] vendor: Lenovo
    driver: i915 v: kernel arch: Gen-12.1 process: Intel 10nm built: 2020-21
    ports: active: eDP-1 empty: HDMI-A-1 bus-ID: 0000:00:02.0
    chip-ID: 8086:9a78 class-ID: 0300
  Device-2: Bison Integrated Camera driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-5:3 chip-ID: 5986:212b
    class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.13 compositor: xfwm4 v: 4.18.0 driver:
    X: loaded: modesetting alternate: fbdev,intel,vesa dri: iris gpu: i915
    display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1600x900 s-dpi: 96 s-size: 423x238mm (16.65x9.37")
    s-diag: 485mm (19.11")
  Monitor-1: eDP-1 model: BOE Display 0x08e4 built: 2019 res: 1600x900
    hz: 60 dpi: 106 gamma: 1.2 size: 382x215mm (15.04x8.46") diag: 438mm (17.3")
    ratio: 16:9 modes: 1600x900
  API: Vulkan v: 1.3.279 layers: 5 device: 0 type: integrated-gpu name: Intel
    UHD Graphics (TGL GT2) driver: mesa intel v: 24.0.8-arch1.1
    device-ID: 8086:9a78 surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe
    (LLVM 17.0.6 256 bits) driver: mesa llvmpipe v: 24.0.8-arch1.1 (LLVM
    17.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
  API: OpenGL Message: Unable to show GL data. glxinfo is missing.
  Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Lenovo
    driver: sof-audio-pci-intel-tgl
    alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 0000:00:1f.3
    chip-ID: 8086:a0c8 class-ID: 0401
  API: ALSA v: k6.6.31-2-lts status: kernel-api tools: N/A
  Server-1: PipeWire v: 1.0.7 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi v: kernel bus-ID: 0000:00:14.3
    chip-ID: 8086:a0f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  Info: services: NetworkManager, systemd-timesyncd, wpa_supplicant
  Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-10:5 chip-ID: 8087:0026
    class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 2 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: <filter> bt-v: 5.2 lmp-v: 11
    status: discoverable: no pairing: no
  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
    v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:9a0b rev: class-ID: 0104
  Local Storage: total: 529.52 GiB used: 168.28 GiB (31.8%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Lenovo
    model: UMIS RPJYJ256RDM1QWY size: 238.47 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: 1.0L0521 temp: 40.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 850 EVO 250GB
    size: 232.89 GiB block-size: physical: 4096 B logical: 512 B type: USB
    rev: 3.0 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 tech: SSD serial: <filter>
    fw-rev: 0301 scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 vendor: Toshiba model: TransMemory
    size: 58.16 GiB block-size: physical: 512 B logical: 512 B type: USB
    rev: 2.0 spd: 480 Mb/s lanes: 1 mode: 2.0 tech: N/A serial: <filter>
    fw-rev: PMAP scheme: MBR
  ID-1: / raw-size: 120.36 GiB size: 117.91 GiB (97.97%)
    used: 17.04 GiB (14.5%) fs: ext4 dev: /dev/nvme0n1p4 maj-min: 259:4
  ID-2: /boot/efi raw-size: 540 MiB size: 538.9 MiB (99.80%)
    used: 296 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 7.55 GiB used: 0 KiB (0.0%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4 dev: /dev/zram0
  ID-2: swap-2 type: partition size: 9.34 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p6 maj-min: 259:5
  System Temperatures: cpu: 35.0 C mobo: N/A
  Fan Speeds (rpm): N/A
  Memory: total: 8 GiB note: est. available: 7.55 GiB used: 3.75 GiB (49.7%)
  Processes: 241 Power: uptime: 20m states: freeze,mem,disk suspend: s2idle
    wakeups: 0 hibernate: platform avail: shutdown, reboot, suspend, test_resume
    image: 3.01 GiB services: upowerd,xfce4-power-manager Init: systemd v: 255
    default: graphical tool: systemctl
  Packages: pm: pacman pkgs: 1361 libs: 437 tools: gnome-software,pamac,paru
    Compilers: gcc: 14.1.1 Shell: garuda-inxi default: fish v: 3.7.1
    running-in: xfce4-terminal inxi: 3.3.34
Garuda (2.6.26-1):
  System install date:     2024-05-23
  Last full system update: 2024-05-25
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       No/Undetected
  Failed units:            snapper-cleanup.service

Does this command show any output?

lsmod | grep pcspkr

Output is 🔴ERROR

But I have a new problem: when I try to log in my user account, the desktop background is black and the windows of some application, like the file manager, work improperly.
I have logged in recovery mode like root and when I try in the console:
sudo su - user
I receive this message:
xset: unable to open display ""

I think I have made a bad manipulation in Sessions an Startup in trying to eliminate the beep.

Now the problem is too much big and it takes too much time to be resolved. I think that the only alternative is a reinstallation.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.