How to Disable Discrete Graphics Card

Radeon Discrete graphics card is faulty and was causing lines on screen,

I have disabled discrete graohic card in grub (see below) and enabled integrated Intel graphics card. Is this the correct way of doing this?

sudo gedit /etc/default/grub

This will ask you for your user account password to get admin privileges. Enter it and when the file opens search for the line

GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash“

and change it to

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.lvds_channel_mode=2 i915.modeset=1 i915.lvds_use_ssc=0"

Once this change is made, check for errors then save and exit.

Next we’ll run another command in the Terminal

sudo gedit /etc/grub.d/10_linux

Again, enter your password if asked and when the file opens find the line

echo "	insmod gzio" | sed "s/^/$submenu_indentation/"

And place the following immediately before this line:

echo "	outb 0x728 1" | sed "s/^/$submenu_indentation/"
echo "	outb 0x710 2" | sed "s/^/$submenu_indentation/"
echo "	outb 0x740 2" | sed "s/^/$submenu_indentation/"
echo "	outb 0x750 0" | sed "s/^/$submenu_indentation/"

Check to make sure that everything is correct and save, then exit gedit once more.

Finally run

sudo update-grub

There is no correct or incorrect way, if this succeeds.
Ask the person that gave you this advice if this will succeed. I have no idea.
In fact, this method alters system important files and packages, which is the last thing you should do. It's a very dirty hack and should not be done with a simple copy/paste commands from the web.

The official way is this
https://wiki.archlinux.org/index.php/Hybrid_graphics#Using_acpi_call

3 Likes

Many thanks for you help and advice.

The grub method was taken rom oficial ubuntu docs MacBookPro8-2/Raring - Community Help Wiki has worked as the the screen flicker and lines have stopped and also the fans are no longer loud.

When I run the following command, I can no longer see the AMD Radeon card:

lspci -vnnn | perl -lne 'print if /^\d+:.+([\S+:\S+])/' | grep VGA

00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0126] (rev 09) (prog-if 00 [VGA controller])

I cannot seem to get the acpi_call to disable the discrete graphics card!

Perhaps check the Arch wiki for this laptop and see what documentation is available for a distribution that matches more closely the one you are running?

2 Likes