How to disable blanking screen on lxqt-kwin please help

Hello.

I hope I understand what you say here on this message, I copy and paste the whole console:
[email protected]
OS: Garuda Linux x86_64
Kernel: 5.15.11-zen1-1-zen
Uptime: 3 hours, 11 mins
Packages: 1396 (pacman)
Shell: bash 5.1.12
Resolution: 1280x1024
DE: LXQt 1.0.0
WM: KWin
Theme: Ant-Dracula [GTK2/3]
Icons: NeonIcons [GTK2/3]
Terminal: alacritty
Terminal Font: Source Code Pro
CPU: Intel Core 2 6300 (2) @ 1.862GHz
GPU: NVIDIA GeForce 210
GPU: Intel 82Q963/Q965
Memory: 1704MiB / 3848MiB

If anyone can help me disable the 5-10 min screen blanking in the terminal or in DE I would appreciate it alot, it's very annoying when I play on retro arch any game every 5-10 minute the screen goes blank and i have disabled all of the settings in power management and where i could find anything on idle or idling or screen or monitor settings. Please help, even if I need to disable it in terminal that I will do so.

No, how do you test DE's?

Post your terminal/konsole in- and output as text (no pictures) from:

inxi -Faz

Did you check the system settings, display configs or Garuda assistant / tweaks?

1 Like

System:
Kernel: 5.15.11-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=53c97b4a-d326-4992-9ca4-f30ba022f86d rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: LXQt 1.0.0 tk: Qt 5.15.2 info: cairo-dock, lxqt-panel
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: Intel model: DQ965GF v: AAD41676-305
serial: BIOS: Intel
v: CO96510J.86A.6100.2009.1004.2331 date: 10/04/2009
Battery:
Device-1: sony_controller_battery_00:06:f7:62:63:6b model: N/A serial: N/A
charge: N/A status: N/A
CPU:
Info: model: Intel Core2 6300 bits: 64 type: MCP arch: Core Merom family: 6
model-id: 0xF (15) stepping: 6 microcode: 0xD0
Topology: cpus: 1x cores: 2 smt: cache: L1: 128 KiB
desc: d-2x32 KiB; i-2x32 KiB L2: 2 MiB desc: 1x2 MiB
Speed (MHz): avg: 1613 high: 1628 min/max: 1596/1862 scaling:
driver: acpi-cpufreq governor: performance cores: 1: 1628 2: 1598
bogomips: 7458
Flags: ht lm nx pae sse sse2 sse3 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: EPT disabled
Type: mds
status: Vulnerable: Clear CPU buffers attempted, no microcode; SMT disabled
Type: meltdown mitigation: PTI
Type: spec_store_bypass status: Vulnerable
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full generic retpoline, STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel 82Q963/Q965 Integrated Graphics driver: i915 v: kernel
bus-ID: 00:02.0 chip-ID: 8086:2992 class-ID: 0380
Device-2: NVIDIA GT218 [GeForce 210] vendor: Gigabyte driver: nouveau
v: kernel bus-ID: 01:00.0 chip-ID: 10de:0a65 class-ID: 0300
Display: x11 server: X.Org 1.21.1.2 compositor: kwin_x11 driver:
loaded: modesetting,nouveau alternate: fbdev,intel,nv,vesa display-ID: :0
screens: 1
Screen-1: 0 s-res: 1280x1024 s-dpi: 96 s-size: 337x270mm (13.3x10.6")
s-diag: 432mm (17")
Monitor-1: VGA-1 res: 1280x1024 hz: 60 dpi: 105
size: 310x230mm (12.2x9.1") diag: 386mm (15.2")
Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
Device-1: Intel 82801H HD Audio driver: snd_hda_intel v: kernel
bus-ID: 00:1b.0 chip-ID: 8086:284b class-ID: 0403
Device-2: NVIDIA High Definition Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:0be3
class-ID: 0403
Sound Server-1: ALSA v: k5.15.11-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.42 running: yes
Network:
Device-1: Intel 82566DM Gigabit Network driver: e1000e v: kernel port: 30c0
bus-ID: 00:19.0 chip-ID: 8086:104a class-ID: 0200
IF: enp0s25 state: up speed: 1000 Mbps duplex: full mac:
Bluetooth:
Device-1: Bluetooth Device Bluetooth Device type: USB driver: btusb v: 0.8
bus-ID: 4-1:2 chip-ID: 0c10:0000 class-ID: e001 serial:
Report: bt-adapter ID: hci0 rfk-id: 0 state: down
bt-service: enabled,running rfk-block: hardware: no software: no
address:
Drives:
Local Storage: total: 465.77 GiB used: 14.29 GiB (3.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Hitachi model: HCS725025VLAT80
size: 232.88 GiB block-size: physical: 512 B logical: 512 B
speed: type: N/A serial: rev: A4NA scheme: MBR
ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST3250310AS
size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 1.5 Gb/s
type: N/A serial: rev: A scheme: MBR
Partition:
ID-1: / raw-size: 232.88 GiB size: 232.88 GiB (100.00%)
used: 14.29 GiB (6.1%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
ID-2: /home raw-size: 232.88 GiB size: 232.88 GiB (100.00%)
used: 14.29 GiB (6.1%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
ID-3: /var/log raw-size: 232.88 GiB size: 232.88 GiB (100.00%)
used: 14.29 GiB (6.1%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
ID-4: /var/tmp raw-size: 232.88 GiB size: 232.88 GiB (100.00%)
used: 14.29 GiB (6.1%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 3.76 GiB used: 257 MiB (6.7%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 57.0 C mobo: N/A gpu: nouveau temp: 52.0 C
Fan Speeds (RPM): N/A
Info:
Processes: 187 Uptime: 17m wakeups: 1 Memory: 3.76 GiB
used: 1.5 GiB (39.8%) Init: systemd v: 249 tool: systemctl Compilers:
gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1400 lib: 450 Shell: Bash
v: 5.1.12 running-in: qterminal inxi: 3.3.11

I hope this help? This is what i get for the in- and output. I can't really see where the screen blanking lays. But I hope this will help to help me to disable it.

also in DE :wink: Poste bitte deine Terminal Outputs vor 3 Tilden und danach auch 3 Tilden um es als Code Output zu markieren und in einem schönen Format wiederzugeben

Tilde = ~

also

Code

Right, just edit your post How to disable blanking screen on lxqt-kwin please help - #3 by das
:slight_smile:

Did you search for Lxqt-kwin manual?

1 Like

Go to 'lxqt settings' which is under 'preferences'..In lxqt settings go to power management settings..then select idle tab..in that idle tab you can change idle time action to nothing or turn off screen..suspend ...etc

2 Likes