How to disable "ALT" navigation function

Hello.

When I hold the "ALT" key, there will be a white line under some letters of each options in the menu bar.

I know it can be really helpful when navigating menu's options but sometimes it conficts with other software's keymap, so is there any way to turn it off? Thanks in advance.

System:
Kernel: 5.16.16-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=95dc98c4-2ec4-4fc4-bbaa-642a90082b50 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
Desktop: KDE Plasma 5.24.3 tk: Qt 5.15.3 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: Micro-Star model: MEG B550 UNIFY-X (MS-7D13) v: 2.0
serial: <superuser required> UEFI: American Megatrends LLC. v: A.40
date: 12/17/2021
CPU:
Info: model: AMD Ryzen 9 5900X bits: 64 type: MT MCP arch: Zen 3
family: 0x19 (25) model-id: 0x21 (33) stepping: 0 microcode: 0xA201016
Topology: cpus: 1x cores: 12 tpc: 2 threads: 24 smt: enabled cache:
L1: 768 KiB desc: d-12x32 KiB; i-12x32 KiB L2: 6 MiB desc: 12x512 KiB
L3: 64 MiB desc: 2x32 MiB
Speed (MHz): avg: 3605 high: 3806 min/max: 2200/4950 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3625 2: 3595
3: 3589 4: 3594 5: 3597 6: 3594 7: 3591 8: 3598 9: 3597 10: 3599 11: 3597
12: 3591 13: 3593 14: 3595 15: 3599 16: 3599 17: 3593 18: 3598 19: 3596
20: 3598 21: 3599 22: 3599 23: 3598 24: 3806 bogomips: 177602
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: always-on, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Navi 23 [Radeon RX 6600/6600 XT/6600M] vendor: Sapphire
driver: amdgpu v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 ports:
active: DP-2,HDMI-A-1 empty: DP-1,DP-3 bus-ID: 2d:00.0 chip-ID: 1002:73ff
class-ID: 0300
Display: x11 server: X.Org v: 1.21.1.3 compositor: kwin_x11 driver: X:
loaded: amdgpu,ati unloaded: modesetting,radeon alternate: fbdev,vesa
gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 5280x2560 s-dpi: 96 s-size: 1395x676mm (54.9x26.6")
s-diag: 1550mm (61")
Monitor-1: DisplayPort-1 mapped: DP-2 pos: primary,right
model: LG (GoldStar) HDR 4K serial: <filter> built: 2021 res: 3840x2160
hz: 60 dpi: 140 gamma: 1.2 size: 697x392mm (27.4x15.4")
diag: 806mm (31.7") ratio: 16:9 modes: max: 3840x2160 min: 640x480
Monitor-2: HDMI-A-0 mapped: HDMI-A-1 pos: primary,left
model: Dell S2721DGF serial: <filter> built: 2021 res: 1440x2560 dpi: 109
gamma: 1.2 size: 336x597mm (13.2x23.5") diag: 685mm (27") ratio: 16:9
modes: max: 2560x1440 min: 720x400
OpenGL: renderer: AMD Radeon RX 6600 XT (DIMGREY_CAVEFISH DRM 3.44.0
5.16.16-zen1-1-zen LLVM 13.0.1)
v: 4.6 Mesa 21.3.7 direct render: Yes
Audio:
Device-1: AMD Navi 21 HDMI Audio [Radeon RX 6800/6800 XT / 6900 XT]
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 2d:00.1 chip-ID: 1002:ab28 class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 2f:00.4 chip-ID: 1022:1487 class-ID: 0403
Sound Server-1: ALSA v: k5.16.16-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.48 running: yes
Network:
Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
speed: 5 GT/s lanes: 1 bus-ID: 29:00.0 chip-ID: 8086:2723 class-ID: 0280
IF: wlo1 state: up mac: <filter>
Device-2: Realtek RTL8125 2.5GbE vendor: Micro-Star MSI driver: r8169
v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 port: f000 bus-ID: 2a:00.0
chip-ID: 10ec:8125 class-ID: 0200
IF: enp42s0 state: down mac: <filter>
Drives:
Local Storage: total: 4.34 TiB used: 35.54 GiB (0.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 model: T-FORCE TM8FP7001T
size: 931.51 GiB block-size: physical: 512 B logical: 512 B
speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter> rev: EGFM13.0
temp: 32.9 C scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:8 vendor: Smart Modular Tech.
model: SHGP31-2000GM size: 1.82 TiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 31060C20 temp: 38.9 C scheme: GPT
ID-3: /dev/nvme2n1 maj-min: 259:5 vendor: SanDisk
model: Extreme Pro 500GB size: 465.76 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 101200RL temp: 36.9 C scheme: GPT
ID-4: /dev/sda maj-min: 8:0 model: SATA SSD size: 223.57 GiB block-size:
physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter>
rev: BB.3 scheme: GPT
ID-5: /dev/sdb maj-min: 8:16 vendor: Crucial model: CT1000MX500SSD1
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 043 scheme: GPT
ID-6: /dev/sdc maj-min: 8:32 type: USB vendor: Kingston
model: DataTraveler 2.0 size: 28.84 GiB block-size: physical: 512 B
logical: 512 B type: N/A serial: <filter> rev: PMAP scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
ID-1: / raw-size: 710.61 GiB size: 710.61 GiB (100.00%)
used: 35.45 GiB (5.0%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
ID-2: /boot/efi raw-size: 901 MiB size: 897 MiB (99.56%)
used: 92 MiB (10.3%) fs: vfat dev: /dev/nvme0n1p3 maj-min: 259:3
ID-3: /home raw-size: 710.61 GiB size: 710.61 GiB (100.00%)
used: 35.45 GiB (5.0%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
ID-4: /var/log raw-size: 710.61 GiB size: 710.61 GiB (100.00%)
used: 35.45 GiB (5.0%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
ID-5: /var/tmp raw-size: 710.61 GiB size: 710.61 GiB (100.00%)
used: 35.45 GiB (5.0%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.33 GiB used: 2.5 MiB (0.0%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 50.0 C
mem: 52.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
Info:
Processes: 493 Uptime: 4h 21m wakeups: 0 Memory: 31.33 GiB
used: 9.65 GiB (30.8%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 1472 lib: 427 Shell: fish
v: 3.3.1 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.13
Garuda (2.5.6-2):
System install date:     2022-03-15
Last full system update: 2022-03-24 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:            bluetooth-autoconnect.service

Welcome :slight_smile:

With some programmes the underscores are always visible, with others only with the ALT key, with others nothing happens when you press them.
So ask the programme manufacturer who is interfering with your other functions whether you can turn it off there or check the instructions first to see whether it is possible there.

1 Like

Thanks for answering. But even I was at "System Settings" of Garuda Linux and hold the "ALT" key, some letters still have the underline show below..

System settings of Garuda Linux, or...KDE?

(I'm guessing on DE because no garuda-inxi).

xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

Sorry... just attached the garuda-inxi.

And yes I'm using KDE-plasma.

We are not psychics, something like that belongs in the first post.

We got no answer for this question.

Could you now describe which (other) programme(s) this disturbs?

Have you checked the shortcuts in the KDE settings?

Honestly I do not see a simple way to disable this feature.

Can you give an example of this? I am just having a hard time imagining any possible situation where this could interfere...with anything. It's not actually doing anything, just the letter shows up with an underline.

Are we talking about the same thing?

No Alt:

Holding Alt:

Are you saying a custom shortcut uses Alt and these underline shortcuts in the menu are taking precedence?

2 Likes

Alt key is the most usually assigned key for in-application menus.
When an application has the focus, it controls its shortcuts and they can't conflict inside it.
In order for a conflict to exist, it can only be a system shortcut.
So, unless you explain the exact conflict situation we cannot help.

1 Like

========Sorry forget reply =======

For example when I'm using Webstorm, there's couple shortcuts start with "Alt" like "Alt + Shift+V". And when I hold Alt, there will be underlines show up at the menu bar of each options. In my case "Alt + Shift + V" will open the view of Webstorm from the menu bar instead of its original function.

Yes and this also apply the menu bar of each applications.

not here but the menu bar of each applications

I don't know this program.
Anyway, in order for a conflict, we need two or more applications.
Try to explain exactly the problem. Our magic crystal sphere is currently on vacation. :mage:

1 Like

This is what the Webstorm menu bar looks like without holding any key:

Webstorm File Edit View History

This is what it looks like when holding "Alt" key or "Alt + Shift":

Webstorm File Edit View History
         -    -    -      -

And when I press "Alt" + "Shift" + "V", the system trigger "View" instead of my custom shortcut in Webstorm. I think maybe it's a priority problem...

This is one program. Not more.

If it's only there, you have to ask the application developer for help.

1 Like

Yes it is one. And this one conficts with the system "Alt" feature . That's two then.

We are having difficulty communicating in Linux/computer language.
The system Alt feature is not an application.

Either explain clearly which two shortcuts conflict each other, or we can't help.
Probably closing this topic.

1 Like

The thing I know is holding "Alt" key and underline showed up is a global behavior, don't know if it's from KDE or what..

If I could find out which two shortcuts confict I wouldn't bother to ask...

Still thanks for patience and time.

Not the system, webstorm did.
Edit your custom shortcut.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.