How to connect to home router vpn?

Hello.

I have been trying to figure out how to connect to my home VPN, I can connect with my Phone.
Searched on the forum and google but no dice.

I got a D-Link DIR-890L Router that got vpn function.
It uses L2TP over IPSec

Anyone who got an idea how to do it on linux?

System:    Kernel: 5.15.6-zen2-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=35a20c23-b85f-4735-ba8e-b0d774e44d09
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.23.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:   Type: Laptop System: Micro-Star product: Delta 15 A5EFK v: REV:1.0 serial: <superuser required>
Chassis: type: 10 serial: <superuser required>
Mobo: Micro-Star model: MS-15CK v: REV:1.0 serial: <superuser required>
UEFI: American Megatrends LLC. v: E15CKAMS.103 date: 08/04/2021
Battery:   ID-1: BAT1 charge: 71.3 Wh (90.5%) condition: 78.8/80.3 Wh (98.1%) volts: 16.8 min: 15.2
model: MSI Corp. MS-15CK type: Li-ion serial: N/A status: Unknown
Device-1: hidpp_battery_0 model: Logitech Wireless Gaming Mouse serial: <filter>
charge: 55% (should be ignored) rechargeable: yes status: Discharging
CPU:       Info: 8-Core model: AMD Ryzen 7 5800H with Radeon Graphics bits: 64 type: MT MCP arch: Zen 3
family: 19 (25) model-id: 50 (80) stepping: 0 microcode: A50000C cache: L1: 512 KiB L2: 4 MiB
L3: 16 MiB
flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 102206
Speed: 3377 MHz min/max: 1200/3200 MHz boost: enabled Core speeds (MHz): 1: 3377 2: 3195
3: 3706 4: 2771 5: 3029 6: 3377 7: 3075 8: 2754 9: 3439 10: 3150 11: 3882 12: 2927 13: 3502
14: 3301 15: 3469 16: 3001
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, STIBP: always-on, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: AMD Navi 22 [Radeon RX 6700/6700 XT / 6800M] vendor: Micro-Star MSI driver: amdgpu
v: kernel bus-ID: 03:00.0 chip-ID: 1002:73df class-ID: 0380
Device-2: AMD Cezanne vendor: Micro-Star MSI driver: amdgpu v: kernel bus-ID: 06:00.0
chip-ID: 1002:1638 class-ID: 0300
Display: x11 server: X.Org 1.21.1.1 compositor: kwin_x11 driver: loaded: amdgpu,ati
unloaded: modesetting,radeon alternate: fbdev,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")
Monitor-1: eDP res: 1920x1080 hz: 240 dpi: 142 size: 344x194mm (13.5x7.6") diag: 395mm (15.5")
Monitor-2: HDMI-A-1-0 res: 1920x1080 hz: 60 dpi: 305 size: 160x90mm (6.3x3.5")
diag: 184mm (7.2")
OpenGL: renderer: AMD RENOIR (DRM 3.42.0 5.15.6-zen2-1-zen LLVM 13.0.0) v: 4.6 Mesa 21.2.5
direct render: Yes
Audio:     Device-1: AMD Navi 21 HDMI Audio [Radeon RX 6800/6800 XT / 6900 XT] driver: snd_hda_intel
v: kernel bus-ID: 03:00.1 chip-ID: 1002:ab28 class-ID: 0403
Device-2: AMD vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus-ID: 06:00.1
chip-ID: 1002:1637 class-ID: 0403
Device-3: AMD Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Micro-Star MSI
driver: snd_rn_pci_acp3x v: kernel alternate: snd_pci_acp3x,snd_pci_acp5x bus-ID: 06:00.5
chip-ID: 1022:15e2 class-ID: 0480
Device-4: AMD Family 17h HD Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel
bus-ID: 06:00.6 chip-ID: 1022:15e3 class-ID: 0403
Sound Server-1: ALSA v: k5.15.6-zen2-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Intel Wi-Fi 6 AX210/AX211/AX411 160MHz driver: iwlwifi v: kernel bus-ID: 04:00.0
chip-ID: 8086:2725 class-ID: 0280
IF: wlp4s0 state: up mac: <filter>
Bluetooth: Device-1: Intel AX210 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 3-3:3 chip-ID: 8087:0032
class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:    Local Storage: total: 953.87 GiB used: 136.61 GiB (14.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Micron model: 2210 MTFDHBA1T0QFD size: 953.87 GiB
block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: P6MA001 temp: 41.9 C scheme: GPT
Partition: ID-1: / raw-size: 689 GiB size: 689 GiB (100.00%) used: 91.3 GiB (13.3%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 716 KiB (0.2%) fs: vfat
dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 689 GiB size: 689 GiB (100.00%) used: 91.3 GiB (13.3%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 689 GiB size: 689 GiB (100.00%) used: 91.3 GiB (13.3%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 689 GiB size: 689 GiB (100.00%) used: 91.3 GiB (13.3%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 9.28 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/nvme0n1p7
maj-min: 259:7
ID-2: swap-2 type: zram size: 15.08 GiB used: 2.5 MiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 58.0 C mobo: N/A
Fan Speeds (RPM): N/A
GPU: device: amdgpu temp: 53.0 C device: amdgpu temp: 48.0 C mem: 48.0 C fan: 0 watts: 11.00
Info:      Processes: 395 Uptime: 9m wakeups: 401 Memory: 15.08 GiB used: 3.5 GiB (23.2%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1984 lib: 567
Shell: fish v: 3.3.1 default: Bash v: 5.1.12 running-in: konsole inxi: 3.3.09

Seems whoogle is full of answers

What have you at least tried to do so far?

1 Like

I have tried to connect to my VPN with OpenVPN, that went really Advanced really fast, way out of my league, tried to see if there is something in Connections in system settings, there is Add New Connection, that killed my network, probably because I did something wrong, and the link you posted is also one of the ones I found, and yes, there is an abundant amount of VPN guides, but none that can help me with my routers VPN.

https://wiki.archlinux.org/title/Openswan_L2TP/IPsec_VPN_client_setup

5 Likes

Those that got some relevance to me are:
https://eu.dlink.com/be/nl/support/faq/routers/wireless-routers/dir-series/dir-878/how-to-setup-vpn-connection

but it's difficult to translate that to Linux

Thank you filo, that worked like a charm, and even I could follow those simple instructions :smiley:

1 Like

Don't be too humble, you did it in less than 14mins :wink:

3 Likes

well, I've been trying to figure it out for the last 2 days, so I think I should give you and those that made that guide WAY more credit than me :smiley:

Lesson learned:
When it's about Garuda:
1st search -> our forum (and for some specific aspects, our Wiki)
2nd search -> Arch Wiki
3rd search -> web incuding arch in the search string
4th search -> Arch forum
Then the rest
:slight_smile:

3 Likes

Yes, I need to remember that, I hope I can get better at searching.

2 Likes

I predict you will. People that are capable of reading, understanding, and following written guides tend to do well in Linux. :100:

Here's something else to help you (and help us):
When you request assistance please include what you have found and read, what you have tried and what the results were. And what you have not and why.

That is an incredible timesaver and help for helpers who are willing to help you.

And it is not unusual at all to solve your problem yourself, trudging along that path.
:smiley:

6 Likes

I did try to solve it my self, but after 2 days, I just thought that the only way is to ask, but I'll do better.
Sorry

1 Like

No need to say sorry, I guess.

You are a valuable member of the forums, and you did try.
But it is completely okay if you had to ask for help.

We don't like people who are help vampires or don't even try hard. Who expect to be spoon fed.
You are not one of those.
:slightly_smiling_face:

8 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.