How to change default browser

Hello.
Similar issue but doesnt seem to help. When vs code prompts to open a website or any other application it prompts for firdragon, but i removed it thinking it would ask me to change defaults.

System:    Host: lostb053 Kernel: 5.15.6-zen2-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=e052b9a5-49eb-436d-a398-6f52160177b6
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.23.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:   Type: Laptop System: Acer product: Nitro AN515-44 v: V1.04 serial: <superuser required>
Mobo: RO model: Stonic_RNS v: V1.04 serial: <superuser required> UEFI: Insyde v: 1.04
date: 02/04/2021
Battery:   ID-1: BAT1 charge: 46.5 Wh (80.3%) condition: 57.9/57.5 Wh (100.8%) volts: 16.3 min: 15.4
model: LGC AP18E8M type: Li-ion serial: 37969 status: Discharging
CPU:       Info: 6-Core model: AMD Ryzen 5 4600H with Radeon Graphics bits: 64 type: MT MCP arch: Zen 2
family: 17 (23) model-id: 60 (96) stepping: 1 microcode: 8600103 cache: L1: 384 KiB L2: 3 MiB
L3: 8 MiB
flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 71863
Speed: 1469 MHz min/max: 1400/3000 MHz boost: enabled Core speeds (MHz): 1: 1579 2: 1610
3: 1393 4: 1393 5: 1397 6: 1395 7: 1397 8: 1397 9: 1844 10: 1400 11: 1983 12: 1681
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: NVIDIA TU117M vendor: Acer Incorporated ALI driver: nvidia v: 495.44
alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1f99 class-ID: 0300
Device-2: AMD Renoir vendor: Acer Incorporated ALI driver: amdgpu v: kernel bus-ID: 05:00.0
chip-ID: 1002:1636 class-ID: 0300
Device-3: Chicony HD User Facing type: USB driver: uvcvideo bus-ID: 3-3:2 chip-ID: 04f2:b64f
class-ID: 0e02 serial: 0001
Display: x11 server: X.Org 1.21.1.1 compositor: kwin_x11 driver: loaded: modesetting,nvidia
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")
Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x193mm (13.5x7.6") diag: 394mm (15.5")
Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:     Device-1: NVIDIA driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:10fa
class-ID: 0403
Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Acer Incorporated ALI
driver: N/A alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x bus-ID: 05:00.5
chip-ID: 1022:15e2 class-ID: 0480
Device-3: AMD Family 17h HD Audio vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel
bus-ID: 05:00.6 chip-ID: 1022:15e3 class-ID: 0403
Sound Server-1: ALSA v: k5.15.6-zen2-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Realtek vendor: Acer Incorporated ALI driver: r8169 v: kernel port: 2000
bus-ID: 03:00.0 chip-ID: 10ec:2600 class-ID: 0200
IF: enp3s0 state: down mac: e4:a8:df:fd:90:34
Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 04:00.0 chip-ID: 8086:2723
class-ID: 0280
IF: wlp4s0 state: up mac: c0:3c:59:ea:ee:c1
Bluetooth: Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-4:2 chip-ID: 8087:0029
class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: C0:3C:59:EA:EE:C5
Drives:    Local Storage: total: 476.94 GiB used: 94.44 GiB (19.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: PC SN530 SDBPNPZ-512G-1014
size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD
serial: 21113V493806 rev: 21103900 temp: 46.9 C scheme: GPT
Partition: ID-1: / raw-size: 149 GiB size: 149 GiB (100.00%) used: 18.23 GiB (12.2%) fs: btrfs
dev: /dev/nvme0n1p6 maj-min: 259:6
ID-2: /boot/efi raw-size: 1 GiB size: 1021 MiB (99.61%) used: 27.9 MiB (2.7%) fs: vfat
dev: /dev/nvme0n1p4 maj-min: 259:4
ID-3: /home raw-size: 149 GiB size: 149 GiB (100.00%) used: 18.23 GiB (12.2%) fs: btrfs
dev: /dev/nvme0n1p6 maj-min: 259:6
ID-4: /var/log raw-size: 149 GiB size: 149 GiB (100.00%) used: 18.23 GiB (12.2%) fs: btrfs
dev: /dev/nvme0n1p6 maj-min: 259:6
ID-5: /var/tmp raw-size: 149 GiB size: 149 GiB (100.00%) used: 18.23 GiB (12.2%) fs: btrfs
dev: /dev/nvme0n1p6 maj-min: 259:6
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.2 GiB used: 256 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   Message: No sensor data found. Is lm-sensors configured?
Info:      Processes: 360 Uptime: 7m wakeups: 1 Memory: 7.2 GiB used: 2.96 GiB (41.0%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: 1427 pacman: 1421
lib: 349 flatpak: 6 Shell: Zsh v: 5.8 default: Bash v: 5.1.12 running-in: konsole inxi: 3.3.09
1 Like

Did you edit the file, did you reboot?

1 Like

cat ~/.profile? What browser is set in default applications?

2 Likes

Since you are using KDE, you should be able to set a new browser default in System Settings > Default Applications > Web Browser.

1 Like

Sorry for late replies

Did. And i tried reboot quite many times

cat ~/.profile
export AMD_VULKAN_ICD=RADV
export BROWSER=/opt/vivaldi/vivaldi
export EDITOR=/usr/bin/micro
export GTK2_RC_FILES="$HOME/.gtkrc-2.0"
export MAIL=thunderbird
export TERM=xterm
export VISUAL=kate

โ•ญโ”€๎‚บ ๏…ผ ๎‚ฑ ๏€• ~ ๎‚ผยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยท๎‚บ โœ” ๎‚ณ 15:15:34 ๏€— ๎‚ผโ”€โ•ฎ
โ•ฐโ”€ /opt/vivaldi/vivaldi                                                                                    โ”€โ•ฏ

(vivaldi:9821): Gtk-WARNING **: 15:15:50.564: Theme parsing error: gtk-dark.css:5822:26: '-shadow' is not a va
lid color name

(vivaldi:9821): Gtk-WARNING **: 15:15:50.564: Theme parsing error: gtk-dark.css:5825:14: not a number

(vivaldi:9821): Gtk-WARNING **: 15:15:50.564: Theme parsing error: gtk-dark.css:5826:13: not a number

(vivaldi:9821): Gtk-WARNING **: 15:15:50.564: Theme parsing error: gtk-dark.css:5827:11: Expected a length
Opening in existing browser session.

โ•ญโ”€๎‚บ ๏…ผ ๎‚ฑ ๏€• ~ ๎‚ผยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยทยท๎‚บ โœ” ๎‚ณ 15:15:50 ๏€— ๎‚ผโ”€โ•ฎ
โ•ฐโ”€ [9860:9860:0100/000000.701439:ERROR:sandbox_linux.cc(376)] InitializeSandbox() called with multiple threads
in process gpu-process.

The /opt/vivaldi/vivaldi when executed starts up browser

Did
any way to make sure about default browser?
actually whenever VS Code prompts to open up a link
it gives message dialogue via this app KIO Client

Unknown error code 100
Could not find the program '/usr/lib/firedragon/firedragon'
Please send a full bug report at https://bugs.kde.org

Well, i felt asking in garuda would be better idea so posted question here

A small update
when i last time checked links from Telegram without reboot, they were giving error
But not this time
somehow it's just VS Code
is it some type of default that isn't removed?
or issue with VS Code?

Maybe check if this helps:

Maybe test it with both vivaldi-stable.desktop and vivaldi.desktop, since something could have changed in these months.

2 Likes

Well
Can't seem to find what the issue is
But it's problem with just vs code where I won't be clicking links much
None of the above worked