How to activate an RTL8812AU wifi device?

I installed a windows driver with "NDISWrapper" it says:
Driver installed
device (0BDA:A811) present
(its a Wlan stick)
How to activate/use it now?

This is almost never required in recent times with Linux (unless your adapter is ancient).

I believe the 0bda:a811 device ID belongs to the rtl8812au Realtek adapter. There are several drivers in the AUR or Chaotic-AUR that should work with that adapter. Try installing in the following order one of these driver packages:




Undo the changes you made installing NDISWrapper then install the driver correctly from the drivers I listed.


That worked. That was easier than i thought it would be. The AUR can everything.
I have a second similar question now, but for Linux mint. My friend wants to use his
FRITZ!WLAN USB Stick AC860 with Linux Mint, can you please say how that is done on Linux Mint? cause the super easy AUR way is not available there and as i looked right now, the AC860 is not even there in the AUR.
PS: I mark your reply as the solution after you answer this, cause i think that you maybe wont look at this issue again if it is marked as solved.
PSS: My friend doesnt have internet on his linux mint until the driver is there, so maybe a solution without internet would be nice, he has dual boot with windows.

Sorry I haven't used anything but a rolling distro in probably 15 years, I'm not the one to ask for advice on Debian based systems as I have never liked them.

Glad that helped, and welcome to Garuda.

1 Like

Thanks. Although ive had some problems with Garuda (gaming version) i like the distro.

search github for a similar driver for it. Its best to see if its a dkms driver so it automatically rebuilds itself after kernel updates. im sure someone has written a driver. as for installing it, usually the github page will have a build file. (nvm seems like theres none for that one, if it was there then usually the procedure would go like this).
you just have to

 git clone


cd yadayadayadadrivernamelink
sudo make dkms_install

The OP has successfully installed the driver. The issue is resolved, so i guess we can close this thread out now.

1 Like