How do I type journalctl without the j key?

I messed up somehow, most likely because of the random freeze that happened on the Live ISO whilst resizing my drive to make room for my swap partition…
But because of that, now my /home drive is unmountable. Can’t read superblock.
Testdisk has failed to fix my /home drive, unlike last time where it worked perfectly.
My home keys and number row are both dead. As are my Ctrl keys. I tried using a wireless keyboard as a bandaid for the water spill, however this is a situation where it doesn’t help. How do I type journalctl -xb without using the J key in emergency mode?

You can type a “j” with hexadecimal input mode (press Ctrl+Shift+u to enter hexadecimal input mode, then 6, a to type a “j”, Enter to get back out of it), but if you have no Ctrl or number row keys even that isn’t going to work.

The simplest solution would be to get a wired keyboard. Typically a wired keyboard will be recognized in the pre-boot environment, unless the keyboard is some kind of abomination that requires proprietary drivers.

If a wired keyboard is not available, try booting back to the live USB and troubleshoot from there. You should be able to get the wireless keyboard working from the live environment.

Yep, that sounds bad.

Is the home partition Btrfs? You can attempt a filesystem repair from the live environment. Run a check:

sudo btrfs check /dev/sda2

Replace /dev/sda2 with whatever the partition is, obviously. If errors are found, you can run a basic repair like this:

sudo btrfs check --repair /dev/sda2

Next, Btrfs has a built-in tool for recovering the superblock you can try.

sudo btrfs rescue super-recover /dev/sda2

Then try mounting it and see if it works.


Man, it feels like the exact keys I would need to get myself out of stuff like this have, with a stroke of bad luck, died.
Oh, and btw, it errors out for the first two commands

Opening filesystem to check...
checksum verify failed on 439661559808 wanted 0x00000000 found 0x2b8eb1ae
checksum verify failed on 439661559808 wanted 0x000085c0 found 0x4ddfd378
checksum verify failed on 439661559808 wanted 0x000085c0 found 0x4ddfd378
bad tree block 439661559808, bytenr mismatch, want=439661559808, have=9932277561265631581
ERROR: cannot read chunk root
ERROR: cannot open file system

And errors out less, but still errors out with the super-recover one.

checksum verify failed on 439661559808 wanted 0x00000000 found 0x2b8eb1ae
checksum verify failed on 439661559808 wanted 0x000085c0 found 0x4ddfd378
ERROR: cannot read chunk root
Failed to recover bad superblocks

Honestly pretty screwed, arent I?

Yes, it is not looking good so far.

As a hail mary, if you have another drive on hand you can attempt to recover data from the damaged filesystem. It doesn’t have to be Btrfs and you don’t need to mount it first.

sudo btrfs restore -vi /dev/sda2 /path/to/restore

Once the restore completes, mount the disk and take a look to see what files were able to be recovered. If everything you need is there, the easiest way forward would be to reformat the disk, perform a clean install, then restore the files you were able to salvage back to the fresh installation.

Man that 4TB Hard Drive would be really useful rn if it wasn’t broken…
Guess I have to start from scratch.
But maybe there’s a way. Maybe if I create ANOTHER partition and try to move the files over to it, it’ll be salvagable…
My last hope.
Nevermind. It won’t let me create a new partition.
Maybe fdisk?
Appears I can’t figure out how to use it.
Using cfdisk.
It didn’t work. Yet another time where I have to restart.

That’s too bad. You could always hold off until you are able to get another disk to restore to. I’m not sure if the data you had there is worth it or not.

Mom wouldn’t get a new one anyway, and at the moment, I can’t simply hold off as I don’t have my own charger for my tablet. (the one I had broke)
And all for a few passwords that I didn’t transfer over? If it’s nothing I can’t reset, then it should be fine. If not, I’m screwed.

onboard app? :slight_smile:

1 Like

A virtual keyboard as @SGS mentioned would be helpful if you could boot into your desktop, but unfortunaely an OSK won’t do much good in the pre-boot environment.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.