How do I make internal SATA drives hold games?

Hello!
I'm new to linux so your help would be very much appreciated.
Since I used to be a gamer on windows, I wanted to start installing my steam library. I started partitioning my internal SSD and HDDs to format them as EXT4. Once I had them all partitioned (and after a few reboots), I thought I could just mount them and start installing some of my library onto them. It took a few hours but they installed pretty quickly. I then turned off my system for a few hours to go work on another project and my steam library is completely empty, but the drives still have the steam library folders on them. So all I'm wondering is how i get those internal drives to stay internal and not removable. Thanks!

Sorry if this isn't formatted right, I wasn't sure how to format it since it has nothing to do with the console.

Thanks so much for your help!
-A new linux user

have you created any entries in /etc/fstab? That way when you reboot the mounts you previously created should be there. Are the permissions for the folders set for access by both steam and the user?

2 Likes

Hey my man! I havent been able to execute that in Konsole because:
fish: The file “/etc/fstab/” is not executable by this user
I'm not sure how to access that to be honest. I'll have to do some more digging.

use the command micro /etc/fstab

1 Like

Not sure what to do with all of this. I'll look into it. Thanks for the help though! i appreciate it

Worth reading: fstab - ArchWiki

4 Likes

Thanks. I tried messing around with this but it wouldn't let me access it before because of the afformentioned denied access. I'll be sure to check this out though.

It is a file, not an executable, which is why you can't run it.

Please read the wiki page - it explains what the file does in a lot of detail (it's dry and technical, but everything you could ever want to know is in there).

3 Likes

If you can't make heads or tails of editing fstab, there is a GUI method.

Install the program disks. You can use disks to automatically create fstab entries for your drives.

6 Likes

Good luck. The switch to Linux is a rough ride for a while, hope you stick at it, look up "the basics" and find it a worthwhile endeavor.
P.S Welcome to the forum and Operating System(s) that provide you freedom.

yeah I'm definitely feeling the heat but I want to stay with it. Even using garuda has me more excited about the future than windows ever has. Even though I'm not even technically competent enough to install a program yet, I hope one day that I can build an OS like the best of em

1 Like

Hey, Sorry to bug you, but is disks available on octopi? I'm trying to find it in console and apparently I'm not in the root access group

sudo pacman -S gnome-disk-utility

Start in laucher with 'disks'

/usr/bin/gnome-disk-image-mounter
/usr/bin/gnome-disks
6 Likes

You're too fast @SGS . :rofl:

3 Likes

To use package manager to install apps/programs/packages, you almost always need to provide root access. When using terminal, start with "sudo" for "superuser do". It's the equivalent of "administrator" in Windows, but you don't add individual users to the group because it makes it too easy to break your system and/or allow malware to gain such access.

1 Like

╭─[email protected] in ~ took 2m12s [🔴] × sudo pacman -S gnome-disk-utility sudo: /etc/sudoers.d is owned by uid 1000, should be 0 [sudo] password for domiepotato:
Not sure whats going on but I enter that line and then it doesn't let me type in the password... I've been messing around trying to get sudoer access so im not sure if i messed something up

What have you been up to?

Please copy and paste the output for
ls -l /etc/sudoers /etc/passwd

[email protected] in ~
╰─λ ls -l /etc/sudoers /etc/passwd
.rw-r--r-- 2.1k root 14 Nov 21:30  /etc/passwd
.r--r----- 3.1k root 22 Sep 01:19  /etc/sudoers

I'm sorry i have no idea what i did to mess it up xD Ive been in settings trying to get access for hours and have tried a lot of stuff

I'm out, my resolutions are a bit dramatic, hopefully someone else has a decent idea how to help.

1 Like

It looks like your user account domiepotato is not allowed to run command as sudo.
Another reading to understand what you'll have to do, sorry it is necessary at the beginning:
https://wiki.archlinux.org/title/Sudo
Unfortunately, in order to do that, you need a root account, which I think you don't have, so my best idea (there is another possibility from the GRUB) is to do this job booting from your live USB and using the chroot tool provided there (I think it is in the Garuda Welcome or Assistant, just search) to enter from the live USB into your installed system (everything you'll do, will be done on your installed system), and you will be automatically root there, i.e. you'll see your terminal prompt as #.
Then, as you'll see in the guide above, you'll need to edit visudo.
Since we don't use as editor neither vi or nano, but micro, I think you could use:
EDITOR=micro visudo
then make sure that the line
%wheel ALL=(ALL) ALL
is uncommented (remove the initial # if present).
Ctrl+q to exit and of course confirm the save with y.
Then, you need to add your user to this wheel group with:
usermod -aG wheel domiepotato.
So, you can try again booting normally and continue as suggested above:
sudo pacman -S gnome-disk-utility
create fstab entries
...

Good luck, I understand it might look complicated, but everything (errors included) will be a good investiment. :wink:

4 Likes