How do I get boot screen shared on external display?

I wish to have everything - encrypted drive unlock, grub menu and plymouth splash screen - shared on my external display.

Right now I have to operate on laptop display all the way upto SDDM login screen. My plymouth splash animation doesn't even play when connected to external display.

I tried Fedora some time ago, and they got very nice integration. Even the disk decryption is a nice GUI that is shared on external screen. I had to come back to Arch since Fedora sucks in regards to packages availability and updates.

How do I get all these niceties on Garuda?

─ inxi -Faz
System:
Kernel: 5.16.10-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=2e41d0ad-de12-458a-acbc-0d038037b38c rw [email protected]
cryptdevice=UUID=c2083ab5-e739-4b3e-af73-4c63321909c4:luks-c2083ab5-e739-4b3e-af73-4c63321909c4
root=/dev/mapper/luks-c2083ab5-e739-4b3e-af73-4c63321909c4 quiet splash
rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
modprobe.blacklist=nouveau
Desktop: KDE Plasma 5.24.2 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: ASUSTeK product: ROG Zephyrus G14 GA401II_GA401II
v: 1.0 serial: <superuser required>
Mobo: ASUSTeK model: GA401II v: 1.0 serial: <superuser required>
UEFI: American Megatrends v: GA401II.219 date: 12/30/2020
Battery:
ID-1: BAT0 charge: 57.9 Wh (78.2%) condition: 74.0/76.0 Wh (97.4%)
volts: 15.8 min: 15.8 model: ASUSTeK ASUS Battery type: Li-ion serial: N/A
status: Discharging
CPU:
Info: model: AMD Ryzen 5 4600HS with Radeon Graphics bits: 64 type: MT MCP
arch: Zen 2 family: 0x17 (23) model-id: 0x60 (96) stepping: 1
microcode: 0x8600104
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 8 MiB desc: 2x4 MiB
Speed (MHz): avg: 1396 high: 1398 min/max: 1400/3000 boost: enabled
scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1397 2: 1397
3: 1396 4: 1397 5: 1397 6: 1396 7: 1397 8: 1396 9: 1398 10: 1397 11: 1397
12: 1396 bogomips: 71861
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
IBRS_FW, STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Renoir vendor: ASUSTeK driver: amdgpu v: kernel pcie: gen: 4
speed: 16 GT/s lanes: 16 ports: active: eDP-1 empty: HDMI-A-1
bus-ID: 04:00.0 chip-ID: 1002:1636 class-ID: 0300
Display: x11 server: X.Org v: 1.21.1.3 compositor: kwin_x11 driver: X:
loaded: amdgpu,ati unloaded: modesetting alternate: fbdev,vesa gpu: amdgpu
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
s-diag: 582mm (22.9")
Monitor-1: eDP res: 1920x1080 hz: 120 dpi: 158
size: 309x174mm (12.2x6.9") diag: 355mm (14")
OpenGL: renderer: AMD RENOIR (DRM 3.44.0 5.16.10-zen1-1-zen LLVM 13.0.1)
v: 4.6 Mesa 21.3.6 direct render: Yes
Audio:
Device-1: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel
v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 04:00.1
chip-ID: 1002:1637 class-ID: 0403
Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor
vendor: ASUSTeK driver: N/A
alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x, snd_pci_acp6x
pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 04:00.5 chip-ID: 1022:15e2
class-ID: 0480
Device-3: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel
v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 04:00.6
chip-ID: 1022:15e3 class-ID: 0403
Sound Server-1: ALSA v: k5.16.10-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.47 running: yes
Network:
Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
speed: 5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 8086:2723 class-ID: 0280
IF: wlp2s0 state: up mac: <filter>
Bluetooth:
Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 5-4:3 chip-ID: 8087:0029 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
Local Storage: total: 953.87 GiB used: 223.6 GiB (23.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKNW010T8
size: 953.87 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 004C
temp: 29.9 C scheme: GPT
Partition:
ID-1: / raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 223.6 GiB (23.4%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-c2083ab5-e739-4b3e-af73-4c63321909c4
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 720 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 223.6 GiB (23.4%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-c2083ab5-e739-4b3e-af73-4c63321909c4
ID-4: /var/log raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 223.6 GiB (23.4%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-c2083ab5-e739-4b3e-af73-4c63321909c4
ID-5: /var/tmp raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 223.6 GiB (23.4%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-c2083ab5-e739-4b3e-af73-4c63321909c4
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.11 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 35.0 C mobo: N/A gpu: amdgpu temp: 33.0 C
Fan Speeds (RPM): cpu: 2300
Info:
Processes: 340 Uptime: 25m wakeups: 2 Memory: 15.11 GiB
used: 2.24 GiB (14.8%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 1404 lib: 358 Shell: Zsh
v: 5.8.1 running-in: konsole inxi: 3.3.13

Have you tried adding a module for your graphic card to your mkinitcpio configuration, so it loads up before the encryption hooks? mkinitcpio - ArchWiki

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.