How do i connect a dual shock 4 (ps4 controller)?

Hello. I have been trying to connect my ps4 controller via bluetooth, it works great with USB but would rather use bluetooth, i have looked at the arch wiki section on connecting bluetooth controllers to it, but it didnt work. Another guide i followed told me to connect it with usb and then connect it from bluetooth from the settings menu, but it isnt showing up.

Post your terminal/konsole in- and output as text (no pictures) from:

System:
Kernel: 5.16.12-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=3d7f37ea-6ec9-4e7c-abfb-36c47e2e627b rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
Desktop: KDE Plasma 5.24.3 tk: Qt 5.15.3 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: Dell product: Latitude E7470 v: N/A
serial: <superuser required> Chassis: type: 9 serial: <superuser required>
Mobo: Dell model: 0T6HHJ v: A00 serial: <superuser required>
UEFI-[Legacy]: Dell v: 1.31.3 date: 10/13/2021
Battery:
ID-1: BAT0 charge: 48.0 Wh (100.0%) condition: 48.0/55.0 Wh (87.4%)
volts: 8.4 min: 7.6 model: SMP DELL MC34Y51 type: Li-poly serial: <filter>
status: Full
ID-2: hidpp_battery_0 charge: 76% condition: N/A volts: 4.0 min: N/A
model: Logitech G502 LIGHTSPEED Wireless Gaming Mouse type: N/A
serial: <filter> status: Discharging
CPU:
Info: model: Intel Core i5-6300U bits: 64 type: MT MCP arch: Skylake
family: 6 model-id: 0x4E (78) stepping: 3 microcode: 0xEC
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 3 MiB desc: 1x3 MiB
Speed (MHz): avg: 2095 high: 2100 min/max: 400/3000 scaling:
driver: intel_pstate governor: powersave cores: 1: 2100 2: 2100 3: 2100
4: 2080 bogomips: 19999
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
IBRS_FW, STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort mitigation: TSX disabled
Graphics:
Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Dell Latitude E7470
driver: i915 v: kernel ports: active: HDMI-A-1,eDP-1 empty: DP-1,HDMI-A-2
bus-ID: 00:02.0 chip-ID: 8086:1916 class-ID: 0300
Device-2: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo
bus-ID: 1-2:3 chip-ID: 0bda:5686 class-ID: 0e02 serial: <filter>
Device-3: Microsoft Microsoft LifeCam Cinema type: USB
driver: snd-usb-audio,uvcvideo bus-ID: 1-4.1:7 chip-ID: 045e:0812
class-ID: 0102
Display: x11 server: X.Org v: 1.21.1.3 compositor: kwin_x11 driver: X:
loaded: intel unloaded: modesetting alternate: fbdev,vesa gpu: i915
display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1013x285mm (39.9x11.2")
s-diag: 1052mm (41.4")
Monitor-1: HDMI1 mapped: HDMI-A-1 pos: primary,right model: Dell U2417H
serial: <filter> built: 2016 res: 1920x1080 hz: 60 dpi: 92 gamma: 1.2
size: 530x300mm (20.9x11.8") diag: 604mm (23.8") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
Monitor-2: eDP1 mapped: eDP-1 pos: primary,left model: BOE Display
built: 2015 res: 1920x1080 hz: 60 dpi: 157 gamma: 1.2
size: 310x170mm (12.2x6.7") diag: 354mm (13.9") ratio: 16:9
modes: 1920x1080
OpenGL: renderer: Mesa Intel HD Graphics 520 (SKL GT2) v: 4.6 Mesa 21.3.7
direct render: Yes
Audio:
Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell Latitude E7470
driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3
chip-ID: 8086:9d70 class-ID: 0403
Device-2: Logitech G935 Gaming Headset type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-3:4 chip-ID: 046d:0a87
class-ID: 0300
Device-3: Microsoft Microsoft LifeCam Cinema type: USB
driver: snd-usb-audio,uvcvideo bus-ID: 1-4.1:7 chip-ID: 045e:0812
class-ID: 0102
Sound Server-1: ALSA v: k5.16.12-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.48 running: yes
Network:
Device-1: Intel Ethernet I219-LM vendor: Dell Latitude E7470 driver: e1000e
v: kernel port: N/A bus-ID: 00:1f.6 chip-ID: 8086:156f class-ID: 0200
IF: enp0s31f6 state: down mac: <filter>
Device-2: Intel Wireless 8260 driver: iwlwifi v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 bus-ID: 01:00.0 chip-ID: 8086:24f3 class-ID: 0280
IF: wlp1s0 state: up mac: <filter>
Bluetooth:
Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
bus-ID: 1-8:95 chip-ID: 8087:0a2b class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 22 state: up address: <filter>
RAID:
Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
v: 3.0 port: f060 bus-ID: 00:17.0 chip-ID: 8086:282a rev: N/A
class-ID: 0104
Drives:
Local Storage: total: 465.76 GiB used: 66.83 GiB (14.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WDS500G2B0B-00YS70 size: 465.76 GiB block-size: physical: 512 B
logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 00WD
scheme: MBR
Partition:
ID-1: / raw-size: 465.76 GiB size: 465.76 GiB (100.00%)
used: 66.83 GiB (14.3%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-2: /home raw-size: 465.76 GiB size: 465.76 GiB (100.00%)
used: 66.83 GiB (14.3%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-3: /var/log raw-size: 465.76 GiB size: 465.76 GiB (100.00%)
used: 66.83 GiB (14.3%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-4: /var/tmp raw-size: 465.76 GiB size: 465.76 GiB (100.00%)
used: 66.83 GiB (14.3%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.3 GiB used: 1.73 GiB (11.3%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 71.0 C pch: 58.5 C mobo: N/A
Fan Speeds (RPM): cpu: 4720
Info:
Processes: 256 Uptime: 11d 23h 32m wakeups: 425 Memory: 15.3 GiB
used: 6.12 GiB (40.0%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 1479 lib: 428 Shell: fish
v: 3.3.1 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.13
Garuda (2.5.6-2):
System install date:     2022-01-30
Last full system update: 2022-03-17 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       <superuser required>
Snapshots:               Snapper
Failed units:

Did you enter the bluetooth pairing mode? Press and hold the PlayStation button and Share button at the same time on your DualShock 4 controller. The lightbar should flash if you entered pairing mode correctly.

1 Like

I did, but its not showing up

bluez just updated very recently Arch Linux - bluez 5.64-2 (x86_64)
I know one of my systems had BT issues recently, and this update fixed it.

Update the system with garuda-update, restart the system and try pairing the controller again.

1 Like