How did you convert to MBR?

How did you convert to MBR ?

Or you installed as gpt?

My SSD was MBR so I used the Aomei partition software to convert it to GPT. And then, I tried again to install Garuda and it worked.

I believe Garuda seems to be GPT only. At least on my PC :sweat_smile:

1 Like

This is …

Kinda concerning and weird, cuz I always had old computers and there’s no way that a old 5-7 years old laptop can have Gpt bios :frowning:

I hope it’ll work on my refurbished laptop :thinking:

Hmm, I wonder what would happen if I were to format a drive with Rufus and Garuda

Mine is from 2009 and it does GPT. No UEFI and no USB boot though.
I also converted the existing disk from MBR to GPT, with gdisk.


Ok, thanks for explaining :slight_smile:

You can’t say like this. My 12-year-old Laptop is GPT capable. :wink:

1 Like

To improve the search function of the forum.

  • ONE issue per topic.

From template

:warning: Missing information requested in the template may result in not receiving assistance

Make sure you have done the following before you post:

Issue still unresolved? Then:

  • ONE issue per topic.
  • Describe your issue in detail. The more we know, the better we can help
  • Show us the results of your searches, and what you’ve tried
  • After rebooting, post the FULL output of garuda-inxi in the body of the post (not linked externally, or collapsed with the “hide details” feature)
  • Format terminal output (including your garuda-inxi) as a code block by clicking the preformatted text button (</>) , or put three tildes (~) above and below the text

Without garuda-inxi this request will be moved to 412 Precondition Failed

GPT-only here. A fast, beautiful Linux experience isn’t always possible with older, low-powered hardware, contrary to the popular conception that “Linux is just great for old hardware” wherever that tripe came from.

Quality is like buying oats. “If you want nice fresh oats you have to pay a fair price . If you can be satisfied with oats that have already been thru the horse, that comes a little cheaper.”

Of course, judgement is reserved until you present a garuda-inxi output. :slight_smile:


Should I have mentioned that separately?
I have moved the posts and hidden the template.
Ok, I make it visible. :slight_smile:


Like Windows, Garuda Linux supports both GPT and MBR.

The original issue was not caused by disks being in MBR or GPT format, that doesn’t matter at all. You can mix them however you like and it will work fine.

Rather, the issue was caused by one OS being installed in UEFI mode while the other was installed in legacy/BIOS mode. Most likely you would still be able to boot and use them just fine, but you would have to boot to the BIOS and explicitly enable legacy/BIOS mode for the one, and disable/enable “UEFI only” mode for the other. Switching between them would have required this intervention every time, so it is better you have them in the same mode now anyway.

To be clear, Garuda Linux can be installed with either one (UEFI or legacy/BIOS mode). The Calamares installer will set up the installation with whatever mode the live environment is in. You have to set up your boot media (the USB stick you install with) according to the mode you wish to use on the installed system.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.