How can I install this please // ocs-url // or // Pling Store

  Kernel: 6.1.9-zen1-2-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=d6891cba-226d-412d-b38d-6e0018489c43 rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3 ibt=off
  Desktop: Deepin v: 20.6 tk: Qt v: 5.15.8 info: mate-panel wm: marco
    v: 1.26.1 vt: 1 dm: LightDM v: 1.32.0 Distro: Garuda Linux base: Arch Linux
  Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
  Mobo: ASUSTeK model: PRIME Z490-A v: Rev 1.xx serial: <superuser required>
    UEFI: American Megatrends v: 2601 date: 05/17/2022
  Info: model: Intel Core i7-10700K bits: 64 type: MT MCP arch: Comet Lake
    gen: core 10 level: v3 note: check built: 2020 process: Intel 14nm family: 6
    model-id: 0xA5 (165) stepping: 5 microcode: 0xF4
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 2 MiB desc: 8x256 KiB
    L3: 16 MiB desc: 1x16 MiB
  Speed (MHz): avg: 4043 high: 5100 min/max: 800/5100 scaling:
    driver: intel_pstate governor: performance cores: 1: 3800 2: 3800 3: 3800
    4: 3800 5: 3800 6: 3800 7: 5100 8: 5099 9: 3800 10: 5100 11: 3800 12: 3800
    13: 3800 14: 3800 15: 3800 16: 3800 bogomips: 121596
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
  Vulnerabilities: <filter>
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
    vendor: ASUSTeK driver: amdgpu v: kernel arch: GCN-4 code: Arctic Islands
    process: GF 14nm built: 2016-20 pcie: gen: 3 speed: 8 GT/s lanes: 16
    ports: active: HDMI-A-1 empty: DP-1, DP-2, DVI-D-1, HDMI-A-2
    bus-ID: 01:00.0 chip-ID: 1002:67df class-ID: 0300 temp: 52.0 C
  Display: x11 server: X.Org v: 21.1.6 compositor: marco v: 1.26.1 driver:
    gpu: amdgpu note: X driver n/a display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2560x1440 s-dpi: 96 s-size: 677x381mm (26.65x15.00")
    s-diag: 777mm (30.58")
  Monitor-1: HDMI-A-1 mapped: HDMI-A-0 model: AOC Q32G1WG4 serial: <filter>
    built: 2019 res: 2560x1440 dpi: 93 gamma: 1.2 size: 697x393mm (27.44x15.47")
    diag: 800mm (31.5") ratio: 16:9 modes: max: 2560x1440 min: 720x400
  API: OpenGL Message: Unable to show GL data. Required tool glxinfo
  Device-1: Intel Comet Lake PCH cAVS vendor: ASUSTeK driver: snd_hda_intel
    v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
    chip-ID: 8086:06c8 class-ID: 0403
  Device-2: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
    vendor: ASUSTeK driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s
    lanes: 16 bus-ID: 01:00.1 chip-ID: 1002:aaf0 class-ID: 0403
  Sound API: ALSA v: k6.1.9-zen1-2-zen running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.65 running: yes
  Device-1: Intel Ethernet I225-V vendor: ASUSTeK driver: igc v: kernel pcie:
    gen: 2 speed: 5 GT/s lanes: 1 port: N/A bus-ID: 04:00.0 chip-ID: 8086:15f3
    class-ID: 0200
  IF: enp4s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  Local Storage: total: 3.18 TiB used: 1.13 TiB (35.6%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
    model: WDS250G2B0C-00PXH0 size: 232.89 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 211070WD temp: 29.9 C scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:3 vendor: Samsung
    model: SSD 970 EVO Plus 250GB size: 232.89 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 2B2QEXM7 temp: 36.9 C scheme: MBR
  ID-3: /dev/sda maj-min: 8:0 vendor: Toshiba model: HDWD130 size: 2.73 TiB
    block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD
    rpm: 7200 serial: <filter> rev: ACF0 scheme: GPT
  ID-1: / raw-size: 232.59 GiB size: 232.59 GiB (100.00%)
    used: 11.99 GiB (5.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 608 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 232.59 GiB size: 232.59 GiB (100.00%)
    used: 11.99 GiB (5.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 232.59 GiB size: 232.59 GiB (100.00%)
    used: 11.99 GiB (5.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 232.59 GiB size: 232.59 GiB (100.00%)
    used: 11.99 GiB (5.2%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 31.25 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 37.0 C mobo: N/A gpu: amdgpu temp: 52.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 1198
  Processes: 362 Uptime: 55m wakeups: 0 Memory: 31.25 GiB
  used: 3.45 GiB (11.0%) Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 Packages: pm: pacman pkgs: 1433
  libs: 359 tools: gnome-software,octopi,pamac,paru Shell: fish v: 3.6.0
  default: Bash v: 5.1.16 running-in: deepin-terminal inxi: 3.3.24
Garuda (2.6.14-1):
head: cannot open '/var/log/pacman.log' for reading: No such file or directory
  System install date:     
  Last full system update: 2023-02-06 ↻
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager mkinitcpio
  Windows dual boot:       No/Undetected
  Failed units:            


How can I install this please // ocs-url // or // Pling Store // I have tried everything I can


Are you sure you want to install this? It looks like it hasn't been worked on in years. Here is the "recent" commit history:

There is an AUR package, but even that hasn't been updated in years.

Package Details: ocs-url 3.1.0-7

Package Actions

Git Clone URL: (read-only, click to copy)
Package Base: ocs-url
Description: An install helper program for items served via OpenCollaborationServices (ocs://).
Upstream URL: DFN2 / ocs-url · GitLab
Licenses: GPL3
Conflicts: xdgurl
Provides: xdgurl
Submitter: oberon2007
Maintainer: Pol_M
Last Packager: Pol_M
Votes: 57
Popularity: 0.21
First Submitted: 2017-03-07 11:46 (UTC)
Last Updated: 2021-12-20 20:49 (UTC)

I'm guessing whatever thing you read online that says you should use this is old/out of date, and you should reconsider the advice.



I sincerely appreciate it.

I'm stuck with it no matter how dated it is.

The one that handles themes is this. ?

Exists a standard that everyone uses?

I do not know what it is for, to be honest. Judging by the comments, it looks like it is not working for others as well. I think it is fair to say the project is abandoned.

1 Like


Thank you I just wanted to install some themes and make Garuda look much nicer :slight_smile:

well if it doesn't work i will remove it

ocs-url has been working fine since I installed it a while ago. I guess there is no need to update it


I've been using ocs-url with Brave and it's worked flawlessly for me on several different Garuda editions but mainly Gnome is the one I use it the most for. You're fine with installing and using it. I can't speak for how it works with Firefox or FireDragon as Brave is my daily main.

sudo pacman -S ocs-url


Thank you :+1:

1 Like

No problem at all. Have fun!

so how do i use it?

it says i need a helper or something
i put the url in terminal but it wont work

So I don't use it in the terminal.

Here is my way of doing it:

  • I navigate to

  • I find the customization I want to add

  • Then I click on the "Install" button

  • Then I allow the browser to communicate with/launch the ocs-url package when it asks (I also click "Do this every time".

  • When OCS-URL handler dialog window comes up, just click "Okay" and close it when it finishes installing the Pling addon

  • Then you can navigate to Appearance Settings (in KDE), MATE Tweaks (in MATE) or Tweaks (in Gnome) and change the customization to what you just installed.

Hope that helps.


The browser is going to be your "helper".

1 Like

You installed ocs-url through the terminal, but you won't use it through the terminal. You can just use it when launched from the browser on the Pling/similar site(s). :slight_smile:

1 Like


Thank you it worked

many thanks man :+1:

1 Like

Anytime! Happy theming!

1 Like

Glad to hear you got it working. :+1:

My apologies for discouraging you from using this software; it looked like an old abandoned project. :face_with_peeking_eye:


"If it ain't broke, don't fix it" is something I heard a lot as a child. Maybe that applies in this case? :joy:

1 Like
No Worries you are still my Friend  :)

No, It applies to me :slight_smile:

I keep pocking around, I love finding new stuff

1 Like

@Firas motto is: "if it ain't broke...keep trying." :rofl: