How can I get the title bar on maximized apps, and other starter questions

Hi, I just installed Garuda and am running into some slight issues.

1.) The biggest one is that if I maximize an app, its title bar vanishes. And with that, the ability to minimize and resize said app.

I installed the Dragonized Version, but redid the layout to a more traditional windows desktop (I feel this is the reason for my woes).

Thus far, this is creating issues with apps like web browsers, Libre Office, etc.

2.) Onionshare is a brilliant file sharing app for securely sharing your files with family. However the app doesn't launch for me.

3.) There is a widget I like using called System Load. It basically gives you a brief view of your cpu & memory usage. However it doesn't seem to work in Garuda for me. Does anyone know how to get it to work?

4.) In the Application Menu, there used to be quick shortcuts to the restart, shutdown, and log out. Now there's only log out available as an option. I have no idea what made the other options disappear. Is there a wayt o get them back?

```
System:    Kernel: 5.13.13-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0 
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=db8c47c7-c1bb-4133-82b2-cb35a105a4dd 
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
systemd.unified_cgroup_hierarchy=1 resume=UUID=fc03ac2b-b608-4b71-b0de-45ef551c6b1b loglevel=3 
Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM 
Distro: Garuda Linux base: Arch Linux 
Machine:   Type: Desktop Mobo: ASRock model: B450 Pro4 serial: <filter> UEFI-[Legacy]: American Megatrends 
v: P3.50 date: 07/18/2019 
CPU:       Info: 6-Core model: AMD Ryzen 5 1600 bits: 64 type: MT MCP arch: Zen family: 17 (23) 
model-id: 1 stepping: 1 microcode: 8001138 cache: L2: 3 MiB 
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 76643 
Speed: 3537 MHz min/max: 1550/3200 MHz boost: enabled Core speeds (MHz): 1: 3537 2: 2818 
3: 3184 4: 2727 5: 2942 6: 2719 7: 2739 8: 2989 9: 3512 10: 2875 11: 2732 12: 2716 
Vulnerabilities: Type: itlb_multihit status: Not affected 
Type: l1tf status: Not affected 
Type: mds status: Not affected 
Type: meltdown status: Not affected 
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
Type: spectre_v2 
mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling 
Type: srbds status: Not affected 
Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] vendor: XFX Pine 
driver: amdgpu v: kernel bus-ID: 09:00.0 chip-ID: 1002:67df class-ID: 0300 
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: amdgpu,ati 
unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1 
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9") 
Monitor-1: HDMI-A-0 res: 1920x1080 hz: 60 dpi: 93 size: 527x296mm (20.7x11.7") 
diag: 604mm (23.8") 
OpenGL: renderer: Radeon RX 570 Series (POLARIS10 DRM 3.41.0 5.13.13-zen1-1-zen LLVM 12.0.1) 
v: 4.6 Mesa 21.2.1 direct render: Yes 
Audio:     Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] vendor: XFX Pine 
driver: snd_hda_intel v: kernel bus-ID: 09:00.1 chip-ID: 1002:aaf0 class-ID: 0403 
Device-2: AMD Family 17h HD Audio vendor: ASRock driver: snd_hda_intel v: kernel 
bus-ID: 0b:00.3 chip-ID: 1022:1457 class-ID: 0403 
Sound Server-1: ALSA v: k5.13.13-zen1-1-zen running: yes 
Sound Server-2: JACK v: 1.9.19 running: no 
Sound Server-3: PulseAudio v: 15.0 running: no 
Sound Server-4: PipeWire v: 0.3.34 running: yes 
Network:   Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 05:00.0 chip-ID: 8086:2723 
class-ID: 0280 
IF: wlp5s0 state: up mac: <filter> 
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASRock driver: r8169 
v: kernel port: d000 bus-ID: 08:00.0 chip-ID: 10ec:8168 class-ID: 0200 
IF: enp8s0 state: down mac: <filter> 
Bluetooth: Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-8:4 chip-ID: 8087:0029 
class-ID: e001 
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter> 
Drives:    Local Storage: total: 1.22 TiB used: 422.99 GiB (33.8%) 
SMART Message: Unable to run smartctl. Root privileges required. 
ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SHFS37A240G size: 223.57 GiB block-size: 
physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: BBF2 scheme: MBR 
ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST9320423AS size: 298.09 GiB block-size: 
physical: 512 B logical: 512 B speed: 3.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: LVM1 
scheme: GPT 
ID-3: /dev/sdc maj-min: 8:32 vendor: Crucial model: CT275MX300SSD1 size: 256.17 GiB block-size:
physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: R060 scheme: GPT
ID-4: /dev/sdd maj-min: 8:48 vendor: Toshiba model: DT01ACA050 size: 465.76 GiB block-size:
physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: A750
scheme: GPT
ID-5: /dev/sde maj-min: 8:64 type: USB vendor: Sony model: Storage Media size: 7.54 GiB
block-size: physical: 512 B logical: 512 B type: N/A serial: <filter> rev: 0100 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition: ID-1: / raw-size: 214.77 GiB size: 214.77 GiB (100.00%) used: 13.67 GiB (6.4%) fs: btrfs
dev: /dev/sda1 maj-min: 8:1
ID-2: /home raw-size: 214.77 GiB size: 214.77 GiB (100.00%) used: 13.67 GiB (6.4%) fs: btrfs
dev: /dev/sda1 maj-min: 8:1
ID-3: /var/log raw-size: 214.77 GiB size: 214.77 GiB (100.00%) used: 13.67 GiB (6.4%) fs: btrfs
dev: /dev/sda1 maj-min: 8:1
ID-4: /var/tmp raw-size: 214.77 GiB size: 214.77 GiB (100.00%) used: 13.67 GiB (6.4%) fs: btrfs
dev: /dev/sda1 maj-min: 8:1
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda2
maj-min: 8:2
ID-2: swap-2 type: zram size: 7.69 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 51.0 C mobo: N/A gpu: amdgpu temp: 53.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 1028
Info:      Processes: 365 Uptime: 15m wakeups: 0 Memory: 7.69 GiB used: 2.96 GiB (38.5%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1407 lib: 350
Shell: fish v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.06
```
  1. Edit the file ~/.config/kwinrc
    find BorderlessMaximizedWindows=true
    set it to BorderlessMaximizedWindows=false
    log out/in.
1 Like

I can't get that setting to stick. I've tried editing it as a root user, but everytime I restart, it's back to being set as true.

Where is your inxi -Faz?

Use Kate to edit and never use root in your ~/ home folder.

Next, one problem, one topic. It's best for the forum search function.

What do you mean, it's right up there :slight_smile:

I tried several ways, including Kate to edit that file. I even launched Kate as root to edit kwinrc, but I can't get it to save those settings.

Edit: Also I feel kind of uncomfortable making multiple posts. Your reasoning for doing so makes sense, but I just feel as if I would be spamming the forum.

Me too :smiley:

How to save file into the home partition in Arch - Unix ...

How to save file into the home partition in Arch - Unix & Linux Stack Exchange

How can I tell Arch to save files in the home partition, instead of using the root one? EDIT: Sorry if I am using a really bad language to describe this problem, but I've been into Linux since like two weeks or so. Please, be patient. UPDATE: This is the image of the content inside /etc/fastab: This is obtained by the command:

3 Ways to Save Linux Files - wikiHow

3 Ways to Save Linux Files - wikiHow

Type a space and enter the name of the file you want to create. If you wanted to save the results to a file called filelist, the command would look like ls -a > filelist. If you're appending the output to an existing file, you'd use ls -a >> filename. 4


First search the web, wiki, garuda wiki.

Second, we do not support of every software in the linux world ( Onionshare, widget I System Load).

You do not tell what are you doing before that happen.

And whether you have made the effort to look for solutions yourself.
It is sobering to hear from those seeking help that he had already found it on the net and read, but it did not help.

1 Like