How can I fix 'System Volume Information' input/output error on one of my internal drives


apparently when I'm trying to access one of my internal hard drives especially in GTK/Gnome apps I'm receiving I/O error and I can't get inside. However there's no problem in other apps or my OS and I/O read and write is working like it should. I'm thinking that it's something remaining from before when I was with Windows.

Anyways, when I go through the drives I saw that one of the drives - the working one is having 3 hidden folders - .Trash-1000 , $RECYCLE.BIN and System Volume Information, but the problematic drive only has .Trash-1000 so it seems that I get this error, because my System Volume Information folder is missing.

Anyone having an idea how can I fix this? Is there a way of creating that folder? or Can I use a Windows VM to try to fix this? How should I proceed?

garuda-inxi :

Kernel: 6.4.4-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=90aeb098-5302-49d3-a3fe-482d1815c7f2 rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
Desktop: KDE Plasma v: 5.27.6 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Desktop Mobo: Micro-Star model: B450 TOMAHAWK MAX II (MS-7C02) v: 3.0
serial: <superuser required> UEFI: American Megatrends LLC. v: H.B1
date: 06/10/2023
Info: model: AMD Ryzen 5 5600X bits: 64 type: MT MCP arch: Zen 3+ gen: 4
level: v3 note: check built: 2022 process: TSMC n6 (7nm) family: 0x19 (25)
model-id: 0x21 (33) stepping: 2 microcode: 0xA20120A
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 32 MiB desc: 1x32 MiB
Speed (MHz): avg: 3001 high: 3600 min/max: 2200/4650 boost: enabled
scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 2810 2: 2650
3: 2871 4: 2880 5: 3599 6: 3001 7: 3600 8: 2879 9: 3028 10: 2223 11: 3597
12: 2879 bogomips: 88802
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Device-1: NVIDIA GA104 [GeForce RTX 3060] vendor: PNY driver: nvidia
v: 535.86.05 alternate: nouveau,nvidia_drm non-free: 535.xx+
status: current (as of 2023-07) arch: Ampere code: GAxxx
process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 3 speed: 8 GT/s lanes: 16
link-max: gen: 4 speed: 16 GT/s bus-ID: 26:00.0 chip-ID: 10de:2487
class-ID: 0300
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.2
compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting,nouveau
alternate: fbdev,nv,vesa gpu: nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 6960x1920 s-dpi: 91 s-size: 1944x536mm (76.54x21.10")
s-diag: 2017mm (79.39")
Monitor-1: DP-0 pos: primary,top-center res: 3840x1600 hz: 60 dpi: 111
size: 879x366mm (34.61x14.41") diag: 952mm (37.49") modes: N/A
Monitor-2: DP-2 pos: top-left res: 1200x1920 hz: 60 dpi: 94
size: 324x518mm (12.76x20.39") diag: 611mm (24.05") modes: N/A
Monitor-3: DP-4 pos: bottom-r res: 1920x1080 hz: 60 dpi: 92
size: 531x299mm (20.91x11.77") diag: 609mm (23.99") modes: N/A
API: OpenGL v: 4.6.0 NVIDIA 535.86.05 renderer: NVIDIA GeForce RTX
3060/PCIe/SSE2 direct-render: Yes
Device-1: NVIDIA GA104 High Definition Audio vendor: PNY
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
link-max: gen: 4 speed: 16 GT/s bus-ID: 26:00.1 chip-ID: 10de:228b
class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 28:00.4 chip-ID: 1022:1487 class-ID: 0403
Device-3: Intel USB PnP Sound Device
driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 1.1 speed: 12 Mb/s
lanes: 1 mode: 1.1 bus-ID: 5-2:3 chip-ID: 8086:0808 class-ID: 0300
API: ALSA v: k6.4.4-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: alsactl,alsamixer,amixer
Server-1: PipeWire v: 0.3.75 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: f000 bus-ID: 22:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp34s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
IF-ID-1: br-0158dadbc9c5 state: down mac: <filter>
IF-ID-2: br-96ccd0623b5d state: up speed: 10000 Mbps duplex: unknown
mac: <filter>
IF-ID-3: docker0 state: up speed: 10000 Mbps duplex: unknown mac: <filter>
IF-ID-4: tailscale0 state: unknown speed: -1 duplex: full mac: N/A
IF-ID-5: veth1dd6268 state: up speed: 10000 Mbps duplex: full
mac: <filter>
IF-ID-6: vetha2daaf6 state: up speed: 10000 Mbps duplex: full
mac: <filter>
IF-ID-7: vethcbcfb37 state: up speed: 10000 Mbps duplex: full
mac: <filter>
IF-ID-8: virbr0 state: up speed: 10000 Mbps duplex: unknown mac: <filter>
IF-ID-9: vnet1 state: unknown speed: 10000 Mbps duplex: full mac: <filter>
Device-1: TP-Link UB500 Adapter driver: btusb v: 0.8 type: USB rev: 1.1
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-2:2 chip-ID: 2357:0604
class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Local Storage: total: 4.1 TiB used: 2.39 TiB (58.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: PC SN520
SDAPNUW-512G-1014 size: 476.94 GiB block-size: physical: 512 B
logical: 512 B speed: 15.8 Gb/s lanes: 2 tech: SSD serial: <filter>
fw-rev: 20110000 temp: 43.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000DM008-2FR102
size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
tech: HDD rpm: 7200 serial: <filter> fw-rev: 0001 scheme: GPT
ID-3: /dev/sdb maj-min: 8:16 vendor: Toshiba model: HDWD120 size: 1.82 TiB
block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s tech: HDD
rpm: 7200 serial: <filter> fw-rev: ACF0 scheme: GPT
ID-1: / raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 100.13 GiB (21.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 100.13 GiB (21.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 100.13 GiB (21.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 476.64 GiB size: 476.64 GiB (100.00%)
used: 100.13 GiB (21.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.27 GiB used: 143.5 MiB (0.4%)
priority: 100 dev: /dev/zram0
System Temperatures: cpu: 35.0 C mobo: 33.0 C gpu: nvidia temp: 57 C
Fan Speeds (RPM): fan-1: 1829 fan-2: 852 fan-3: 730 fan-4: 0 fan-5: 0
fan-6: 0 gpu: nvidia fan: 0%
Processes: 396 Uptime: 11h 21m wakeups: 0 Memory: total: 32 GiB
available: 31.27 GiB used: 18.09 GiB (57.9%) Init: systemd v: 253
default: graphical tool: systemctl Compilers: gcc: 13.1.1 Packages: pm: dpkg
pkgs: 0 pm: pacman pkgs: 1870 libs: 469 tools: octopi,pamac,paru Shell: fish
v: 3.6.1 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.28
Garuda (2.6.16-1):
System install date:     2023-07-22
Last full system update: 2023-07-23 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       No/Undetected
Failed units:            systemd-networkd-wait-online.service

delete those recycle bin and SVI folders, you'll need to right click and use the root actions to delete them and then set ownership on the inaccessible drive to your linux user account.

those remnant files from windows are useless to linux and should be removed if you're not using windows at all.

also be warned that windows will sometimes take ownership of a drive when accessed by dual boot or possibly even via a virtual machine.
i've never used a VM so i'm not exactly sure, but it stands to reason that it may do so.

it's happened to me before so i set my linux ssd's to 'offline' in the windows drive management app in the administrative tools section of the control panel to prevent any such issue.

for the record however, the Garuda team does not provide support for dual-boot systems, so you're pretty much on your own if you have one.

Can you be more specific which apps produce the behavior you are trying to describe?

What does the error say? Copy and paste the exact message into the thread if you can.

What file system is on the disk? How are you mounting it?

Paste the output of:

sudo parted -l


lsblk -o name,type,fstype,size,mountpoint

I have only music in that drive so most of the software which I ran into are music players and this is the message I receive every time when I try to acces that drive.

sudo parted -l

Model: ATA ST2000DM008-2FR1 (scsi)
Disk /dev/sda: 2000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags:

Number  Start   End     Size    File system  Name  Flags
1      1049kB  2000GB  2000GB  ntfs               msftdata

Model: ATA TOSHIBA HDWD120 (scsi)
Disk /dev/sdb: 2000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags:

Number  Start   End     Size    File system  Name  Flags
1      32,8kB  2000GB  2000GB  ntfs               msftdata

Model: WDC PC SN520 SDAPNUW-512G-1014 (nvme)
Disk /dev/nvme0n1: 512GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number  Start   End    Size   File system  Name  Flags
1      2097kB  317MB  315MB  fat32              boot, esp
2      317MB   512GB  512GB  btrfs        root

Model: Unknown (unknown)
Disk /dev/zram0: 33,6GB
Sector size (logical/physical): 4096B/4096B
Partition Table: loop
Disk Flags:

Number  Start  End     Size    File system     Flags
1      0,00B  33,6GB  33,6GB  linux-swap(v1)

lsblk -o name,type,fstype,size,mountpoint

sda         disk          1,8T
└─sda1      part ntfs     1,8T /media/disk2
sdb         disk          1,8T
└─sdb1      part ntfs     1,8T /media/disk1
zram0       disk         31,3G [SWAP]
nvme0n1     disk        476,9G
├─nvme0n1p1 part vfat     300M /boot/efi
└─nvme0n1p2 part btrfs  476,6G /var/tmp

Btw thats a good question. I’ve used Gnome’s disks, because I find it easy to manage and there was no problem when mounted them in the first place. So why the othere software showing me error?

Could not read the contents of disk2
Error when getting information for the file “/media/disk2/System Volume Information” : Input/output error

It's possible you have a few corrupted sectors on the drive. Windows has better tools for repairing NTFS than Linux, but ntfsfix is at least worth a shot.

sudo umount /dev/sda1
sudo ntfsfix /dev/sda1

If that doesn't work, there is not much for it but to load Windows and run its disk checking program, chkdsk:

If you are not going to use Windows on this system anymore, you should backup your data and format those disks to something other than NTFS as soon as you can.


sudo ntfsfix /dev/sda1

Mounting volume... OK
Processing of $MFT and $MFTMirr completed successfully.
Checking the alternate boot sector... OK
NTFS volume version is 3.1.
NTFS partition /dev/sda1 was processed successfully.

Still getting that same error.

can I do it in VM ? if not I need to install Windows again ? :frowning:

what format should I use if go this way? also I should format the both drives, not only the problematic one?

If you are done with Windows, I would format both drives. NTFS will continue to give you grief if you keep using it on Linux, and as you have discovered the Linux-side tools for repairing it are rather limited.

If you aren't sure what filesystem to format the drives, I would just make them ext4.

A VM should be fine for using the chkdsk tool, as long as it has access to the disk.

1 Like

Thank you for your help! I appreciate it!

I'm gonna try to fix it inside a VM tonight and write back how it went. The thing is, that the VM shows it like a folder, not like a drive, so I'm not sure weather that chkdsk tool would help. Let's see.

If the VM doesn't work out, another option would be to use Windows PE. It runs entirely in memory (like booting to the live environment before installing Linux), and is designed for running Windows tools for disk rescue, etc. You would boot it off a thumb drive or similar, so no need to cut Windows back in to your disk.


NTFS file systems can become easily corrupted in Linux systems. It’s happened to me several times over the years. Mostly, it seems, when copying over a large dataset. The solution is to use a Linux filesystem.

Regardless of the exact cause, the only ways I know of to recover a corrupted NTFS partition/drive is a Windows-based repair disk or Windows itself.

1 Like

Thank you for you suggestions! I managed to fix my issues with Hiren's BootCD PE and it was surprisingly easy. I just installed it on ext drive, booted the drive and from there I think windows knew exactly what is missing. I ran chkdsk on both of my drives and I even managed to delete some folders and symlinks which I couldn't before.

Now I have that $recyclebin and System Volume Folders back. So, do I need them? Should I keep them hided or should I delete them?

Thank you for your help!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.