Home Disk space gradually decreased till reached zero suddenly

Yesterday, the weirdest thing happened to me. I was deleting some files in my home directory(a tv series that i had just finished) and instead of space being freed out, nothing happened, then suddenly space started decreasing in front of my eyes till it reached 0 bytes.

The whole ui started acting up,then crashed and the whole system became extremely laggy, I forced shutdown the device, waited a few seconds and started again.

First of all, i checked the partition in filelight, to my surprise my 100 gb home partition contained 113 gb of data, second of all the Ui is totally destroyed, and animations are tearing and are not correct. - I will provide a screenshot- I noticed that the baloo index was taking 28 gb so i deleted it for now as i can rebuild it later.

I also tried timeshift before all that, and today i tried the linux lts kernel and it's the same result in both situations.

so Now I have about 30 gb free space, while all the other problems are there.

can someone tell me what the hell just happened?

output of inxi -Faz

System:    Kernel: 5.10.75-1-lts x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts root=UUID=5a31376c-873a-4e8e-bc94-fc848ec1ba42
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 resume=UUID=937e0c91-c630-428c-b79a-269814b701cb loglevel=3
Desktop: KDE Plasma 5.23.2 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:   Type: Laptop System: ASUSTeK product: ASUS TUF Gaming F15 FX506LI_FX506LI v: 1.0
serial: <filter>
Mobo: ASUSTeK model: FX506LI v: 1.0 serial: <filter> UEFI: American Megatrends v: FX506LI.309
date: 02/02/2021
Battery:   ID-1: BAT1 charge: 24.4 Wh (59.5%) condition: 41.0/48.2 Wh (85.1%) volts: 11.7 min: 11.9
model: ASUS A32-K55 type: Li-ion serial: N/A status: Unknown
CPU:       Info: Quad Core model: Intel Core i5-10300H bits: 64 type: MT MCP arch: Comet Lake family: 6
model-id: A5 (165) stepping: 2 microcode: EA cache: L2: 8 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 39999
Speed: 800 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800
6: 800 7: 800 8: 800
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel CometLake-H GT2 [UHD Graphics] vendor: ASUSTeK driver: i915 v: kernel
bus-ID: 00:02.0 chip-ID: 8086:9bc4 class-ID: 0300
Device-2: NVIDIA TU117M [GeForce GTX 1650 Ti Mobile] vendor: ASUSTeK driver: nvidia v: 470.74
alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1f95 class-ID: 0300
Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo bus-ID: 1-7:2
chip-ID: 13d3:56a2 class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: modesetting,nvidia
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")
Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6") diag: 395mm (15.5")
OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 21.2.4 direct render: Yes
Audio:     Device-1: Intel Comet Lake PCH cAVS vendor: ASUSTeK driver: snd_hda_intel v: kernel
alternate: snd_soc_skl,snd_sof_pci bus-ID: 00:1f.3 chip-ID: 8086:06c8 class-ID: 0403
Sound Server-1: ALSA v: k5.10.75-1-lts running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.39 running: yes
Network:   Device-1: Intel Comet Lake PCH CNVi WiFi driver: iwlwifi v: kernel bus-ID: 00:14.3
chip-ID: 8086:06f0 class-ID: 0280
IF: wlo1 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8169
v: kernel port: 3000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp3s0 state: down mac: <filter>
Bluetooth: Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-14:3
chip-ID: 8087:0026 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:    Local Storage: total: 1.14 TiB used: 867.29 GiB (74.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: PC SN530 SDBPNPZ-256G-1002
size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD
serial: <filter> rev: 21106000 temp: 31.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD10SPZX-22Z10T1 size: 931.51 GiB
block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400
serial: <filter> rev: 1A04 scheme: MBR
Partition: ID-1: / raw-size: 55 GiB size: 55 GiB (100.00%) used: 34.99 GiB (63.6%) fs: btrfs
dev: /dev/nvme0n1p6 maj-min: 259:6
ID-2: /boot/efi raw-size: 514.8 MiB size: 513.8 MiB (99.80%) used: 580 KiB (0.1%) fs: vfat
dev: /dev/nvme0n1p4 maj-min: 259:4
ID-3: /home raw-size: 100 GiB size: 100 GiB (100.00%) used: 68.05 GiB (68.0%) fs: btrfs
dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 55 GiB size: 55 GiB (100.00%) used: 34.99 GiB (63.6%) fs: btrfs
dev: /dev/nvme0n1p6 maj-min: 259:6
ID-5: /var/tmp raw-size: 55 GiB size: 55 GiB (100.00%) used: 34.99 GiB (63.6%) fs: btrfs
dev: /dev/nvme0n1p6 maj-min: 259:6
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 7.81 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/nvme0n1p5
maj-min: 259:5
ID-2: swap-2 type: zram size: 7.61 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 57.0 C mobo: 27.8 C
Fan Speeds (RPM): cpu: 0
Info:      Processes: 271 Uptime: 7m wakeups: 1 Memory: 7.61 GiB used: 2.2 GiB (28.9%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1517 lib: 428
flatpak: 0 Shell: fish v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.08

A screenshot of how my desktop currently looks like:

Have you emptied the trash?
How many snapshots do you have?
You can check Btrfs in the Garuda Assistent.

I shift+delete as i was sure i don't want these files anymore.

A lot actually but on a separate drive, I have a 55gb root partition on my ssd and a 100gb home partition on y hdd

Why was my post unlisted?

Big system error on my part, sorry.

I'd give a look at the status of the compositor for this.
In general, you may also want to check if a full btrfs balance is suggested in the Garuda Assistant.

1 Like

Also check the size of your logs and especially the size of your crash dumps.

2 Likes

This looks like a case of computer worm to me.

Don't panic. Just boot from a bootable usb, format the drive containing worm and reinstall.
Also, what exactly were you deleting btw?

1 Like

btw ... some context:

2 Likes

Just some videos I didn't want anymore nothing vital or system related.

What was there source? I obviously know that they were not vital, because there aren't any :joy:

Wait, my bad, you mentioned something in your post

Exactly what I had thought. You might have downloaded it from some filthy source, like Torrent or any unknown and untrustworthy website. I believe it is the case of worm.

But as I told you, don't worry. Just don't mount any other partition/ pen drive etc. Power off your computer immediately. And then plug in a bootable usb and boot into it. Now, again don't mount anything, and reinstall. Don't forget to format that partition.

Do you have any important data btw, that is on that partition and not backuped yet?

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.