High Frame times and low fps

Hello.

So i have very weird issue with games specifically steam games. Some of them run very slowly and by that i mean like 20-30 fps with frametimes going between 20-600. I tried almost every proton version from 4.2-9 to proton experimental and proton ge 7.0 but no matter what i do the problem persists. I encountered this issue before and what resolved it was completely reinstalling the whole system which i'd prefer to avoid. I also tried using linux-lts but it didn't seem to help. Also i tried different launch options in Sword Art Online fatal bullet as my test game and what semi helped was using those but some games like f1 2019 completely break when using them. Also the games i tried to play were: Need for speed Heat, SAO Fatal Bullet, Grid 2 and Warframe. The last one is the most playable because those issues randomly appear and then disappear. CSGO and 2d games seem to run fine those same as older games like postal 2. Also im a newbie when it comes to linux

gamemoderun mesa_glthread=true PROTON_USE_WINED3D11=1 RADV_PERFTEST=aco VK_ICD_FILENAMES=/usr/share/vulkan/icd.d/amd_icd32.json:/usr/share/vulkan/icd.d/amd_icd64.json %command%
System:
Kernel: 5.16.2-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=b6dde099-8cf7-4e35-8362-435fd7be6c77 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: Gigabyte product: B450M DS3H v: N/A
serial: <superuser required>
Mobo: Gigabyte model: B450M DS3H-CF v: x.x serial: <superuser required>
UEFI: American Megatrends v: F51 date: 07/29/2020
Battery:
Device-1: hidpp_battery_0
model: Logitech G305 Lightspeed Wireless Gaming Mouse serial: <filter>
charge: 100% (should be ignored) rechargeable: yes status: Discharging
CPU:
Info: model: AMD Ryzen 5 2600X bits: 64 type: MT MCP arch: Zen+
family: 0x17 (23) model-id: 8 stepping: 2 microcode: 0x800820D
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 576 KiB desc: d-6x32 KiB; i-6x64 KiB L2: 3 MiB desc: 6x512 KiB
L3: 16 MiB desc: 2x8 MiB
Speed (MHz): avg: 4005 high: 4042 min/max: 2200/3600 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 4030 2: 4041
3: 4013 4: 4041 5: 4042 6: 4041 7: 4040 8: 4010 9: 3938 10: 4040 11: 4020
12: 3805 bogomips: 86224
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
vendor: Micro-Star MSI driver: amdgpu v: kernel bus-ID: 06:00.0
chip-ID: 1002:67df class-ID: 0300
Display: x11 server: X.Org 1.21.1.3 compositor: kwin_x11 driver:
loaded: amdgpu,ati unloaded: modesetting alternate: fbdev,vesa
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1200 s-dpi: 96 s-size: 508x317mm (20.0x12.5")
s-diag: 599mm (23.6")
Monitor-1: HDMI-A-0 res: 1920x1200 hz: 60 dpi: 94
size: 518x324mm (20.4x12.8") diag: 611mm (24.1")
OpenGL: renderer: AMD Radeon RX 570 Series (POLARIS10 DRM 3.44.0
5.16.2-zen1-1-zen LLVM 13.0.0)
v: 4.6 Mesa 21.3.5 direct render: Yes
Audio:
Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus-ID: 06:00.1
chip-ID: 1002:aaf0 class-ID: 0403
Device-2: AMD Family 17h HD Audio vendor: Gigabyte driver: snd_hda_intel
v: kernel bus-ID: 08:00.3 chip-ID: 1022:1457 class-ID: 0403
Device-3: Razer USA RC30-026902 Gaming Headset [Nari Essential Wireless
Receiver]
type: USB driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-4:2
chip-ID: 1532:051e class-ID: 0300
Sound Server-1: ALSA v: k5.16.2-zen1-1-zen running: yes
Sound Server-2: sndio v: N/A running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.44 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Gigabyte driver: r8169 v: kernel port: f000 bus-ID: 04:00.0
chip-ID: 10ec:8168 class-ID: 0200
IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
Local Storage: total: 1.58 TiB used: 1.15 TiB (72.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 model: SATA3 240GB SSD size: 223.57 GiB
block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD
serial: <filter> rev: 8B0 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital
model: WD5000AAKS-07A7B2 size: 465.76 GiB block-size: physical: 512 B
logical: 512 B speed: 3.0 Gb/s type: N/A serial: <filter> rev: 3B01
scheme: MBR
ID-3: /dev/sdc maj-min: 8:32 vendor: Seagate model: ST1000DM010-2EP102
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: CC43
scheme: GPT
Partition:
ID-1: / raw-size: 223.27 GiB size: 223.27 GiB (100.00%)
used: 201.76 GiB (90.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 223.27 GiB size: 223.27 GiB (100.00%)
used: 201.76 GiB (90.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 223.27 GiB size: 223.27 GiB (100.00%)
used: 201.76 GiB (90.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 223.27 GiB size: 223.27 GiB (100.00%)
used: 201.76 GiB (90.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.64 GiB used: 2.34 GiB (14.9%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 16.8 C mobo: N/A gpu: amdgpu temp: 54.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 205
Info:
Processes: 471 Uptime: 6h 53m wakeups: 7 Memory: 15.64 GiB
used: 8.1 GiB (51.8%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 2068 lib: 574 flatpak: 0
Shell: fish v: 3.3.1 default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.12
Garuda (2.5.3-1):
System install date:     2021-11-25
Last full system update: 2022-01-31
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:            bluetooth-autoconnect.service systemd-guest-user.service

Without it, you will not receive any help from the Garuda team or your topic is likely to be closed without notice.

Before you open a new help request, read relevant sections of the Arch and Garuda wiki.
Thoroughly search your issue and any error messages in the forum and on the web.

Report everything you have already attempted to solve your problem.

You're explicitly using AMDVLK. Try RADV instead.

3 Likes

I can almost say for certain your Warframe issues is because its building shader cache on new areas. I play that game quite a lot.
Just for future reference, Warframe works pretty good other than alt-tabbing. Avoid doing that; its pretty much a coin-flip each time for the chances on it to crash while doing that.

Most games don't need all of those flags going, by the way. Some flags only be added if you are having rendering issues in certain games (like not all elements or graphical layers are loading). Running some flags on heavy 3D games will make them run much worse. gamemoderun is perfectly fine to use, but other than that, seek recommendations per game (if things don't run well out of the box) from https://www.protondb.com/

2 Likes

I was having a similar issue with Valheim (only game I've been playing for a few weeks). I was gonna say I just did a Reinstall All Packages from Garuda Assistant to resolve the issue... but it seems you want to avoid that and know a specific resolution... :stuck_out_tongue:

I was referring to reinstalling the whole system. Reinstalling the packages is fine. Hopefully it will help. Well after reinstalling all the packages from garuda assistant it seems it didn't fix the issue.

i do have shader pre caching turned on shouldn't it help?

I tried both and neither of them seemed to fix it in either F1 2019 and SAO FB(those were the only 2 games i tested the commands on). For SAO FB what fixed it was PROTON_USE_WINED3D11=1. Can't use mangohud anymore but the framerate seems stable at 60fps (the in game limit) and there aren't any stutters apart from when first loading into the game. When i tried using the command in F1 2019 there were a lot of visual glitches but the frametimes and framerates were back to normal.