Hibernation doesn't work

I found that hibernation does't not work. When I was installing Garuda, I have selected swap for hibernation. When I try to hybernate system by clicking on main menu or by command systemctl hibernate the system is shut down and after I turn it on the desktop is clean as it was turned off by shutdown command.
I was trying to find out solution by myself, in arch wiki I found that kernel parametr should contain resume=UUID=... so I checked it out and it is ok resume=/dev/mapper/luks-50d49f5f-1fc0-4d79-932d-ae062518669d
here is my swapon --show
NAME TYPE SIZE USED PRIO
' /dev/dm-1 partition 17,2G 0B -2
/dev/zram0 partition 1,3G 0B 32767
/dev/zram1 partition 1,3G 0B 32767
/dev/zram2 partition 1,3G 0B 32767
/dev/zram3 partition 1,3G 0B 32767
/dev/zram4 partition 1,3G 0B 32767
/dev/zram5 partition 1,3G 0B 32767
/dev/zram6 partition 1,3G 0B 32767
/dev/zram7 partition 1,3G 0B 32767
/dev/zram8 partition 1,3G 0B 32767
/dev/zram9 partition 1,3G 0B 32767
/dev/zram10 partition 1,3G 0B 32767
/dev/zram11 partition 1,3G 0B 32767'

and bash -c 'grep -E "swap|var" /etc/fstab'
/dev/mapper/luks-a9e20eba-17d5-498c-8f0f-a342d303cd5c /var/cache btrfs subvol=@cache,defaults,noatime,space_cache,autodefrag,compress=zstd,ssd,commit=120 0 2
/dev/mapper/luks-a9e20eba-17d5-498c-8f0f-a342d303cd5c /var/log btrfs subvol=@log,defaults,noatime,space_cache,autodefrag,compress=zstd,ssd,commit=120 0 2
/dev/mapper/luks-a9e20eba-17d5-498c-8f0f-a342d303cd5c /var/tmp btrfs subvol=@tmp,defaults,noatime,space_cache,autodefrag,compress=zstd,ssd,commit=120 0 2
/dev/mapper/luks-50d49f5f-1fc0-4d79-932d-ae062518669d swap swap defaults,noatime 0 0

I have 16 gb of RAM.
What else should I do to have hibernation work on?

Read the forum threads concerning such.

4 Likes

I read other threads but it didn't help me.

Hello -

Just installed Garuda Linux and love it! I also had problem as you setting up Hibernation with Full Disk Encrypted. Here is how I fixed it (just in case others have the same problem).

Edit the file:

sudo vi /etc/openswap.conf

Change

keyfile_filename=crypto_keyfile.bin

to

keyfile_filename=@/crypto_keyfile.bin

The issue is that the openswap hook in mkinitcpio doesn’t account for it being a BTRFS file system and it tries to open the key file in the root drive without the “@”.

Hope this helps someone. I tried searching the forums for the solution and I didn’t find anything. So sorry if this was already solved.

Don’t forget to rebuild the

mkinitcpio -P

3 Likes

:slight_smile:

We prefer micro instead of vi :smiley:

No one knows how to close it :wink:

2 Likes

Haha. Will need to learn micro. I was wondering why vi wasn't installed by default. :smile:

2 Likes

image

image

3 Likes

Hi agonzalez,

just to complete your answer. I think a better way is to change

#keyfile_device_mount_options="--options=subvol=__active/__"

to

keyfile_device_mount_options="--options=subvol=@"

on openswap.conf.

tenorio

2 Likes

I don't believe you have provided your system specs.

We could use that info, please post:

inxi -Fxxxza 

Please do not post outputs as text.

Have you checked the Archwiki yet for an entry on your specific laptop model?

Has hibernation ever worked properly on your laptop?

Is your bios up to date?

Have you tested multiple kernels?

If the laptop is new, test the linux-mainline kerernel. Be sure to test at least 4 alternate kernels including the LTS kernel.

These Questions and suggestions are for the originator of this thread. If you are not the OP and you wish your hibernation issue looked at then open your own help request thread with your own system specs attached.

Edit:

I am locking this thread as the OP has not visited the forum for several months. If the OP wishes to revisit this thread drop a moderator a PM and they will reopen your thread.

Others wishing their hibernation issue addressed please open your own help request.

4 Likes