Hi folks how are you using kdeconnect with port blocking?

Hello Garuda users.

I have one issue is that I think my ISP is not providing PORT unblocking so I mean kdeconnect app is only work with port between 1714-1764 right? I mean your mobile and laptop should be on the same router's wifi and your router should provide port range open from 1714-1764 so if there is issue with ISP what can we do is there any other alternative?

I hope most of the folks in india at least uses Jio. Then those would be also facing the same issue. So basically I tried it but my mobile not got listed in kdeconnect.

Kernel: 6.3.4-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=d81c9e20-12ce-4bca-a5bd-4199f01659e5 rw rootflags=subvol=@
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=e2f828e9-a24d-4ebb-b265-9c39b304a139 loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.5 tk: Qt v: 5.15.9 wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Type: Laptop System: Dell product: Inspiron 5593 v: N/A
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: Dell model: 0HP5Y9 v: A00 serial: <superuser required> UEFI: Dell
v: 1.26.0 date: 03/13/2023
ID-1: BAT0 charge: 19.5 Wh (89.4%) condition: 21.8/42.0 Wh (52.0%)
volts: 12.9 min: 11.4 model: BYD DELL 1VX1H99 type: Li-ion serial: <filter>
status: charging
Info: model: Intel Core i5-1035G1 bits: 64 type: MT MCP arch: Ice Lake
gen: core 10 level: v4 note: check built: 2019-21 process: Intel 10nm
family: 6 model-id: 0x7E (126) stepping: 5 microcode: 0xBA
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 2 MiB desc: 4x512 KiB L3: 6 MiB
desc: 1x6 MiB
Speed (MHz): avg: 1149 high: 1396 min/max: 400/3600 scaling:
driver: intel_pstate governor: powersave cores: 1: 999 2: 1300 3: 629
4: 1300 5: 1048 6: 1300 7: 1396 8: 1224 bogomips: 19046
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel Iris Plus Graphics G1 vendor: Dell driver: i915 v: kernel
arch: Gen-11 process: Intel 10nm built: 2019-21 ports: active: eDP-1
empty: HDMI-A-1 bus-ID: 0000:00:02.0 chip-ID: 8086:8a56 class-ID: 0300
Device-2: NVIDIA GP108M [GeForce MX230] vendor: Dell driver: nouveau
v: kernel non-free: 530.xx+ status: current (as of 2023-05) arch: Pascal
code: GP10x process: TSMC 16nm built: 2016-21 bus-ID: 0000:01:00.0
chip-ID: 10de:1d11 class-ID: 0302
Device-3: Microdia Integrated_Webcam_HD driver: uvcvideo type: USB
rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-6:4 chip-ID: 0c45:671e
class-ID: 0e02
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.1
compositor: kwin_x11 driver: X: loaded: modesetting,nouveau
alternate: fbdev,intel,nv,vesa dri: iris,nouveau gpu: i915 display-ID: :0
screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 model: LG Display 0x05f2 built: 2018 res: 1920x1080
hz: 60 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5")
ratio: 16:9 modes: 1920x1080
API: OpenGL v: 4.6 Mesa 23.1.0 renderer: Mesa Intel UHD Graphics (ICL GT1)
direct-render: Yes
Device-1: Intel Ice Lake-LP Smart Sound Audio vendor: Dell
driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_icl
bus-ID: 0000:00:1f.3 chip-ID: 8086:34c8 class-ID: 0403
API: ALSA v: k6.3.4-zen1-1-zen status: kernel-api tools: N/A
Server-1: PipeWire v: 0.3.71 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell
driver: r8169 v: kernel port: 3000 bus-ID: 0000:02:00.0 chip-ID: 10ec:8136
class-ID: 0200
IF: enp2s0 state: down mac: <filter>
Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
vendor: Dell driver: ath10k_pci v: kernel bus-ID: 0000:03:00.0
chip-ID: 168c:0042 class-ID: 0280
IF: wlp3s0 state: up mac: <filter>
IF-ID-1: br-c680a8bca5ba state: down mac: <filter>
IF-ID-2: docker0 state: down mac: <filter>
Device-1: Qualcomm Atheros driver: btusb v: 0.8 type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-10:5 chip-ID: 0cf3:e009
class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode]
driver: intel_nvme_remap v: N/A port: 5060 bus-ID: 0000:00:17.0
chip-ID: 8086:282a rev: N/A class-ID: 0104
Local Storage: total: 1.38 TiB used: 32.85 GiB (2.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix model: BC511 NVMe 512GB
size: 476.94 GiB block-size: physical: 512 B logical: 512 B tech: SSD
serial: <filter> fw-rev: 11001101 temp: 43.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM049-2GH172
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
tech: HDD rpm: 7200 serial: <filter> fw-rev: SDM2 scheme: GPT
ID-1: / raw-size: 467.84 GiB size: 467.84 GiB (100.00%)
used: 32.84 GiB (7.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 467.84 GiB size: 467.84 GiB (100.00%)
used: 32.84 GiB (7.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 467.84 GiB size: 467.84 GiB (100.00%)
used: 32.84 GiB (7.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 467.84 GiB size: 467.84 GiB (100.00%)
used: 32.84 GiB (7.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.53 GiB used: 1.58 GiB (20.9%)
priority: 100 dev: /dev/zram0
ID-2: swap-2 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/nvme0n1p3 maj-min: 259:3
System Temperatures: cpu: 79.0 C mobo: 58.0 C gpu: nouveau temp: 63.0 C
Fan Speeds (RPM): cpu: 5291
Processes: 272 Uptime: 1h 0m wakeups: 63269 Memory: available: 7.53 GiB
used: 5.6 GiB (74.3%) Init: systemd v: 253 default: graphical
tool: systemctl Compilers: gcc: 13.1.1 Packages: pm: pacman pkgs: 1200
libs: 330 tools: octopi,paru Shell: fish v: 3.6.1 default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.27
Garuda (2.6.16-1):
System install date:     2023-05-27
Last full system update: 2023-05-28
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       No/Undetected
Failed units:

If the two devices are on the same network, you shouldn't need your ISP to be involved in any way. You may need to simply amend your firewall rules. From the KDE wiki:

I have two devices running KDE Connect on the same network, but they can't see each other

KDE Connect uses dynamic ports in the range 1714-1764 for UDP and TCP. So if you are behind a firewall, make sure to open this port range for both TCP and UDP. Otherwise, make sure your network is not blocking UDP broadcast packets.

Check that the process is listening on the network:

sudo netstat -tunelp | grep -i kdeconnect

Are the ports open/blocked?

netcat -z -v <your-phones-ip> 1714-1764

Example output:

Connection to <your -phones-ip> 1716 port [tcp/*] succeeded!

You also get lots of Connection refused, but you need 1 “succeeded”

If the the network connection is not the problem, you might try starting from a clean configuration again:

killall kdeconnectd 
mv ~/.config/kdeconnect ~/.config/kdeconnect.bak


If your firewall is ufw, you can open the necessary ports with:

sudo ufw allow 1714:1764/udp 
sudo ufw allow 1714:1764/tcp 
sudo ufw reload


If your firewall is firewalld, you can open the necessary ports with:

sudo firewall-cmd --permanent --zone=public --add-service=kdeconnect 
sudo firewall-cmd --reload

Firewall Configuration (firewall-config)

Open Firewall Configuration (firewall-config). In ZonesServices, check the kde-connect service.

Make sure you choose the "Permanent" Configuration: option in the drop-down menu at the top, otherwise rebooting will discard your settings changes.


If your firewall is iptables, you can open the necessary ports with:

sudo iptables -I INPUT -i <yourinterface> -p udp --dport 1714:1764 -m state --state NEW,ESTABLISHED -j ACCEPT 
sudo iptables -I INPUT -i <yourinterface> -p tcp --dport 1714:1764 -m state --state NEW,ESTABLISHED -j ACCEPT 
sudo iptables -A OUTPUT -o <yourinterface> -p udp --sport 1714:1764 -m state --state NEW,ESTABLISHED -j ACCEPT 
sudo iptables -A OUTPUT -o <yourinterface> -p tcp --sport 1714:1764 -m state --state NEW,ESTABLISHED -j ACCEPT

In my case this get's stuck and doesn't output anything, so doesn't <your-phones-ip> is actually the router's IP where phone and laptop both connected?

So in this case my laptop's IP and phone's IP are the same right? could it be because my router doesn't have static IP, but in that case as well it should work right for example let's say for this day I assigned somekind of static IP then it should work for that day, for other day maybe I have to reconnect if IP is changed.

If your phone is connected to your network (through WiFi, for example) then it should be getting assigned a private IP address through DHCP. Your computer, and any other devices on the network, will get a private IP address as well. These are non-routable IP addresses, meaning they are not addresses that are valid outside of your network. They normally fall in the 192.168.xxxx.xxxx address range, but can be in other private ranges as well depending on your router.

Your ISP has nothing to do with these addresses, and in fact can't even see them unless they have access to your network's gateway (not common, even for very snoopy ISPs).

I know what you mean by this: in a way, the two devices have the same IP address--from an external network. In fact, the externally-facing IP address on your network is the IP address of your gateway. Your phone and computer are not directly connected to the internet, they connect through the gateway and technically do not have an externally-facing IP address of their own.

Anyway, the IP address you want is the private one. You can find it on your phone by going to Settings -> About phone and scroll down to the IP address section. The local address will be in a non-routable address range (probably 192.168.xxxx.xxxx). On my phone it is the last address listed in the section.

On your computer you can run ip address show and look for the inet entry on the interface you are using. For example:

ip address show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: wlp170s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether f4:26:79:6a:c1:47 brd ff:ff:ff:ff:ff:ff
    inet brd scope global noprefixroute wlp170s0
       valid_lft forever preferred_lft forever

The "1: lo:" section is related to the loopback address, just ignore that. In the "2: wlp170s0:" section, right after the inet and before the subnet mask (/24) you can see the IP address is

wlp170s0 is the interface in use in this example, by the way.

Another way to get these IP addresses is just log in to your router's admin panel (if you have access to it) and just look at the devices on your network from there.

I hope that helps. :slightly_smiling_face:


Thanks you so much for your explanation.

Somehow my Laptop got showed up in my mobile, I don't know why but I was just doing some work on my laptop while keeping my mobile aside and when I saw on mobile it got listed out.

I don't know the reason but when I was waiting for pairing it didn't showed up.

I was actually thinking I would need VPN, but your explanation is very helpful. :heart:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.