Help with grub

Hello Garuda users.

This shoulod have been in newbie but just cause I searched in wikies before asking here I posted here and I dont think there is any konsole output to post.

So I have grub installed in my boot partition and also in my root partition(garuda btrfs partition)(idk why)
and the boot partition is marked as bootable but it boots to root partition

How I got into this:
My mom can only use this if grub menu option name is ubuntu so I renamed and and added a bracket in everything else than main system boot option.
Updates readded the option so I commented out os-prober part and copy pasted everything from grub.cfg(boot partition) in 40_custom and it worked well for a week-ish but the next time it was booting into root.

I searched and tried many ways that I dont even remember the first way

Welcome :slight_smile:

I move it from Issues & Assistance to Unsupported Software (AUR & Other) .

Wrong. Post your garuda-inxi, please, as text. Also

lsblk -f

If you change certain things, updates will stop working properly and make the system unusable.

If you break it, you fix it yourself.


I did uncomment what I commented out and here is the inxi and lsblk

Kernel: 6.4.3-zen1-2-zen arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
parameters: BOOT_IMAGE=/vmlinuz-linux-zen
root=UUID=e67771ce-22cc-4de3-822b-507289c04040 rw rootflags=subvol=@
loglevel=3 quiet
Desktop: KDE Plasma v: 5.27.6 tk: Qt v: 5.15.10 wm: kwin_x11 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Type: Portable System: Dell product: Inspiron 3521 v: A11 serial: <filter>
Chassis: type: 8 v: A11 serial: <filter>
Mobo: Dell model: 0JYTX5 v: A00 serial: <filter> UEFI-[Legacy]: Dell
v: A11 date: 08/29/2013
ID-1: BAT1 charge: 2.6 Wh (10.8%) condition: 24.0/41.4 Wh (57.8%)
volts: 15.5 min: 14.8 model: Simplo DELL FW1MN31P type: Unknown
serial: <filter> status: charging
Info: model: Intel Core i3-3217U socket: rPGA988B (U3E1) note: check
bits: 64 type: MT MCP arch: Ivy Bridge gen: core 3 level: v2 built: 2012-15
process: Intel 22nm family: 6 model-id: 0x3A (58) stepping: 9
microcode: 0x17
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 3 MiB desc: 1x3 MiB
Speed (MHz): avg: 1763 high: 1796 min/max: 800/1800 base/boost: 1800/4000
scaling: driver: intel_cpufreq governor: performance volts: 0.9 V
ext-clock: 100 MHz cores: 1: 1707 2: 1796 3: 1796 4: 1754 bogomips: 14367
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel 3rd Gen Core processor Graphics vendor: Dell driver: i915
v: kernel arch: Gen-7 process: Intel 22nm built: 2012-13 ports:
active: LVDS-1 empty: DP-1,HDMI-A-1,VGA-1 bus-ID: 00:02.0
chip-ID: 8086:0166 class-ID: 0300
Device-2: Realtek Integrated Webcam HD driver: uvcvideo type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-1.4:5 chip-ID: 0bda:58c2
class-ID: 0e02 serial: <filter>
Display: server: X.Org v: 21.1.8 with: Xwayland v: 23.1.2
compositor: kwin_x11 driver: X: loaded: modesetting
alternate: fbdev,intel,vesa dri: crocus gpu: i915 display-ID: :0
screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
s-diag: 414mm (16.31")
Monitor-1: LVDS-1 model: LG Display 0x03ab built: 2012 res: 1366x768
hz: 60 dpi: 101 gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5")
ratio: 16:9 modes: 1366x768
API: OpenGL v: 4.2 Mesa 23.1.3 renderer: Mesa Intel HD Graphics 4000 (IVB
GT2) direct-render: Yes
Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Dell 7
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20
class-ID: 0403
API: ALSA v: k6.4.3-zen1-2-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 0.3.73 status: n/a (root, process) with:
1: pipewire-pulse status: active 2: wireplumber status: active
3: pipewire-alsa type: plugin 4: pw-jack type: plugin
tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell
driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 2000
bus-ID: 01:00.0 chip-ID: 10ec:8136 class-ID: 0200
IF: enp1s0 state: down mac: <filter>
Device-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter
vendor: Dell driver: ath9k v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
bus-ID: 02:00.0 chip-ID: 168c:0036 class-ID: 0280
IF: wlp2s0 state: up mac: <filter>
Device-1: Qualcomm Atheros AR9462 Bluetooth driver: btusb v: 0.8 type: USB
rev: 1.1 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-1.1:6
chip-ID: 0cf3:0036 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Local Storage: total: 465.76 GiB used: 36.01 GiB (7.7%)
ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST500LT012-1DG142
family: Laptop HDD size: 465.76 GiB block-size: physical: 4096 B
logical: 512 B sata: 3.0 speed: 6.0 Gb/s tech: HDD rpm: 5400
serial: <filter> fw-rev: SDM1 temp: 40 C scheme: MBR
SMART: yes state: enabled health: PASSED on: 1y 88d 9h cycles: 7618
read: 31.8 TiB written: 20.29 TiB Old-Age: g-sense error rate: 3239
Pre-Fail: attribute: Spin_Retry_Count value: 100 worst: 100 threshold: 97
ID-1: / raw-size: 296.56 GiB size: 296.56 GiB (100.00%)
used: 35.88 GiB (12.1%) fs: btrfs block-size: 4096 B dev: /dev/sda5
maj-min: 8:5
ID-2: /boot raw-size: 200 MiB size: 196 MiB (98.00%)
used: 127.8 MiB (65.2%) fs: vfat block-size: 512 B dev: /dev/sda1
maj-min: 8:1
ID-3: /home raw-size: 296.56 GiB size: 296.56 GiB (100.00%)
used: 35.88 GiB (12.1%) fs: btrfs block-size: 4096 B dev: /dev/sda5
maj-min: 8:5
ID-4: /var/log raw-size: 296.56 GiB size: 296.56 GiB (100.00%)
used: 35.88 GiB (12.1%) fs: btrfs block-size: 4096 B dev: /dev/sda5
maj-min: 8:5
ID-5: /var/tmp raw-size: 296.56 GiB size: 296.56 GiB (100.00%)
used: 35.88 GiB (12.1%) fs: btrfs block-size: 4096 B dev: /dev/sda5
maj-min: 8:5
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 3.74 GiB used: 691 MiB (18.1%) priority: 100
dev: /dev/zram0
System Temperatures: cpu: 61.0 C mobo: N/A
Fan Speeds (RPM): cpu: 4400
Processes: 218 Uptime: 53m wakeups: 2 Memory: available: 3.74 GiB
used: 2 GiB (53.4%) Init: systemd v: 253 default: graphical tool: systemctl
Compilers: gcc: 13.1.1 clang: 15.0.7 Packages: 2072 pm: pacman pkgs: 2066
libs: 572 tools: octopi,paru pm: flatpak pkgs: 6 Shell: garuda-inxi (sudo)
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.27
Garuda (2.6.16-1):
System install date:     2023-05-23
Last full system update: 2023-07-11
Is partially upgraded:   Yes
Relevant software:       snapper(custom) NetworkManager dracut
Windows dual boot:       No/Undetected
Failed units:
├─sda1 vfat   FAT32       E4F7-6490                              68.2M    65% /boot
├─sda2 ntfs               BC6A167E6A16359C
└─sda5 btrfs              e67771ce-22cc-4de3-822b-507289c04040  257.9G    12% /var/log
zram0                                                                         [SWAP]

btw I do dual-boot (I use ReviOS maybe thats why inxi couldn't detect it


I was adding it


lsblk -f
NAME        FSTYPE FSVER LABEL       UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
zram0                                                                                    [SWAP]
├─nvme0n1p1 vfat   FAT32 SYSTEM_DRV  94BA-ECE1                             221,1M    14% /boot/efi
├─nvme0n1p3 ntfs         Windows-SSD A2A8BB95A8BB6707                                    
├─nvme0n1p4 ntfs         WINRE_DRV   B8F6BC25F6BBE234                                    
├─nvme0n1p5 btrfs        KDE         fc62cc44-07ab-497b-ac89-15704c290993                
├─nvme0n1p6 btrfs        Hyprland    7ef49644-ecb9-48da-88a7-a2056b7e5164                
└─nvme0n1p7 btrfs        i3wm        21e02e96-0ed6-4629-9a39-85ffee7a4359                /var/tmp

I think you need /boot/efi in sda1.

GRUB_DISABLE_OS_PROBER=false in /etc/default/grub

sudo grub-install 
sudo update-grub


sudo grub-install /dev/sda1
sudo update-grub

M$, we do not support win dual boot :slight_smile:

1 Like

I left out one thing, I am in BIOS(Legacy)MBR.
I tried all of that, reinstalling grub. deleting grub on root.and reinstalling grub stopped detecting garuda linux so I booted into live usb and chrooted from there and fixed that(os-prober btrfs not working was the problem) and also installed missing kernel files so that I can boot from grub command line.

I'm not a specialist in this field, and unfortunately I can't help you any further.
Maybe others have a solution.

inxi just reminded me of garuda-update command

I’m a bit lost in this thread and I too forgot how BIOS Legacy MBR systems work. :blush:
Anyway, the GRUB in your case should be installed with

sudo grub-install /dev/sda 
sudo update-grub 

and in this way, ifI remember correctly, it will go in the “the post-MBR gap”, not in the first partition.


still boots into root
(I added an extra option in root(ran update-grub after unmounting sda1) saying fix grub)

I set root partition as bootable and reset it as the boot partition a few times ( over 10 times) and it works now

after trying filo's suggestion

1 Like

I also regenerated fstab (followed arch linux installation guide) after doing this

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.