HELP! no sound!

Hello everyone, this is my first post here and I want to apologize ahead of time to anyone who gets triggered by me being a forum noob and posting like its facebook lol I get it now and I want to thank everyone who is trying to help :pray: :pray: :pray:

I just installed Garuda for my first linux distro and i have no sound. i installed pulse audio volume control and it shows my sound cards as (unplugged)

im on a galaxy book 2 pro 360

here is the required command text:

System:
Kernel: 6.0.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=d658b71c-eb70-4abc-8b48-0adedd3e6704 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.26.3 tk: Qt v: 5.15.7 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Convertible System: SAMSUNG product: 950QED v: P08AKK
serial: <superuser required> Chassis: type: 31 serial: <superuser required>
Mobo: SAMSUNG model: NP950QED-KB1US
v: SGLB182A1Z-C01-G002-S0001+10.0.22000 serial: <superuser required>
UEFI: American Megatrends LLC. v: P08AKK.680.220621.SH date: 06/21/2022
Battery:
ID-1: BAT1 charge: 31.8 Wh (46.9%) condition: 67.8/66.8 Wh (101.4%)
volts: 16.0 min: 15.4 model: SAMSUNG Electronics SR Real Battery
type: Li-ion serial: <filter> status: charging cycles: 11
CPU:
Info: model: 12th Gen Intel Core i7-1260P bits: 64 type: MST AMCP
arch: Alder Lake level: v3 note: check built: 2021+
process: Intel 7 (10nm ESF) family: 6 model-id: 0x9A (154) stepping: 3
microcode: 0x421
Topology: cpus: 1x cores: 12 mt: 4 tpc: 2 st: 8 threads: 16 smt: enabled
cache: L1: 1.1 MiB desc: d-8x32 KiB, 4x48 KiB; i-4x32 KiB, 8x64 KiB
L2: 9 MiB desc: 4x1.2 MiB, 2x2 MiB L3: 18 MiB desc: 1x18 MiB
Speed (MHz): avg: 1558 high: 2500 min/max: 400/4700:3400 scaling:
driver: intel_pstate governor: powersave cores: 1: 974 2: 2500 3: 982 4: 684
5: 766 6: 2500 7: 983 8: 2500 9: 826 10: 671 11: 2500 12: 1092 13: 453
14: 2500 15: 2500 16: 2500 bogomips: 79872
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
filling, PBRSB-eIBRS: SW sequence
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel Alder Lake-P Integrated Graphics vendor: Samsung Co
driver: i915 v: kernel arch: Gen-12.2 process: Intel 10nm built: 2021-22+
ports: active: eDP-1 empty: DP-1, DP-2, DP-3, DP-4, DP-5 bus-ID: 00:02.0
chip-ID: 8086:46a6 class-ID: 0300
Device-2: Sunplus Innovation 1080p FHD Camera type: USB driver: uvcvideo
bus-ID: 3-6:4 chip-ID: 1bcf:2d05 class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.5
compositor: kwin_x11 driver: gpu: i915 note: X driver n/a display-ID: :0
screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 model: Samsung 0x4159 built: 2020 res: 1920x1080 hz: 60
dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5")
ratio: 16:9 modes: 1920x1080
API: OpenGL v: 4.6 Mesa 22.2.3 renderer: Mesa Intel Graphics (ADL GT2)
direct render: Yes
Audio:
Device-1: Intel Alder Lake PCH-P High Definition Audio vendor: Samsung Co
driver: sof-audio-pci-intel-tgl
alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 00:1f.3
chip-ID: 8086:51c8 class-ID: 0401
Sound API: ALSA v: k6.0.2-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.60 running: yes
Network:
Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:51f0 class-ID: 0280
IF: wlo1 state: up mac: <filter>
Bluetooth:
Device-1: Intel type: USB driver: btusb v: 0.8 bus-ID: 3-10:6
chip-ID: 8087:0033 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Drives:
Local Storage: total: 953.87 GiB used: 9.48 GiB (1.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: MZVLQ1T0HBLB-00B
size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 type: SSD serial: <filter> rev: FXM7AK1Q temp: 29.9 C scheme: GPT
Partition:
ID-1: / raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 9.48 GiB (1.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 608 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 9.48 GiB (1.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 9.48 GiB (1.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 9.48 GiB (1.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.24 GiB used: 37.5 MiB (0.2%)
priority: 100 dev: /dev/zram0
Sensors:
Src: /sys System Temperatures: cpu: 55.0 C mobo: N/A
Fan Speeds (RPM): N/A
Power: 12v: N/A 5v: 5 3.3v: N/A vbat: N/A
Info:
Processes: 370 Uptime: 3h 22m wakeups: 9960 Memory: 15.24 GiB
used: 6.53 GiB (42.9%) Init: systemd v: 252 default: graphical
tool: systemctl Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1516
libs: 391 tools: gnome-software,octopi,pamac,paru Shell: fish v: 3.5.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.23
Garuda (2.6.9-1):
System install date:     2022-11-19
Last full system update: 2022-11-19 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Timeshift
Failed units:

The "↻" symbol means that you should restart. Most of the time on a new install there will be a lot of new things to update. Things like newer kernels and the like won't be in use until after a restart.

ohhhhh okay thank you! Ill restart and report back!

This did not fix it sadly :face_exhaling:

i wish I could post pictures

I've found that pulse audio does not work that well anymore. Go over Garuda's Assistant tool and find the audio section, change from pulse to pipewire. Give it a restart and see if it works.

I've looked up your model on the Arch wiki, and it should work with the additional packages that are already available for ALSA (that Garuda has already in its KDE package lists).
I am unsure what exactly you installed for a volume control and Garuda doesn't use pulse by default (piprewire instead). Does anything show up in the volume controls within KDE's settings? (system settings -> Audio)

2 Likes

garuda-Inxi says pipewire already.

1 Like

Welcome :slight_smile:

Please do no not post like in a chat room.
Edit your last post as long as no one has replied to it. Thank you.

Maybe it is related to jamesdsp?

1 Like

okay i am going to uninstall pulse and get piprewire going again but where do i access kde settings? Im so sorry im a brand new baby boy when it comes to linux lol

i guess just hold my hand there please? haha

hit your windows (AKA meta or super key) or click to bring up the menu. In the search field, search "System Settings" (should also be the gear wheel icon in the dock by default).

Within system settings there is a search in the upper left.
Search for "Audio", and click on the left field where it says "Audio" after the search.

we got another problem, turns out when i installed pulse audio volume manager i also installed a bunch of other pulse apps and I cant uninstall them because they all have dependencies and i followed the dependencies pretty far and i got into what looked like important files, I didnt remove anything but i think i am going to have to do a restore or re install garuda

Sorry about that, I am also pretty new to forums lol

You could restore a snapshot from before you installed the pulse stuff Restoring snapshots to get the system back to working state | Garuda Linux wiki (something good to learn as its one of Garuda's strong points and will help with avoiding reinstalling the whole system down the road if you do a few mistakes with installing things)
Depending on when it was, you should probably garuda-update the system again after restoring a snapshot and then restarting again.

okay i loaded a snapshot from before i installed any pulse anything and I checked for audio again, maybe i should specify i have only tried playing anything through youtube until now but i tried to play a song from my library just now and still no luck.

i see what your saying now :man_facepalming:

In KDE's audio settings (same settings as before), have you hit the Test button on different audio sources and then try hitting the left/right speaker tests? There might be an audio source that is not familiarly named for you.

If you do find something that works on the tests and you've selected it as your audio device but somehow don't hear anything else with it still, open the Audio Volume by clicking on the volume icon that is at the top of your screen. Next to your selected audio device, click the hamburger menu (three lines) and select "Play all audio on this device". Also be sure the audio levels are high enough to hear and that Applications listed in that menu aren't muted and are at a high volume.

If you find afterwards that some things aren't working still (like Youtube audio until the volume icon is clicked), users have reported issues with jamesdsp like SGS pointed out. Remove jamesdsp (or take it off autostart) and restart.

1 Like

Alright I plugged some headphones in and got sound immediately. i am only able to see my audio device when I click show inactive devices.

heres what happens without inactive devices shown