Help installing Nvidia hybrid drivers (auto install feature tried already )

Sorry! I meant to include that too.

After "auto install" I reboot.

Then I get stuck at the very beginning of Garuda trying to boot :frowning:

Restore your previous snapshot and manually install the drivers.

I hope you understand what "proprietary" means.

1 Like

Already restored to get back into Garuda again. How does one manually install drivers exactly?

I understand it as it's usually defined. Is there something else you think I should know?

bump

still no further :frowning:

Check to see if you have fast boot enabled in bios and if it is then disable.
Then try to install auto install drivers and check for erorrs in log when installing.

1 Like

fastboot was not enabled.

I'm not comfortable using the "auto install" as it has not worked one single time so far.

I came across this post however

It's pretty much exactly what I was searching for, as it deals with hybrid graphics setups.

I was able to install nvidia drivers with

sudo pacman -S nvidia-dkms nvidia-lts nvidia-prime nvidia-utils

and lsmod | grep nvidia now shows

nvidia_modeset       1200128  32 nvidia_drm
nvidia              35328000  1947 nvidia_modeset
i2c_nvidia_gpu         16384  0
drm_kms_helper        319488  2 nvidia_drm,i915
drm                   630784  17 drm_kms_helper,nvidia,nvidia_drm,i915

I had to add "nvidia" to MODULES in /etc/mkinitcpio.conf before it would boot successfully though.

So this looks good so far yes?

Until I try installing optimus-manager, I reboot and it fails again at Loading initial ramdisk

Getting somewhere but really starting to give up on arch based setup.

I'm mean this PC is new this year, I'm kinda shocked that it is SO difficult just to get graphics sorted.

Hardware config still looks like this.

So what error do you get when you install it?

Do you have secure boot disabled?

1 Like

There is no error - it installs just fine. But it fails to boot again after restarting - just stuck at "Loading initial ramdisk"

Secure boot is not enabled.

optimus-manager should be pre-installed already if you are using a recent iso since it was included into all editions from Garuda Linux "Spotted Eagle" (210507) onwards.

What does your boot log say when it fails

1 Like

How do I check that?

look in /var/log/boot log and at which one that failed might give you a clue

1 Like

right but how do I check that if I can't boot into the OS first?

it doesn't appear to be installed on my system, less than one week old

if you are booting into it now your old logs will be there?
if not boot live usb and mount the drive to see logs.

Did you have problems with the live usb when using the nvidia drivers boot option?

1 Like

I had to boot into a timeshift backup in order to get back in.

Yes I had problems with the live usb nvidia - it wouldn't boot, so had to use open source drivers option.

I don't think I have the patience to stick with this much longer tbh. I just want the drivers installed so I can play a few games, nothing special.

And for such a highly praised distro to have basic driver problems like this isn't great really.

In Ubuntu this was done in a few clicks.

Ok?
You have your setting wrong in your bois that is what is wrong.
Check you have uefi boot enabled.
check fastboot is off
check secure boot is off and delete keys.

Then try live usb with nvidia drivers.
If it boots ok in live mode then your setting are ok?

1 Like

OK I'll try it again.

So as expected it still won't boot into live usb with nvidia drivers.

The last two things shown on screen are:


Then the screen simply goes black as if signal is lost. Left it for more than five minutes and nothing.

It really looks like you have a setting wrong in your bios, i have come across this before.
Your graphics card is not being seen at boot.
Check you have the most upto date bios?
Reset bios to defaults,
Check all the above are still disabled after the reset.