Help installing and launching Garuda

Hi bros, I have a problem when I want to install Garuda, I put the ISO on a USB with Ventoy and select Garuda Linux starts the grub and then when I put to be able to install the operating system it goes to black screen and the image is not reflected. I’ve traded with another OS, but it’s the same thing. I tried Debian and it let me enter the installation, but when it starts it doesn’t let me get black screen, I have tried the USB on a notebook, and I didn’t have any problems.

Well have you ensured that you,

  • Disable fastboot and secure boot. It may not be possible to disable the latter explicitly - try clearing the secure boot keys instead. Check the manual of your device/motherboard for further info.
  • Make sure that your device’s SATA controller is set to AHCI mode in your device’s setup utility aka your UEFI/BIOS page. Otherwise, the Linux kernel may not be able to detect your drive.
  • If your firmware supports UEFI then configure your device to use UEFI only in its setup utility.

anything else you tried?


Thank you for responding, for a moment I’ll send you images of my motherboard so you can confirm that all the configuration you tell me about is correct.

Please provide your


from the live usb so it can be determined which iso you are trying to install and your hardware


Hello brother, thanks for answering. I only get as far as the installation grub part and can’t get into the live itself.

In the second image the green :green_circle: next to “fast boot” leads me to believe it’s enabled? If it is please disable it and see if anything changes when you boot.


Thank you very much friends, because that was the problem, the usb fastboot was apparently causing a conflict, now I am from the garuda live.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.