Headset microphone not working/is not detected properly

Hello. I am new to Linux and have been using Garuda Linux (KDE Dragonized Gaming version) on my desktop computer for around two months now.

I am using a 'JBL Quantum 400' headset connected to my monitor and through display port to my computer. Audio output works fine with the headset but I cannot get the microphone to work.

I have primarily tried with discord but it did not work in any other situation either such as mic testing websites. The input device detected by applications is called 'alsa_output.pci-0000_0b_00.4.iec958-stereo.monitor' and this device plays back all system output, but does not play anything from the microphone.

I know my microphone and monitor are functional, as using them with my windows laptop has worked fine.

System:
Kernel: 5.16.5-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=7dad8b1e-d496-4253-b075-eb6863dfeb33 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
Mobo: ASUSTeK model: ROG STRIX B550-F GAMING (WI-FI) v: Rev X.0x
serial: <superuser required> UEFI: American Megatrends v: 2006
date: 03/19/2021
Battery:
ID-1: hidpp_battery_0 charge: 37% condition: N/A volts: 3.8 min: N/A
model: Logitech G502 LIGHTSPEED Wireless Gaming Mouse type: N/A
serial: <filter> status: Discharging
CPU:
Info: model: AMD Ryzen 7 5800X bits: 64 type: MT MCP arch: Zen 3
family: 0x19 (25) model-id: 0x21 (33) stepping: 0 microcode: 0xA201009
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
L3: 32 MiB desc: 1x32 MiB
Speed (MHz): avg: 3838 high: 4632 min/max: 2200/4850 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3706 2: 3694
3: 3691 4: 3752 5: 4507 6: 3724 7: 3698 8: 3730 9: 3852 10: 3702 11: 3764
12: 3824 13: 4632 14: 3676 15: 3707 16: 3752 bogomips: 121377
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
IBRS_FW, STIBP: always-on, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Navi 21 [Radeon RX 6800/6800 XT / 6900 XT] vendor: ASUSTeK
driver: amdgpu v: kernel bus-ID: 09:00.0 chip-ID: 1002:73bf class-ID: 0300
Display: x11 server: X.Org 1.21.1.3 compositor: kwin_x11 driver:
loaded: amdgpu,ati unloaded: modesetting,radeon alternate: fbdev,vesa
display-ID: :0 screens: 1
Screen-1: 0 s-res: 4480x1440 s-dpi: 96 s-size: 1185x381mm (46.7x15.0")
s-diag: 1245mm (49")
Monitor-1: DisplayPort-0 res: 1920x1080 hz: 60 dpi: 82
size: 598x336mm (23.5x13.2") diag: 686mm (27")
Monitor-2: DisplayPort-2 res: 2560x1440 hz: 165 dpi: 109
size: 597x336mm (23.5x13.2") diag: 685mm (27")
OpenGL: renderer: AMD Radeon RX 6800 (SIENNA_CICHLID DRM 3.44.0
5.16.5-zen1-1-zen LLVM 13.0.0)
v: 4.6 Mesa 21.3.5 direct render: Yes
Audio:
Device-1: AMD Navi 21 HDMI Audio [Radeon RX 6800/6800 XT / 6900 XT]
driver: snd_hda_intel v: kernel bus-ID: 09:00.1 chip-ID: 1002:ab28
class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel bus-ID: 0b:00.4 chip-ID: 1022:1487
class-ID: 0403
Sound Server-1: ALSA v: k5.16.5-zen1-1-zen running: yes
Sound Server-2: sndio v: N/A running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.45 running: yes
Network:
Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 05:00.0
chip-ID: 8086:2723 class-ID: 0280
IF: wlp5s0 state: up mac: <filter>
Device-2: Intel Ethernet I225-V vendor: ASUSTeK driver: igc v: kernel
port: N/A bus-ID: 06:00.0 chip-ID: 8086:15f3 class-ID: 0200
IF: enp6s0 state: down mac: <filter>
Bluetooth:
Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 1-5:2 chip-ID: 8087:0029 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: down
bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
Drives:
Local Storage: total: 1.82 TiB used: 421.88 GiB (22.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
model: SSD 970 EVO Plus 2TB size: 1.82 TiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 2B2QEXM7 temp: 46.9 C scheme: GPT
Partition:
ID-1: / raw-size: 1.82 TiB size: 1.82 TiB (100.00%)
used: 421.88 GiB (22.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 1.82 TiB size: 1.82 TiB (100.00%)
used: 421.88 GiB (22.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 1.82 TiB size: 1.82 TiB (100.00%)
used: 421.88 GiB (22.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 1.82 TiB size: 1.82 TiB (100.00%)
used: 421.88 GiB (22.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 31.3 GiB used: 2.2 MiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 57.0 C
mem: 56.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
Info:
Processes: 434 Uptime: 1h 34m wakeups: 10 Memory: 31.3 GiB
used: 6.04 GiB (19.3%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1951 lib: 567 Shell: fish
v: 3.3.1 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.12
Garuda (2.5.4-2):
System install date:     2022-01-05
Last full system update: 2022-02-06
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:

I have tried using the archwiki fix for this issue (setting 'api.alsa.use-acp' to false/ setting 'api.alsa.use-ucm' to true) which did not work. I have also looked on the forums for a solutions but most involve using 'pavucontrol' to configure audio devices which did not work for me.

Any help with this issue would be appreciated.

I am assuming your are using the USB plug of that headset since I see USB related issues when I search for that headset model.
This link should point you in the right direction to get it fixed while using USB

I am using the audio jack plug. I will try this fix regardless and let you know what happens.

if you are using the 3.5mm then it should work out of the box. Try making sure the headset mic works by plugging directly into the motherboard.

Yes it does work plugged into my motherboard. The issue appears to be with the monitor, although I know the monitor is not faulty since my headset worked through hdmi to my laptop before.

Should I maybe plug in the USB cable and then try the fix you gave earlier?

If USB is more comfortable for your desktop setup instead of using your motherboard's ports, then its worth a shot.

Plugging in with USB to my computer works, however I like to use my monitor for more devices than my computer which means audio does not work for other devices if my headset is plugged into my computer. Is there a workaround you can think of for this? (plugging 3.5 mm jack and usb into headset does not work)

What is the model of your monitor?

Also, if you are using the monitor's "hub", make sure the USB from the monitor is connected to the PC securely.

My monitor is a Gigabyte G27QC A 27", not sure what you mean by USB from the monitor to the PC, but all my connections are secure.


This is what I am talking about. The monitor came with a USB cord for its upstream port. Also, it only looks like it has a regular headphone jack for just audio out.

That is odd, since audio in was working through the monitor on another computer, or mabye I am misremembering. What should this USB cord do? My current one does not reach the monitor.

I'll leave you with the manual https://download.gigabyte.com/FileList/Manual/G27QC_A_UM_English.pdf?v=4a47d0707d9029113077abda33f6ab3e

1 Like

Moved my monitor around and plugged the headset into it and the same issue remains with other devices, although my microphone now works on my computer and I have thought of a workaround for my HDMI connected devices. Thank you for being so patient and helpful!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.