Headset mic not working

i am new to linux
the problem is that the audio from my pc inbuilt mic is comming properly
but the mic form my headset is not working
driver-pipeline
plz help need to attend online class

System:    Kernel: 5.13.8-zen2-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0  
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=7112fee5-1db7-413b-85df-89fd133914fb  
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 loglevel=3
Desktop: KDE Plasma 5.22.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM  
Distro: Garuda Linux base: Arch Linux  
Machine:   Type: Laptop System: Acer product: Swift SF314-55G v: V1.07 serial: <filter>  
Mobo: WL model: MILLER_WL v: V1.07 serial: <filter> UEFI: American Megatrends v: 1.07  
date: 12/24/2018  
Battery:   ID-1: BAT0 charge: 29.1 Wh (84.8%) condition: 34.3/48.9 Wh (70.0%) volts: 16.4 min: 15.2  
model: AC14B8K type: Li-ion serial: N/A status: Charging  
CPU:       Info: Quad Core model: Intel Core i5-8265U bits: 64 type: MT MCP arch: Kaby Lake note: check  
family: 6 model-id: 8E (142) stepping: B (11) microcode: EA cache: L2: 6 MiB  
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 28800  
Speed: 3703 MHz min/max: 400/3900 MHz Core speeds (MHz): 1: 3703 2: 3747 3: 3744 4: 3082  
5: 3752 6: 3732 7: 3539 8: 3591  
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled  
Type: l1tf status: Not affected  
Type: mds mitigation: Clear CPU buffers; SMT vulnerable  
Type: meltdown status: Not affected  
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp  
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization  
Type: spectre_v2  
mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling  
Type: srbds mitigation: Microcode  
Type: tsx_async_abort status: Not affected  
Graphics:  Device-1: Intel WhiskeyLake-U GT2 [UHD Graphics 620] vendor: Acer Incorporated ALI driver: i915  
v: kernel bus-ID: 00:02.0 chip-ID: 8086:3ea0 class-ID: 0300  
Device-2: NVIDIA GP108BM [GeForce MX250] vendor: Acer Incorporated ALI driver: nvidia  
v: 470.57.02 alternate: nouveau,nvidia_drm bus-ID: 02:00.0 chip-ID: 10de:1d52 class-ID: 0302  
Device-3: Chicony HD WebCam type: USB driver: uvcvideo bus-ID: 1-7:5 chip-ID: 04f2:b5c5  
class-ID: 0e02 serial: <filter>  
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: modesetting,nvidia  
display-ID: :0 screens: 1  
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")  
Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 158 size: 309x173mm (12.2x6.8") diag: 354mm (13.9")  
OpenGL: renderer: Mesa Intel UHD Graphics 620 (WHL GT2) v: 4.6 Mesa 21.1.6 direct render: Yes  
Audio:     Device-1: Intel Cannon Point-LP High Definition Audio vendor: Acer Incorporated ALI  
driver: sof-audio-pci-intel-cnl alternate: snd_hda_intel,snd_soc_skl,snd_sof_pci_intel_cnl  
bus-ID: 00:1f.3 chip-ID: 8086:9dc8 class-ID: 0401  
Sound Server-1: ALSA v: k5.13.8-zen2-1-zen running: yes  
Sound Server-2: JACK v: 1.9.19 running: no  
Sound Server-3: PulseAudio v: 15.0 running: no  
Sound Server-4: PipeWire v: 0.3.33 running: yes  
Network:   Device-1: Intel Cannon Point-LP CNVi [Wireless-AC] driver: iwlwifi v: kernel port: 4000  
bus-ID: 00:14.3 chip-ID: 8086:9df0 class-ID: 0280  
IF: wlo1 state: up mac: <filter>  
Bluetooth: Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB driver: btusb v: 0.8  
bus-ID: 1-10:6 chip-ID: 8087:0aaa class-ID: e001  
Report: bt-adapter ID: hci0 rfk-id: 2 state: down bt-service: enabled,running rfk-block:  
hardware: no software: yes address: <filter>  
RAID:      Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci v: 3.0 port: 4060  
bus-ID: 00:17.0 chip-ID: 8086.282a rev: 30 class-ID: 0104  
Drives:    Local Storage: total: 476.94 GiB used: 16.55 GiB (3.5%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: PC SN520 SDAPNUW-512G-1014
size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 15.8 Gb/s lanes: 2 type: SSD
serial: <filter> rev: 20110000 temp: 48.9 C scheme: GPT
Partition: ID-1: / raw-size: 476.68 GiB size: 476.68 GiB (100.00%) used: 16.55 GiB (3.5%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) used: 562 KiB (0.2%) fs: vfat
dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 476.68 GiB size: 476.68 GiB (100.00%) used: 16.55 GiB (3.5%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 476.68 GiB size: 476.68 GiB (100.00%) used: 16.55 GiB (3.5%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 476.68 GiB size: 476.68 GiB (100.00%) used: 16.55 GiB (3.5%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.62 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 68.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:      Processes: 316 Uptime: 25m wakeups: 2568 Memory: 7.62 GiB used: 3.6 GiB (47.2%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1406 lib: 400
Shell: fish v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.06

Has it ever worked?

Is it wired or Bluetooth?

Is it connected correctly?

Have you selected that microphone as the primary input?

Have you selected that microphone as input for the application you are using?

The forum is not here to provide a personal service. If you have a problem that is urgent then you should be looking for another solution (for example, use the already-working internal microphone!).

1 Like

@jonathon all ans to your question
no it has never worked
wired
yes
yes
yes

and i cant use my internal mic cuz it is very bad
i turned it on and 30 students left the meeting lol

If it has never worked, why is this a Garuda issue? Buy a new headset.

1 Like

no it worked with windows
i mean never worked with garuda
@jonathon

plz help anyone

Install and run pavucontrol and see what's happening with the microphones.

Stop that. This is not a personal support forum, it's not a chat service, and begging for help won't make more people appear and read your post.

If you have an urgent issue with something you need for classes then contact the technical support routes for the organisation running the classes.

how do i install pavucontrol
edit:ok i got it installing

nothing changed still unable to her voice from my headset mic

Read laptop's user manual.
Is the laptop port a unified one, like smartphones'?

These cases have known issues in Linux. Archwiki has some troubleshooting tips for this.

2 Likes

plz give the link for the troubleshooting page and it is 3.5mm jack earphone

https://wiki.archlinux.org/

1 Like

This is not clear enough.
Anyway, it needs careful reading, testing and experimenting.
You may start from here and more.

1 Like

My BIOS has an option that checks for new/changed/gone hardware. When I had it set to either "Minimal" or "Auto," Windows decided to change things one fine day, seeing no BT adaptor after a software update. That change carried over into Linux (Arch and Garuda).

When I changed the BIOS setting to "Thorough" Linux (and Windows) re-acquired the adaptor.

It may (or may not) be something similar.

regards

5 Likes

and i understood noting plz use simple terms i am noob

my laptop acer swift 3 sf314-55g-52at
drivers -alsa support,pipewire,jack ,user in realtime group(they are checked in assistant)
and i have no pipewire folder idk why

I am sorry, but I do not give basic computing classes. May I suggest you read "PCs for Dummies" or another, similar, primer?

Unless you're responding to @petsam. He might.
:wink:

2 Likes

After reading the material @petsam furnished and, considering the Warning issued above that section in the Arch Wiki, you might want to consider replacing pipewire with tried and true pulseaudio. Pipewire is reputedly still under heavy development, and the terminology used in the Wiki is a bit beyond the scope of what a beginner would be able to follow without developing a massive headache in no time at all.

I'm fairly sure I have seen a post regarding that replacement--it's not a straight remove-and-install that Pamac or Octopi handles gracefully--so search the forum. If you try hard but still fail at that, I'll be doing a Barebones KDE installation on another machine tomorrow morning and will note the procedure steps from a console.

regards

4 Likes

Simply installing pavucontrol would indeed change nothing - you have to run it and check the settings. Do you see the meters move? Is the microphone unmuted? Is its volume at a sufficient level?

It sounds like you should be doing some reading and exploring your system. Imagine a world without web forums and chat channels where you can immediately ask every question that pops into your head - what would you do?

3 Likes

Okay, if you would like to replace pipewire-support with pulseaudio-support, here's a forum searched link. Note that you cannot totally remove pipewire since it is a required dependency of kwin/KDE Plasma. After installing pulseaudio-support, I would also install the pulsesaudio metapackage.

You should then goto the Garuda Assistant and make sure the Pulseaudio Support box is checked under System Components, along with all the Bluetooth items as well.

And, to make things a bit easier to sort out, please follow @jonathon's suggestions.

P.S. Don't forget to reboot afterwards. :wink:

4 Likes