Headphones not being detected

Hello,

The problem i'm currently having is that my headphones aren't being detected, i have a realtek sound card integrated into my motherboard and i think the reason my headphones aren't being detected is because normally, on windows i have to go to the realtek audio settings thingy in control panel to enable the front headphone jacks for my headphones to work but i have no idea how to do this in linux, i have done a bunch of research but haven't found much on how to do so. Please help!

Edit: i just realised linux doesn't even detect my sound card, so im imagining i dont have any drivers for it?

inxi:

System:
  Kernel: 5.15.55-2-lts arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts
    root=UUID=f9bca527-d148-4e99-8b54-d2f186d91b80 rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3
  Desktop: GNOME v: 42.3.1 tk: GTK v: 3.24.34 wm: gnome-shell dm: GDM
    v: 42.0 Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: Gigabyte model: F2A68HM-H v: x.x serial: N/A
    UEFI: American Megatrends v: FB date: 04/22/2015
CPU:
  Info: model: AMD A8-7600 Radeon R7 10 Compute Cores 4C+6G socket: FM2 (P0)
    note: check bits: 64 type: MT MCP arch: Steamroller built: 2014
    process: GF 28nm family: 0x15 (21) model-id: 0x30 (48) stepping: 1
    microcode: 0x6003106
  Topology: cpus: 1x cores: 4 smt: enabled cache: L1: 256 KiB
    desc: d-4x16 KiB; i-2x96 KiB L2: 4 MiB desc: 2x2 MiB
  Speed (MHz): avg: 3100 min/max: 1400/3100 boost: enabled
    base/boost: 3100/3100 scaling: driver: acpi-cpufreq governor: performance
    volts: 1.2 V ext-clock: 100 MHz cores: 1: 3100 2: 3100 3: 3100 4: 3100
    bogomips: 24755
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, STIBP: disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Kaveri [Radeon R7 Graphics] vendor: Gigabyte driver: radeon
    v: kernel alternate: amdgpu arch: GCN 2 process: GF/TSMC 16-28nm
    built: 2013-17 ports: active: VGA-1 empty: DVI-D-1,HDMI-A-1
    bus-ID: 00:01.0 chip-ID: 1002:1313 class-ID: 0300
  Device-2: NVIDIA GM206 [GeForce GTX 960] vendor: Micro-Star MSI
    driver: nvidia v: 515.57 alternate: nouveau,nvidia_drm non-free: 515.xx+
    status: current (as of 2022-06) arch: Maxwell process: TSMC 28nm
    built: 2014-19 pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 3
    speed: 8 GT/s bus-ID: 01:00.0 chip-ID: 10de:1401 class-ID: 0300
  Display: server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
    compositor: gnome-shell driver: X: loaded: nvidia,radeon
    unloaded: modesetting,nouveau alternate: fbdev,nv,vesa gpu: radeon
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1016x286mm (40.00x11.26")
    s-diag: 1055mm (41.55")
  Monitor-1: HDMI-0 pos: primary,right res: 1920x1080 dpi: 82
    size: 598x336mm (23.54x13.23") diag: 686mm (27.01") modes: N/A
  Monitor-2: VGA-1-0 pos: primary,left res: 1920x1080 hz: 60 dpi: 96
    size: 510x287mm (20.08x11.3") diag: 585mm (23.04") modes: N/A
  OpenGL: renderer: NVIDIA GeForce GTX 960/PCIe/SSE2 v: 4.6.0 NVIDIA 515.57
    direct render: Yes
Audio:
  Device-1: AMD Kaveri HDMI/DP Audio vendor: Gigabyte driver: snd_hda_intel
    v: kernel bus-ID: 00:01.1 chip-ID: 1002:1308 class-ID: 0403
  Device-2: AMD FCH Azalia vendor: Gigabyte driver: snd_hda_intel v: kernel
    bus-ID: 00:14.2 chip-ID: 1022:780d class-ID: 0403
  Device-3: NVIDIA GM206 High Definition Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:0fba class-ID: 0403
  Sound Server-1: ALSA v: k5.15.55-2-lts running: yes
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.56 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Gigabyte driver: r8169 v: kernel modules: r8168 pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 02:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  IF: enp2s0 state: down mac: <filter>
  Device-2: Realtek RTL8188EUS 802.11n Wireless Network Adapter type: USB
    driver: r8188eu bus-ID: 2-3:3 chip-ID: 0bda:8179 class-ID: 0000
    serial: <filter>
  IF: wlan0 state: down mac: <filter>
  IF-ID-1: enp0s19f2u1 state: unknown speed: -1 duplex: half mac: <filter>
Bluetooth:
  Device-1: Samsung Galaxy series misc. (tethering mode) type: USB
    driver: rndis_host v: kernel bus-ID: 2-1:2 chip-ID: 04e8:6863
    class-ID: 0a00 serial: <filter>
  Report: bt-service: enabled,stopped note: tool can't run
Drives:
  Local Storage: total: 2.04 TiB used: 101.28 GiB (4.9%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000DM001-1ER164
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: CC25 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Kingston model: SV300S37A240G
    size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: BBF0 scheme: GPT
Partition:
  ID-1: / raw-size: 207.81 GiB size: 207.81 GiB (100.00%)
    used: 101.28 GiB (48.7%) fs: btrfs block-size: 4096 B dev: /dev/sda3
    maj-min: 8:3
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 608 KiB (0.2%) fs: vfat block-size: 512 B dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 207.81 GiB size: 207.81 GiB (100.00%)
    used: 101.28 GiB (48.7%) fs: btrfs block-size: 4096 B dev: /dev/sda3
    maj-min: 8:3
  ID-4: /var/log raw-size: 207.81 GiB size: 207.81 GiB (100.00%)
    used: 101.28 GiB (48.7%) fs: btrfs block-size: 4096 B dev: /dev/sda3
    maj-min: 8:3
  ID-5: /var/tmp raw-size: 207.81 GiB size: 207.81 GiB (100.00%)
    used: 101.28 GiB (48.7%) fs: btrfs block-size: 4096 B dev: /dev/sda3
    maj-min: 8:3
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 14.59 GiB used: 512 KiB (0.0%)
    priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 10.2 C mobo: N/A
  Fan Speeds (RPM): N/A
  GPU: device: nvidia screen: :0.0 temp: 58 C fan: 0% device: radeon
    temp: 11.0 C
Info:
  Processes: 251 Uptime: 9m wakeups: 0 Memory: 14.59 GiB
  used: 2.59 GiB (17.8%) Init: systemd v: 251 default: graphical
  tool: systemctl Compilers: gcc: 12.1.0 clang: 14.0.6 Packages: pacman: 1486
  lib: 470 Shell: garuda-inxi (sudo) default: Bash v: 5.1.16
  running-in: gnome-terminal inxi: 3.3.19
Garuda (2.6.5-1):
  System install date:     2022-07-18
  Last full system update: 2022-07-27 ↻
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       Yes
  Snapshots:               Snapper
  Failed units:            bluetooth-autoconnect.service 

That's your integrated audio chip, so it's detecting that fine (what Gigabyte calls the Realtek chip on that board). Have you tried the back audio ports directly from the motherboard first to make sure its working at all? If that works and you want to switch to the front, there should be a headphone option to change to them.

3 Likes

Please ensure the BIOS settings for all ports are correctly marked, if you haven't already done so.

Also, since you are dual-booting with Windows, please be aware that Windows has a nasty tendency to "capture" hardware and doesn't always willingly surrender its use.

2 Likes

This doesn't sound like a normal thing to have to do. Are the headers connected correctly inside the PC?

I have tried that and nothing, i tried one by one all the audio output devices and none worked

¯_(ツ)_/¯

It's because theres an option called Disable front headphone jacks which is the thing i have to disable for the front headphone jacks to work and i think its just selected by default with the software

I am already aware of that and in a post with another problem i had the person told me to disable fast and secure boot

So you have NVIDIA card?

I guess I know your issue. You have NVIDIA card and the PC is giving sound output to it.
But you are trying to receive output from motherboard's sound card, and plugging into motherboard's sound outlet.

This issue may be solved by going to Pavucontrol and disabling the NVIDIA card and enable the motherboard's sound card.

In the BIOS?

That was not the point c00ter was making.

Where in pavucontrol would i be able to do that?

Sorry im kinda unfamiliar with it

In the Realtek software configuration thingy

And what about in the BIOS? Is there an "enable onboard soundcard" option or similar?

1 Like

It should be in Output Devices or Configuration

if that was disabled then windows would have also not been working but windows works

Didn't work, i disabled GM206 High Definition Audio Controller in configuration and nothing really changed.

After you enable the setting using the manufacturer's driver software. Have you verified that it is enabled in the BIOS?

2 Likes

It is already enabled in bios i checked

You may want to take a peak in 'alsamixer' in terminal. Worth a shot. Sometimes all that is needed is to "un-mute" the headphones in alsamixer.

  1. In terminal type alsamixer

  2. Hit F6 and choose your AMD card with PCH in the name. It will not be the HDMI.

  3. You should now see many sliders, including headphones. Make sure this slider is un-muted and turned up.

Worth a shot. Saved me many times.

1 Like


I don't see the sound card

It's probably 'default:2 HD-Audio Generic'