Headphones crash after a resume

Hello Garuda users.

So, the title is not clickbait. It really happens and i am soooo frickin' annoyed by this at this stage. I've hopped 2 distros in hopes this gets resolved and i can't even narrow the problem down. It just feels like a headphone problem but i need them to work fine like they do on windows and mobile phones.

I have Sony WH-CH710N headphones and what happens is if they are connected by bluetooth after a while, like if i am listening to songs on spotify and suddenly pause them to watch a youtube video for example, then the youtube video starts to buffers, and after 4-5 seconds, i head a "tick" in my headphones. the headphones don't respond to its own buttons after that. i have to switch it off and turn it back on and now they work and reconnect like nothing happened.

sudo journalctl -b || grep "blue" gives this input:

Dec 06 22:12:18 charismatic bluetoothd[459]: profiles/audio/avdtp.c:cancel_request() Start: Connection timed out (110)
Dec 06 22:12:18 charismatic wireplumber[376188]: Transport Acquire() failed for transport /org/bluez/hci0/dev_30_53_C1_67_B1_8C/sep2/fd
23 (Input/output error)
Dec 06 22:12:18 charismatic wireplumber[376188]: (bluez_output.30_53_C1_67_B1_8C.1-19) suspended -> error (Start error: Input/output er
ror)
Dec 06 22:12:20 charismatic bluetoothd[459]: profiles/audio/avdtp.c:cancel_request() Abort: Connection timed out (110)
Dec 06 22:12:20 charismatic dbus-daemon[460]: [system] Rejected send message, 0 matched rules; type="method_return", sender=":1.444" (u
id=1000 pid=376188 comm="/usr/bin/wireplumber") interface="(unset)" member="(unset)" error name="(unset)" requested_reply="0" destinati
on=":1.5" (uid=0 pid=459 comm="/usr/lib/bluetooth/bluetoothd")
Dec 06 22:12:34 charismatic bluetoothd[459]: src/profile.c:ext_io_disconnected() Unable to get io data for Hands-Free Voice gateway: ge
tpeername: Transport endpoint is not connected (107)
Dec 06 22:12:40 charismatic bluetoothd[459]: src/profile.c:record_cb() Unable to get Hands-Free Voice gateway SDP record: Host is down
Dec 06 22:12:47 charismatic bluetoothd[459]: src/profile.c:record_cb() Unable to get Hands-Free Voice gateway SDP record: Host is down
Dec 06 22:12:56 charismatic bluetoothd[459]: src/profile.c:record_cb() Unable to get Hands-Free Voice gateway SDP record: Host is down
Dec 06 22:13:10 charismatic bluetoothd[459]: src/profile.c:record_cb() Unable to get Hands-Free Voice gateway SDP record: Host is down
Dec 06 22:13:33 charismatic bluetoothd[459]: src/profile.c:ext_connect() Hands-Free Voice gateway failed connect to 30:53:C1:67:B1:8C: Connection refused (111)
garuda-inxi

System:
Kernel: 6.0.10-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=e58f8d48-2762-4f6b-917d-30452146592e rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=9b87b565-dc9a-49cd-a3ed-1ad68b237274 loglevel=3
Desktop: KDE Plasma v: 5.26.4 tk: Qt v: 5.15.7 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: Hewlett-Packard product: HP ProBook 450 G2
v: A3008CD10003 serial: <superuser required> Chassis: type: 10
serial: <superuser required>
Mobo: Hewlett-Packard model: 2248 v: KBC Version 59.22
serial: <superuser required> BIOS: Hewlett-Packard v: M73 Ver. 01.14
date: 06/23/2015
Battery:
ID-1: BAT0 charge: 0.0 Wh (0.0%) condition: 42.6/42.6 Wh (100.0%)
volts: 16.4 min: 14.8 model: Hewlett-Packard Primary type: Li-ion
serial: <filter> status: not charging
CPU:
Info: model: Intel Core i5-5200U bits: 64 type: MT MCP arch: Broadwell
gen: core 5 level: v3 note: check built: 2015-18 process: Intel 14nm
family: 6 model-id: 0x3D (61) stepping: 4 microcode: 0x2F
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 3 MiB desc: 1x3 MiB
Speed (MHz): avg: 2415 high: 2478 min/max: 500/2700 scaling:
driver: intel_cpufreq governor: performance cores: 1: 2440 2: 2377 3: 2478
4: 2366 bogomips: 17559
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: mmio_stale_data status: Unknown: No mitigations
Type: retbleed status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel HD Graphics 5500 vendor: Hewlett-Packard driver: i915
v: kernel arch: Gen-8 process: Intel 14nm built: 2014-15 ports:
active: eDP-1 empty: DP-1,HDMI-A-1,HDMI-A-2 bus-ID: 00:02.0
chip-ID: 8086:1616 class-ID: 0300
Device-2: AMD Topaz PRO [Radeon R5 M255] vendor: Hewlett-Packard
driver: amdgpu v: kernel arch: GCN-3 code: Volcanic Islands
process: TSMC 28nm built: 2014-19 pcie: gen: 1 speed: 2.5 GT/s lanes: 4
link-max: gen: 3 speed: 8 GT/s lanes: 8 bus-ID: 0a:00.0 chip-ID: 1002:6901
class-ID: 0380 temp: 51.0 C
Device-3: Lite-On HP HD Webcam type: USB driver: uvcvideo bus-ID: 2-7:4
chip-ID: 04ca:704d class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.5
compositor: kwin_x11 driver: X: loaded: amdgpu,modesetting
alternate: fbdev,intel,vesa dri: iris,radeonsi gpu: i915 display-ID: :0
screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
s-diag: 414mm (16.31")
Monitor-1: eDP-1 model: ChiMei InnoLux 0x15be built: 2013 res: 1366x768
hz: 60 dpi: 101 gamma: 1.2 size: 344x193mm (13.54x7.6") diag: 394mm (15.5")
ratio: 16:9 modes: 1366x768
API: OpenGL v: 4.6 Mesa 22.2.3 renderer: Mesa Intel HD Graphics 5500 (BDW
GT2) direct render: Yes
Audio:
Device-1: Intel Broadwell-U Audio vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel bus-ID: 00:03.0 chip-ID: 8086:160c
class-ID: 0403
Device-2: Intel Wildcat Point-LP High Definition Audio
vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
chip-ID: 8086:9ca0 class-ID: 0403
Sound API: ALSA v: k6.0.10-zen2-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.61 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Hewlett-Packard driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: 5000 bus-ID: 08:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp8s0 state: down mac: <filter>
Device-2: Realtek RTL8723BE PCIe Wireless Network Adapter
vendor: Hewlett-Packard driver: rtl8723be v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: 4000 bus-ID: 09:00.0 chip-ID: 10ec:b723
class-ID: 0280
IF: wlo1 state: up mac: <filter>
Bluetooth:
Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
bus-ID: 2-4:2 chip-ID: 0bda:b001 class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 6 state: up address: <filter>
Drives:
Local Storage: total: 931.51 GiB used: 22.04 GiB (2.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM035-1RK172
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 5400 serial: <filter> rev: LFM3 scheme: MBR
Partition:
ID-1: / raw-size: 922.71 GiB size: 922.71 GiB (100.00%)
used: 22.04 GiB (2.4%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-2: /home raw-size: 922.71 GiB size: 922.71 GiB (100.00%)
used: 22.04 GiB (2.4%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-3: /var/log raw-size: 922.71 GiB size: 922.71 GiB (100.00%)
used: 22.04 GiB (2.4%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
ID-4: /var/tmp raw-size: 922.71 GiB size: 922.71 GiB (100.00%)
used: 22.04 GiB (2.4%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.44 GiB used: 2.12 GiB (28.5%)
priority: 100 dev: /dev/zram0
ID-2: swap-2 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/sda2 maj-min: 8:2
Sensors:
System Temperatures: cpu: 59.0 C mobo: N/A gpu: amdgpu temp: 51.0 C
Fan Speeds (RPM): N/A
Info:
Processes: 257 Uptime: 2d 9h 57m wakeups: 7 Memory: 7.44 GiB
used: 4.84 GiB (65.0%) Init: systemd v: 252 default: graphical
tool: systemctl Compilers: gcc: 12.2.0 Packages: 1880 pm: pacman pkgs: 1862
libs: 519 tools: octopi,paru pm: flatpak pkgs: 18 Shell: fish v: 3.5.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.23
Garuda (2.6.10-1):
System install date:     2022-12-03
Last full system update: 2022-12-06 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       <superuser required>
Snapshots:               Snapper
Failed units:            archlinux-keyring-wkd-sync.service

All i can deduce after months of this annoyance is that it maybe due to the usage of non-standard bluetooth protocols by my headphones but like is there any fix for it? maybe a new bluetooth adapter or something? Other than this it has been about 4-5 days on Garuda, And i must say this is sooooooo good, my boot time has just halved, everything feels snappier, lower memory usage and better kde experience than fedora kde spin that i was on ;p.
ALL OF YOUR HELP WILL BE HUGELY APPRECIATED.

there is one more error from the journalctl that I just realised i didn't copy. May this one help

Dec 07 01:19:39 charismatic wireplumber[376188]: set volume 112 failed for transport /org/bluez/hci0/dev_30_53
_C1_67_B1_8C/fd37 (No such property 'Volume')

Am I doing anything wrong? Why isn't anybody willing to help? That's a shame ok.

NVM NOW, I managed to use my brain and observe that it always happens after nothing is playing and all of a sudden something starts to play.. So, if anyone of the ignorant members have had this problem, i fixed it by making a process of 0 volume and keeping it in the background if i were to use the laptop...

speaker-test -S 0

So, thanks but no thanks. it is kinda unfortunate that the os is so good but the community isn't very helpful around it.... Atleast for us newcomers, help make it a bit more helpful by atleast acknowledging that someone might've read my query and intends to solve it

Hmm, this assessment is somewhat unfair I think. Spend some time in the forum reading through some threads other than your own and you'll likely change your tune. This community puts in a lot of time and effort to help one another.

Bear in mind, this is not some huge project with tons of staff or resources--rather, we are just a few folks who come here in our free time to try to be helpful because we care about the project.

You make it sound like we're all just sitting around knowing fully well what's wrong with your special headphones, and we are withholding our knowledge because we are embittered or purposefully unfriendly. I am sure if someone had experience with your issue and they happened to read your post (in the one day it was up before being marked solved), they would have chimed in with their advice.

It sounds like you found a way to resolve your issue, but if you are interested in digging a little deeper: the third answer in this thread suggests a solution for disabling audio sync suspend for Bluetooth devices: linux - How do I disable audio sink suspend on idle using WirePlumber in Fedora 35 so that audio isn't delayed when starting playback? - Unix & Linux Stack Exchange. I'm not certain that is the source of the issue you are experiencing, but it seems like it could be. There is also an ArchWIki article for Bluetooth headsets; this specific entry here is in regards to issues resuming from idle: Bluetooth headset - ArchWiki.

No hard feelings, but do try to be kind; we are all just regular people here. :slightly_smiling_face:

6 Likes

I actually know exactly what is wrong with your headphones. The headphones are Bluetooth, that's the problem. If you want have a ton of problems using Linux then use all Bluetooth devices wherever possible.

I avoid Bluetooth like the plague, because of its security vulnerabilities and frequent breakages with Linux. Kernel updates break Bluetooth with regularity, so inevitable problems can be expected if you insist on using Bluetooth.

You may think it unacceptable that Bluetooth can be unreliable in Linux. However I think it is unaceptable that Windows has rampant security holes that can go unpatched for years, leaving my computer vulnerable to all manner of virii, malware, and ransom ware. In the end it is up to the user to decide which technology is the safest and/or most reliable for their use case. In my case Linux is the clear choice, and sometimes you have to accept the good with the bad, (I can live without Bluetooth).

Unlike Windows, most Linux distros are free and do not come with paid support staff. The Garuda forum has no paid staff on hand to answer your questions 24 hrs per day. Members of the Garuda community volunteer their time on the forum to help others whenever they have the time available. In most people's case they have a life outside the forum and only have so much time available to help out here.

In my case, I only just read your thread a few minutes ago. I was not refusing to help you. I find your intimation that community members here are all unhelpful and were refusing to help you extremely offensive. I simply didn't have the time to read every thread on the forum yesterday. If you expect instant assistance whenever you have a problem, then you should really be using a commercial operating system where you can pay for that privilege.

Garuda is a free OS with a small dev team, you need to have more realistic expectations when using a small independent Linux project. This is not a multi billion dollar mega corporation with thousands of paid developers and support staff. Give your head a shake buddy.

2 Likes

yeah i get that. Maybe i was pissed at myself not to have solved the issue earlier or something. I regret sounding like that. But my problem was maybe just frustration with the bluetooth in linux overall. I've had this problem in Pop!_OS and Fedora, and after being head stakingly annoyed by this, i booted up Garuda. Getting this problem again, made it seem like the incompatibility of my headphones with linux, which i get it now.
Sorry if I was offensive guys, I am and have been a linux user for a long time, and maybe the anger that I had no answer for this simple thing for so long got over me this time. And as for the links, yeah i have tried literally everything available on internet, and even broke my bluetooth packages one, but nothing worked.
And sry again. Though the satisfaction of getting this problem over with is heavenly ;p

3 Likes

tbg you crusty old dinosaur--get with the times already! :rofl:

Just kidding, I'm not a huge fan of Bluetooth myself actually--although I definitely feel it has come a loooong way. I have a few Bluetooth devices, and they all work perfectly fine (...most of the time...:laughing:).

Part of the problem with Bluetooth is it's still an evolving technology, making it a bit of a moving target for Linux because all the functionality is driver-based. Every time you turn around, someone has made a new set of headphones or something that relies on a new protocol or uses the Bluetooth stack in a new way, and they'll slap together a driver for Windows and put the thing out to market. Linux is left scrambling to reverse-engineer what just happened and try to get support into the kernel, but it can take a long time to catch up.

The same thing happens with new WiFi cards. Someone will roll out an improvement to the stack ("Here's Wifi 6" "Here's WiFi 6E" "Here's Wifi 7!!" :rocket:) and immediately new WiFi adapters and laptops with the latest adapters built in will hit the shelves. Sometimes it takes a few kernel releases for initial support to be available, and even then bugs will continue to linger for (sometimes) years to come.

@ARNAVVGUPTAA, there may come a day when you are just sitting there doing nothing, rebooting after a kernel update and the issue with your headphones is miraculously gone. :magic_wand: :tophat:

Until then, I'm glad you found a workaround--and I appreciate you updating the thread with the solution you settled on, so folks searching after the same issue in the future can try out your hack for a fix. :+1:

5 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.