Having issues with audio occassionally cutting out on all channels

System:
Kernel: 5.16.13-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=37536d2b-56c7-4224-bd6a-a48d164c6ef7 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
intel_iommu=on iommu=pt systemd.unified_cgroup_hierarchy=0
Console: pty pts/1 wm: kwin_x11 DM: SDDM Distro: Garuda Linux
base: Arch Linux
Machine:
Type: Desktop Mobo: MEDION model: B560H6-EM v: 1.0 serial: <filter>
UEFI: American Megatrends v: 560H6W0X.019 date: 07/12/2021
CPU:
Info: model: 11th Gen Intel Core i5-11400 socket: U3E1 bits: 64
type: MT MCP arch: Rocket Lake family: 6 model-id: 0xA7 (167) stepping: 1
microcode: 0x50
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 480 KiB desc: d-6x48 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 12 MiB desc: 1x12 MiB
Speed (MHz): avg: 3895 high: 4382 min/max: 800/4400 base/boost: 4158/4400
scaling: driver: intel_pstate governor: performance volts: 1.2 V
ext-clock: 100 MHz cores: 1: 4213 2: 3908 3: 4065 4: 3769 5: 3489 6: 4382
7: 3529 8: 2759 9: 3728 10: 4243 11: 4313 12: 4351 bogomips: 62208
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA GA106 [GeForce RTX 3060] vendor: ZOTAC driver: nvidia
v: 510.54 alternate: nouveau,nvidia_drm pcie: gen: 4 speed: 16 GT/s
lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:2503 class-ID: 0300
Device-2: SHENZHEN EMEET HD Webcam C960 type: USB
driver: hid-generic,snd-usb-audio,usbhid,uvcvideo bus-ID: 1-5:5
chip-ID: 328f:2013 class-ID: 0300 serial: <filter>
Display: server: X.Org v: 1.21.1.3 compositor: kwin_x11 driver: X:
loaded: nvidia unloaded: modesetting alternate: fbdev,nouveau,nv,vesa
gpu: nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x1080 s-dpi: 90 s-size: 1084x301mm (42.7x11.9")
s-diag: 1125mm (44.3")
Monitor-1: DP-0 pos: primary,left res: 1920x1080 dpi: 94
size: 521x293mm (20.5x11.5") diag: 598mm (23.5")
Monitor-2: DP-2 pos: primary,right res: 1920x1080 dpi: 90
size: 544x303mm (21.4x11.9") diag: 623mm (24.5")
OpenGL: renderer: NVIDIA GeForce RTX 3060/PCIe/SSE2
v: 4.6.0 NVIDIA 510.54 direct render: Yes
Audio:
Device-1: Intel Tiger Lake-H HD Audio vendor: MEDION AG
driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_tgl
bus-ID: 00:1f.3 chip-ID: 8086:43c8 class-ID: 0403
Device-2: NVIDIA vendor: ZOTAC driver: snd_hda_intel v: kernel pcie:
gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:228e
class-ID: 0403
Device-3: JMTek LLC. USB PnP Audio Device type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-1:2 chip-ID: 0c76:161e
class-ID: 0300
Device-4: SHENZHEN EMEET HD Webcam C960 type: USB
driver: hid-generic,snd-usb-audio,usbhid,uvcvideo bus-ID: 1-5:5
chip-ID: 328f:2013 class-ID: 0300 serial: <filter>
Sound Server-1: ALSA v: k5.16.13-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.48 running: yes
Network:
Device-1: Intel Tiger Lake PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:43f0 class-ID: 0280
IF: wlo1 state: down mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: MEDION AG driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: 3000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
IF-ID-1: docker0 state: down mac: <filter>
IF-ID-2: virbr0 state: down mac: <filter>
Bluetooth:
Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 1-14:6 chip-ID: 8087:0026 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
Local Storage: total: 982.7 GiB used: 532.08 GiB (54.1%)
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
model: MZVL21T0HCLR-00B00 size: 953.87 GiB block-size: physical: 512 B
logical: 512 B speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
rev: GXA7301Q temp: 38.9 C scheme: GPT
SMART: yes health: PASSED on: 17d 23h cycles: 213
read-units: 15,274,953 [7.82 TB] written-units: 18,056,507 [9.24 TB]
ID-2: /dev/sda maj-min: 8:0 type: USB vendor: Kingston
model: DataTraveler 3.0 size: 28.83 GiB block-size: physical: 512 B
logical: 512 B type: N/A serial: <filter> rev: 1100 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
ID-1: / raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 532.08 GiB (55.8%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
maj-min: 259:1
ID-3: /home raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 532.08 GiB (55.8%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
ID-4: /var/log raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 532.08 GiB (55.8%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
ID-5: /var/tmp raw-size: 953.57 GiB size: 953.57 GiB (100.00%)
used: 532.08 GiB (55.8%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.5 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 50.0 C mobo: N/A gpu: nvidia temp: 57 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info:
Processes: 371 Uptime: 2h 54m wakeups: 0 Memory: 15.5 GiB
used: 8.81 GiB (56.9%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 clang: 13.0.1 Packages: 1912 pacman: 1906 lib: 547 flatpak: 6
Shell: garuda-inxi (sudo) default: Bash v: 5.1.16 running-in: yakuake
inxi: 3.3.13
Garuda (2.5.5-1):
System install date:     2022-01-10
Last full system update: 2022-03-09
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:            memavaild.service systemd-oomd.socket

I've tried using pulse audio and not using pulse audio but the issue seems to persist, and it's quite inconsistent it's not like cutting out constantly, but the interval and frequency seems to change for no apparent reason. Lmao not even sure how to approach this issue, anyone else experiencing this? I've been having the issue since I started using garuda, so it's been quite a while.

It sounds like perhaps your sound card is running with a power-saving feature enabled. If you can find it and shut it off it might help.

Check to see if you have any .conf files in /etc/modprobe.d/ related to audo power save, for example options snd_hda_intel power_save=1. Changing the value to zero would turn it off.

1 Like

Doesn't seem to be the cause, had no audio power save related files. it's so weird that the issue came out of the box, seems to just be an audio playing issue the system still receives the audio fine.

Off the top of my head the other thing that comes to mind to try would be switching to the LTS kernel. You can install the LTS kernel from Garuda Assistant and switch kernels from the grub menu before the login screen.

1 Like

Here's what I do:

Create a text file inside /etc/modprobe.d.
Name it, "snd_hda_intel.conf"
Inside the text file write: "options snd_hda_intel power_save=0"
Save, exit, reboot.

This will stop any power-saving features that sometimes interfere with my sound output.

2 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.