Have to close and reopen laptop lid on reboot

Hello all,

I've been an arch user for a few years now, so I have some experience in that area, but I'm in my first few days of using Garuda. [Side note: I'm loving it so far!]. The one thing that's puzzling me is every time that I reboot (or cold start) my laptop, before I can log in I have to close my laptop lid and then open it back up. This would only happen when it booted up and didn't happen again until a reboot.

When I start the laptop I make it past the GRUB screen, and then my laptop will flash the dell logo a few times (on some reboots), and then the screen will go dark (one time it displayed the two lines: Loading kernel and Loading initial ramdisk, and froze. I left it for about a minute and it was still just those two lines). Then, I close the laptop lid, leave it for a few seconds, and then open it back up. About a second or two later, I see the mouse appear in the bottom right corner, and after another second or two, the login screen will appear.

I've tried pressing enter and typing my password in before the lid open and close to test if it was just the display not showing but that doesn't change anything, the login screen just appeared as usual. I also checked journalctl -p 3 -xb (and -p 4), but I couldn't find anything that seemed relevant (I may have missed something though).

It wasn't happening to me immediately after I installed Garuda, so I initially thought it was caused by something to do with my dotfiles, since I have a setup script in there that I recently finished writing so I could get started on Garuda that goes and edits some of my system config files with sed and etc. (which I actually really happy with, it's been really fun writing them!), but it turns out on a completely fresh install, while the laptop boots as expected immediately after finishing the install process, the issue is still there after running the setup assistant (choosing a bunch of software installed from the offered selection). Since I installed a new kernel in the process (xanmod), I tried switching back to the tkg-bmq kernel and the issue persisted.

I haven't found any similar issues online, so I'm asking here. Has this happened to anyone else before? Anything I can do next?

Thanks :slight_smile:

EDIT: I also installed the linux-lts kernel and when I rebooted into that I did not have this issue. I'll do a bit more googleing and see if I can find something.

EDIT 2: I rebooted again back with the xanmod kernel and it started just fine. The only difference here was I ran quikaccess and installed all its deps. I tried the tkg-bmq kernel again, and it was still working fine. I'll see how it goes from here.

EDIT 3: So I'm not sure how I got the previous success on the xanmod kernel, becuase I tried again on both the default linux kernel, the linux-lts kernel, and the linux-tkg-bmq kernel, and it booted just fine on all of those. Looks like I'll be sticking to tkg-bmq for the time being, unless I can figure something out soon.

1 Like

Bisecting the kernel to find the issue should be easy-peasy for an experienced Arch user. Prefacing your post with the above statement implies something.

regards

4 Likes

Sorry, but I tend to agree with @c00ter here. If you've used Arch for several years, you should not need to be told to test the LTS kernel before opening a help request about this. Your symptoms scream "kernel related issue". I would think that testing the LTS kernel would be an automatic response for a seasoned Arch user in this situation.

Glad you found your solution, but perhaps test a bunch of alternate kernels before opening a help request in the future.

Sorry if we're seeming rude, but an Arch user should already know this stuff.

Please don't be offended by the grumpy old guys.

Welcome to Garuda.

4 Likes

But also (and on the other hand), it's good to know you tried things and found something that worked. :grin:

2 Likes