[HARDWARE FAULTY] Garuda crashed and is stuck in the cool loading screen

So yeah, I was playing rocket league and suddenly, my system froze completely. I had hibernate it the night before. I did a hard power off and tried rebooting. Sometimes, it would take a while to boot, but when I reset it again, it usually works.This time, it hasn't. I tried going to previous snapshots, but that didn't work either.

Any suggestions on wut I should do?

The laptop I have is an Asus vivo book with Intel cpu and Intel integrated gpu and Nvidia 1050ti with 32 GB RAM. It's on single boot with 32 GB swap as well.

Hibernating a frozen state is not a good idea (I don't even know if it's possible btw), coz even when you resume it's frozen. So maybe why you're not able to boot is you're resuming a frozen state so it's again frozen. Try removing resume=UUID=UUID from kernel parameters at before boot (you can do this by pressing E in Grub Menu).

1 Like

@SameExpert My bad. I didn't convey it properly. Last night, I hibernated and resumed it today morning. All was well and good until I played rocket league, where my system froze. And after it did, I did a hard power off. Nevertheless, I will try your solution.

Edit: removing that line didn't work

How long did you wait? Normally, when you force poweroff, the system checks for filesystem errors and it may take time. It's better you post your inxi -Fxxxza (If you can't boot into the PC you can do it with Live USB) and some experts may help you out.

1 Like

I've waited for the better part of 2 hours. I think I'm gonna boot into live USB. Thanks!

Ok, I did a live USB boot into linux mint. I'm unable to mount my nvme disk in which I installed Garuda. It says "Can't read superblock on /dev/nvme0n1p2" (That's the btrfs partition in which Garuda is installed")

I had a bad superblock on that partition and the backup superblocks were also corrupted, so I wasn't able to mount that drive normally anymore. I reformatted the whole drive and flashed garuda again along with fedora. But some weird issues start up now. I suspect a drive issue. In any case, I'm closing this topic. No solution found.


Also be sure to check your ram, as bad ram can corrupt your hard drive.