Hard Disk not recognized after update to Kernel: 6.2.2-zen1-1-zen

My HDD(1TB) used to be detected properly on kernel 6.1 but now it is not getting detected after the update to kernel = 6.2 version.

I've have tried live-booting with ubuntu-unity 22.10 and manjaro-kde with kernel 6.1.12 and in both of these the HDD is getting detected.

Kernel: 6.2.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=ed329938-824d-4feb-9e33-6e4f40b11e9c rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=7cbda469-84a9-4c52-bb43-caae1e75782b loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.2 tk: Qt v: 5.15.8 wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Type: Laptop System: Acer product: Nitro AN515-56 v: V1.08
serial: <superuser required>
Mobo: TGL model: Scala_TLM v: V1.08 serial: <superuser required>
UEFI: Insyde v: 1.08 date: 12/02/2021
ID-1: BAT1 charge: 45.4 Wh (89.2%) condition: 50.9/57.5 Wh (88.6%)
volts: 17.3 min: 15.4 model: LGC AP18E8M type: Li-ion serial: <filter>
status: charging cycles: 58
Info: model: 11th Gen Intel Core i5-11300H bits: 64 type: MT MCP
arch: Tiger Lake gen: core 11 level: v4 note: check built: 2020
process: Intel 10nm family: 6 model-id: 0x8C (140) stepping: 1
microcode: 0xA6
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 5 MiB desc: 4x1.2 MiB L3: 8 MiB
desc: 1x8 MiB
Speed (MHz): avg: 2842 high: 3308 min/max: 400/4400 scaling:
driver: intel_pstate governor: powersave cores: 1: 3100 2: 3100 3: 3100
4: 832 5: 3100 6: 3100 7: 3308 8: 3100 bogomips: 49766
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics]
vendor: Acer Incorporated ALI driver: i915 v: kernel arch: Gen-12.1
process: Intel 10nm built: 2020-21 ports: active: eDP-1 empty: DP-1
bus-ID: 0000:00:02.0 chip-ID: 8086:9a49 class-ID: 0300
Device-2: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q]
vendor: Acer Incorporated ALI driver: nvidia v: 525.89.02
alternate: nouveau,nvidia_drm non-free: 525.xx+
status: current (as of 2023-02) arch: Turing code: TUxxx
process: TSMC 12nm FF built: 2018-22 bus-ID: 0000:01:00.0
chip-ID: 10de:1f9d class-ID: 0300
Device-3: Quanta HD User Facing type: USB driver: uvcvideo bus-ID: 2-8:3
chip-ID: 0408:a061 class-ID: 0e02
Display: x11 server: X.Org v: 21.1.7 with: Xwayland v: 22.1.8
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia unloaded: nouveau
alternate: fbdev,intel,nv,vesa dri: iris gpu: i915 display-ID: :0
screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 model: ChiMei InnoLux 0x1521 built: 2020 res: 1920x1080
hz: 144 dpi: 142 gamma: 1.2 size: 344x193mm (13.54x7.6") diag: 394mm (15.5")
ratio: 16:9 modes: 1920x1080
API: OpenGL v: 4.6 Mesa 22.3.6 renderer: Mesa Intel Xe Graphics (TGL GT2)
direct-render: Yes
Device-1: Intel Tiger Lake-LP Smart Sound Audio
vendor: Acer Incorporated ALI driver: sof-audio-pci-intel-tgl
alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 0000:00:1f.3
chip-ID: 8086:a0c8 class-ID: 0401
Device-2: NVIDIA vendor: Acer Incorporated ALI driver: snd_hda_intel
v: kernel bus-ID: 0000:01:00.1 chip-ID: 10de:10fa class-ID: 0403
Sound API: ALSA v: k6.2.2-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.66 running: yes
Device-1: Intel Wi-Fi 6 AX201 vendor: Rivet Networks driver: iwlwifi
v: kernel bus-ID: 0000:00:14.3 chip-ID: 8086:a0f0 class-ID: 0280
IF: wlp0s20f3 state: up mac: <filter>
Device-2: Realtek vendor: Acer Incorporated ALI driver: r8169 v: kernel
port: 3000 bus-ID: 0000:2c:00.0 chip-ID: 10ec:2600 class-ID: 0200
IF: enp44s0 state: down mac: <filter>
Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 2-10:4 chip-ID: 8087:0026 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter>
Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:9a0b rev: class-ID: 0104
Local Storage: total: 476.94 GiB used: 16.85 GiB (3.5%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix model: HFM512GD3JX016N
size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 type: SSD serial: <filter> rev: 41020C20 temp: 48.9 C scheme: GPT
ID-1: / raw-size: 459.68 GiB size: 459.68 GiB (100.00%)
used: 16.85 GiB (3.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 608 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 459.68 GiB size: 459.68 GiB (100.00%)
used: 16.85 GiB (3.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 459.68 GiB size: 459.68 GiB (100.00%)
used: 16.85 GiB (3.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 459.68 GiB size: 459.68 GiB (100.00%)
used: 16.85 GiB (3.7%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 16.96 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
ID-2: swap-2 type: zram size: 15.42 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Src: /sys System Temperatures: cpu: 46.0 C mobo: N/A
Fan Speeds (RPM): N/A
Processes: 251 Uptime: 18m wakeups: 18002 Memory: 15.42 GiB
used: 3.07 GiB (19.9%) Init: systemd v: 253 default: graphical
tool: systemctl Compilers: gcc: 12.2.1 Packages: pm: pacman pkgs: 1187
libs: 311 tools: octopi,paru Shell: fish v: 3.6.0 default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.25
Garuda (2.6.15-1):
System install date:     2023-03-06
Last full system update: 2023-03-06 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       No/Undetected
Failed units:

I can't move back to older snapshot now because I did a fresh install of garuda-linux thinking that the issue might be because of the additional-software that I installed.. :frowning:

Try installing the LTS kernel and headers to see the drive is detected. The LTS kernel is currently on 6.1.

First bring your system fully up to date with garuda-update, then install the kernel and headers:

sudo pacman -S linux-lst linux-lts-headers

Select the LTS kernel from advanced boot options in the Grub menu.

If that resolves the issue, you may be up against a kernel bug and I would just use the LTS kernel until a fix comes down from upstream.


It is still not being detected with linux-lts..
Current output of sudo fdisk -l

Disk /dev/nvme0n1: 476.94 GiB, 512110190592 bytes, 1000215216 sectors
Disk model: HFM512GD3JX016N
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 864B2EC4-A359-3241-A735-C019A4666C6B

Device             Start        End   Sectors   Size Type
/dev/nvme0n1p1      4096     618495    614400   300M EFI System
/dev/nvme0n1p2    618496  964635926 964017431 459.7G Linux filesystem
/dev/nvme0n1p3 964635927 1000206899  35570973    17G Linux swap

Disk /dev/zram0: 15.42 GiB, 16561209344 bytes, 4043264 sectors
Units: sectors of 1 * 4096 = 4096 bytes
Sector size (logical/physical): 4096 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes

Search for clues in dmesg; see if there are any failure messages related to the disk.

nothing suspicious.. I tried sudo dmesg | grep sd

[    0.009042] ACPI: SSDT 0x0000000045BE2000 00B254 (v02 INTEL  TcssSsdt 00001000 INTL 20160422)
[    0.165162] ACPI: SSDT 0xFFFF88A481C07800 0001C6 (v02 PmRef  Cpu0Psd  00003000 INTL 20160422)
[    0.172076] ACPI: SSDT 0xFFFF88A481240800 0004D4 (v02 PmRef  ApPsd    00003000 INTL 20160422)
[    2.235478] ahci 10000:e0:17.0: flags: 64bit ncq sntf pm clo only pio slum part deso sadm sds
[    2.668570] BTRFS info (device nvme0n1p2): enabling ssd optimizations

Hmm, that is curious. :thinking: Does the disk show up in your UEFI/BIOS menu? (Assuming storage devices are reported in your system's BIOS interface.)

Yes, I can see it in the Bios

I still suspect something wacky with the kernel update. Check out this thread, a few other folks have been hit by something similar: SSD drive disappeared after upgrade to linux-6.2.1.arch1-1 / Kernel & Hardware / Arch Linux Forums

Try downgrading the kernel to test if the device reappears after rebooting.

sudo downgrade linux-zen

Pick the last version (besides 6.2.2, obviously) you have in /var/chache/pacman/pkg, that's probably the one that was working before the update.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.