Grub Theme not applying


I just installed this distro and I love it so far. I first installed this by replacing my ubuntu installation using the replace option on garuda installer (this is on a dual boot with windows 11 secure boot off). On that installation the grub theme was applied. I redid the installation because I wanted encryption so I manually deleted the partitions (I think the boot partition was ext4) and manually created the partitions but this time the boot is btrfs (I heard this might cause issues but ext4 was not given as an option in the garuda installer). The /boot and /boot/efi are not encrypted while /root is. On this install I noticed the grub theme was the normal black and white theme. I wanted the dragonized theme.

What I tried:

  • I updated using

sudo pacman -Sy
sudo pacman -Syu

  • I tried using the built in garuda boot options. The theme box was checked. Unchecked and applied, checked and applied. Reboot and still same issue. I checked splash theme and that didn’t stay checked after I applied and when back to the same window. I also noticed I was unable to open help or display logs.

  • I tried manually changing the values in /etc/defaults/grub with gvim. It looked correct.
    The file contents will be near the end

  • I tried

sudo grub-install
sudo update-grub

Output of update-grub will be near end

output of sudo update-grub:
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-linux-zen
Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux-zen.img
Found fallback initrd image(s) in /boot:  intel-ucode.img initramfs-linux-zen-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
Found Windows Boot Manager on /dev/nvme0n1p2@/efi/Microsoft/Boot/bootmgfw.efi
Adding boot menu entry for UEFI Firmware Settings ...
Detecting snapshots ...
Found snapshot: 2023-11-21 13:16:22 | @/.snapshots/24/snapshot | post | ca-certificates-mozilla git lib32-nss linux-zen linux-zen-headers nfs-ut |
Found snapshot: 2023-11-21 13:15:49 | @/.snapshots/23/snapshot | pre  | pacman -Su                            |
Found snapshot: 2023-11-21 13:04:04 | @/.snapshots/22/snapshot | post | conky                                 |
Found snapshot: 2023-11-21 13:04:03 | @/.snapshots/21/snapshot | pre  | pacman -R conky                       |
Found snapshot: 2023-11-21 13:03:56 | @/.snapshots/20/snapshot | post | conky-manager                         |
Found snapshot: 2023-11-21 13:03:55 | @/.snapshots/19/snapshot | pre  | pacman -R conky-manager               |
Found snapshot: 2023-11-21 03:25:29 | @/.snapshots/18/snapshot | post | python-argcomplete python-pipx python-userpath                           |
Found snapshot: 2023-11-21 03:25:28 | @/.snapshots/17/snapshot | pre  | pacman -S python-pipx                 |
Found snapshot: 2023-11-21 03:16:21 | @/.snapshots/16/snapshot | post | python-cryptography python-pip python-wheel                              |
Found snapshot: 2023-11-21 03:16:20 | @/.snapshots/15/snapshot | pre  | pacman -S python-pip                  |
Found 10 snapshot(s)
Unmount /tmp/grub-btrfs.C88jMEspk9 .. Success
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe: warning: unknown device type nvme0n1.

file /etc/default/grub

# GRUB boot loader configuration

GRUB_CMDLINE_LINUX_DEFAULT='quiet rd.luks.uuid=cec3ee25-e912-4b5c-b9e9-29c377bc4000 loglevel=3'

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices

# Set to 'countdown' or 'hidden' to change timeout behavior,
# press ESC key to display menu.

# Uncomment to use basic console

# Uncomment to disable graphical terminal

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `videoinfo'

# Uncomment to allow the kernel use the same resolution used by grub

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"

# Uncomment to disable generation of recovery mode menu entries

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.

# Uncomment one of them for the gfx desired, a image background or a gfxtheme

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

# Uncomment to make GRUB remember the last selection. This requires
# setting 'GRUB_DEFAULT=saved' above.

# Uncomment to disable submenus in boot menu

# Probing for other operating systems is disabled for security reasons. Read
# documentation on GRUB_DISABLE_OS_PROBER, if still want to enable this
# functionality install os-prober and uncomment to detect and include other
# operating systems.

# This config file imports drop-in files from /etc/default/grub.d/.
for garuda_grub_d in ${sysconfdir}/default/grub.d/*.cfg ; do if [ -e "${garuda_grub_d}" ]; then source "${garuda_grub_d}"; fi; done
Kernel: 6.6.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: acpi_pm parameters: BOOT_IMAGE=/vmlinuz-linux-zen
root=UUID=bef76749-c48d-4bdc-9b91-d0359a19ad52 rw rootflags=subvol=@
quiet rd.luks.uuid=cec3ee25-e912-4b5c-b9e9-29c377bc4000 loglevel=3
Desktop: KDE Plasma v: 5.27.9 tk: Qt v: 5.15.11 wm: kwin_wayland vt: 1
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Convertible System: LENOVO product: 82R7 v: IdeaPad Flex 5 14IAU7
serial: <superuser required> Chassis: type: 31 v: IdeaPad Flex 5 14IAU7
serial: <superuser required>
Mobo: LENOVO model: LNVNB161216 v: SDK0T76463 WIN
serial: <superuser required> UEFI: LENOVO v: J7CN44WW date: 05/24/2023
ID-1: BAT0 charge: 41.9 Wh (79.5%) condition: 52.7/52.5 Wh (100.4%)
volts: 12.5 min: 11.5 model: SMP L21M3PE0 type: Li-poly serial: <filter>
status: not charging cycles: 56
Info: model: 12th Gen Intel Core i5-1235U bits: 64 type: MST AMCP
arch: Alder Lake level: v3 note: check built: 2021+
process: Intel 7 (10nm ESF) family: 6 model-id: 0x9A (154) stepping: 4
microcode: 0x430
Topology: cpus: 1x cores: 10 mt: 2 tpc: 2 st: 8 threads: 12 smt: enabled
cache: L1: 928 KiB desc: d-8x32 KiB, 2x48 KiB; i-2x32 KiB, 8x64 KiB
L2: 6.5 MiB desc: 2x1.2 MiB, 2x2 MiB L3: 12 MiB desc: 1x12 MiB
Speed (MHz): avg: 400 min/max: 400/4400:3300 scaling: driver: intel_pstate
governor: performance cores: 1: 400 2: 400 3: 400 4: 400 5: 400 6: 400
7: 400 8: 400 9: 400 10: 400 11: 400 12: 400 bogomips: 59904
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel Alder Lake-UP3 GT2 [Iris Xe Graphics] vendor: Lenovo
driver: i915 v: kernel arch: Gen-12.2 process: Intel 10nm built: 2021-22+
ports: active: eDP-1 empty: DP-1,DP-2,HDMI-A-1 bus-ID: 00:02.0
chip-ID: 8086:46a8 class-ID: 0300
Device-2: Bison Integrated Camera driver: uvcvideo type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-6:2 chip-ID: 5986:214d
class-ID: fe01 serial: <filter>
Display: wayland server: v: with: Xwayland v: 23.2.2
compositor: kwin_wayland driver: X: loaded: modesetting
alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: 0
Monitor-1: eDP-1 res: 1536x960 size: N/A modes: N/A
API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
device: 1 drv: swrast surfaceless: drv: iris wayland: drv: iris x11:
drv: iris inactive: gbm
API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.2.1-arch1.2
glx-v: 1.4 direct-render: yes renderer: Mesa Intel Graphics (ADL GT2)
device-ID: 8086:46a8 memory: 14.83 GiB unified: yes display-ID: :1.0
API: Vulkan v: 1.3.269 layers: 9 device: 0 type: integrated-gpu name: Intel
Graphics (ADL GT2) driver: mesa intel v: 23.2.1-arch1.2
device-ID: 8086:46a8 surfaces: xcb,xlib,wayland device: 1 type: cpu
name: llvmpipe (LLVM 16.0.6 256 bits) driver: mesa llvmpipe
v: 23.2.1-arch1.2 (LLVM 16.0.6) device-ID: 10005:0000
surfaces: xcb,xlib,wayland
Device-1: Intel Alder Lake PCH-P High Definition Audio vendor: Lenovo
driver: sof-audio-pci-intel-tgl
alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 00:1f.3
chip-ID: 8086:51c8 class-ID: 0401
API: ALSA v: k6.6.2-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 0.3.85 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:51f0 class-ID: 0280
IF: wlp0s20f3 state: up mac: <filter>
Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-10:4 chip-ID: 8087:0026
class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 2 state: down bt-service: enabled,running
rfk-block: hardware: no software: no address: <filter> bt-v: 5.2 lmp-v: 11
status: discoverable: no pairing: no
Local Storage: total: 931.51 GiB used: 15.09 GiB (1.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 980 PRO 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: 5B2QGXA7 temp: 42.9 C
scheme: GPT
ID-1: / raw-size: 462.1 GiB size: 462.1 GiB (100.00%) used: 14.94 GiB (3.2%)
fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-cec3ee25-e912-4b5c-b9e9-29c377bc4000
ID-2: /boot raw-size: 1 GiB size: 1 GiB (100.00%) used: 148.6 MiB (14.5%)
fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-3: /boot/efi raw-size: 500 MiB size: 499 MiB (99.80%)
used: 576 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p6 maj-min: 259:6
ID-4: /home raw-size: 462.1 GiB size: 462.1 GiB (100.00%)
used: 14.94 GiB (3.2%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-cec3ee25-e912-4b5c-b9e9-29c377bc4000
ID-5: /var/log raw-size: 462.1 GiB size: 462.1 GiB (100.00%)
used: 14.94 GiB (3.2%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-cec3ee25-e912-4b5c-b9e9-29c377bc4000
ID-6: /var/tmp raw-size: 462.1 GiB size: 462.1 GiB (100.00%)
used: 14.94 GiB (3.2%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-cec3ee25-e912-4b5c-b9e9-29c377bc4000
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 15.19 GiB used: 1.5 MiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 12 dev: /dev/zram0
System Temperatures: cpu: 48.0 C mobo: N/A
Fan Speeds (rpm): N/A
Processes: 336 Uptime: 13m wakeups: 0 Memory: total: 16 GiB note: est.
available: 15.19 GiB used: 3.51 GiB (23.1%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
pm: pacman pkgs: 1943 libs: 569 tools: octopi,pamac,paru Shell: fish
v: 3.6.1 running-in: konsole inxi: 3.3.31
Garuda (2.6.19-2):
System install date:     2023-11-21
Last full system update: 2023-11-21
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       Probably (Run as root to verify)
Failed units:

Try commenting this line out, then regenerate the Grub configuration file again.

sudo update-grub

By the way, thank you for including a lot of useful information in your first forum topic! And welcome to the community. :slightly_smiling_face:


I don’t think that first suggestion is right actually; I was thinking of the other console line.

Can you double-check the theme is installed?

ls -R /usr/share/grub/themes/

Edit 2:

One more suggestion:

Try changing this to auto.


Then regenerated the Grub configuration file and test again. :crossed_fingers:


Thanks for the reply.
I have messed up my install by trying to use my yubikey to act as my passphrase and causing the system not recognizing the partition. I shall be doing a reinstall soon.

Before the mess up I had confirmed the grub theme was installed. Which makes sense cause it comes preinstalled by default with an internet connection.


was originally auto. I tried changing it to this resolution because I saw a post saying the resolution could mess up the theme.


As I was reinstalling garuda a thought crossed my mind.

Is the reason the grub theme is not applying is because the grub theme pulls from the root partition which is LUKS encrypted? Or does the theme apply and bakes in to GRUB when update-grub is ran?

Can confirm GRUB grabs the files on boot up and is not baked in. I fixed this issue by adding the theme files to boot/efi and changing the file /etc/default/grub to the destination of the theme on boot/efi. Ran update-grub after and this fixed the issue.


1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.