Grub not loading after Garuda update

Hi there, yesterday (4 April) I've updated my Garuda installation (Gnome) and after rebooting the boot process stops with GRUB _ (blinking underscore). I read lots of posts about how to re-install Grub but I must be doing something wrong.

I booted from my live Garuda USB and tried to walk through the process outlined in a number of posts (Grub fails after update - #2 by librewish).
sudo mkdir /mnt (already existed)
sudo mount /dev/sde3 /mnt
sudo mount /dev/sde2 /mnt/boot
sudo garuda-chroot /mnt/@
sudo grub-install /dev/sde (exits with an error that embedding on fat is not supported)

sde2 is mounted correctly and I can see the Grub folder and all kernel images in the gnome file manager. However, if I change into the /boot folder in the terminal it only shows the grub folder. I don't understand why that is.

Here is the partitioning of my SSD:
Disk /dev/sde: 447.13 GiB, 480103981056 bytes, 937703088 sectors
Disk model: CT480BX500SSD1
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 7AB45423-AB9F-6A4B-BB10-203AF096E7B8

Device Start End Sectors Size Type
/dev/sde1 2048 18431 16384 8M Linux filesystem
/dev/sde2 18432 1247231 1228800 600M Microsoft basic data
/dev/sde3 1247232 528101375 526854144 251.2G Linux filesystem

2 is mounted to /boot (FAT32)
3 is mounted to / (BTRFS)

Any help is appreciated.

I assume that sde2 is the EFI partition? Did you mount that to /boot/efi during installation?

Where are the /boot files? On sde3?

Assuming that sde2 is only the EFI partition, then you need to mount that at /mnt/boot/efi not /mnt/boot.

Also make sure you mount the correct BTRFS subvolume, not the partition (i.e. mount -o subvol=@ /dev/sde3 /mnt).

Go back through the steps and try again.

2 Likes

Thanks Jonathon, Initially I tried using efi but after an update of the system the option to boot Garuda disappeared in the boot menu of the bios and I couldn't start Garuda any more. I then re-installed Garuda with the MBR option for which I had to create a boot partition sde2 and the root partition as BTRFS on sde3. So the grub folder and kernel images are on sda2 (no efi) and root is on / sde3

So you installed to a GPT disk in BIOS boot mode. That must mean sde1 is the GRUB BIOS partition.

Not the most straightforward setup by a long shot.

Personally, I'd either boot in UEFI mode with the GPT partition table (and fix or reinstall), or wipe the disk and create an MBR partition table if you're using BIOS mode.

However, given this is sde there are likely to be other disks in the system, which means you're likely to be dual (or more) booting, and that means you want to pick one boot mode and use it for all OS to keep things nice and straightforward.

Therefore, my recommendation would be to boot in UEFI mode and either reinstall (easiest) or manually set up the GRUB boot loader again (mounting /dev/sde3 to /mnt and /dev/sde2 to /mnt/boot/efi , reinstalling GRUB pacman -S grub, and then running grub-install /dev/sde).

3 Likes

Blimey! I need to get my head around this first. Yes, you are correct, I have a multi boot setup with Ubuntu on other disks. Sorry, I know Garuda doesn't support this setup but I can't explain this to my children who want to use Ubuntu. Initially the issue I had was that Garuda wasn't detected on the Ubuntu grub. So I thought using this way would make it work (but It didn't work either). I can live with this because Garuda detects my Ubuntu partitions (although I can't change the boot order in Garuda grub for some reason - but that's a different topic)

My info on how to install Garuda came through posts and videos I've checked out. I'm okay installing Garuda again. What would be the best way of partitioning and/or setting up Garuda.
I must be able to multi boot (Ubuntu uses MBR) and it must be safe. I cannot afford loosing the ability to boot Ubuntu.

Ubuntu can be installed on GPT. This might solve one of your problems.

Thanks waeking, but I can't re-install Ubuntu again - it's just too much work. I have four user accounts all set up for the family.
I like Garuda and would like to make it work for me but it needs to work reliably. I'm still experimenting with Garuda so don't mind installing it again (the fourth time :wink:

As you did not provide your system specs I do not know for sure if this is a laptop or a desktop computer system. I am going to assume this is a desktop system as that is more likely for a multi user family computer IMO.

Multi-booting creates nothing but headaches. If you have the funds a hot swap SSD rack is the simplest solution for running multiple OS's and it does not require a boot manager.

A hot swap rack can be purchased on sale as cheaply as $50-$85 in Canada or the US. These docks can be purchased in 4 to 6 Bay models. The hot swap dock fits inside a standard size CD/DVD bay in a desktop computer.

Once you have this installed Multi-booting becomes unbelievably simple. In Canada or the US an SSD drive in 128 GB size can be purchased for under $20 to $25. Simply install each OS on its own small cheap SSD and your multi-boot problems are over.

All you do is shutdown and swap SSD's when you wish to change OS's. No more headaches and borked installs from one OS overwriting the others boot loader.

Yes it costs a little more, but if you buy the components on sale it can be done quite cheaply. If you go this route you will never look back. I have been using this method for almost 15 years and would never go back to using a boot manager to swap OS's.

Just a word to the wise if you want to avoid all these issues.

1 Like

Hi tbg, I fully appreciate your response and I will certainly look into this. However, I would kindly like to mention that the problem of the non starting grub occurred after updating Garuda and the request to restart the system. Before the update everything worked just fine. So the update must have broken something and prevent grub from starting. All I was asking for was some advise on how to get Garuda grub back working again. So far I have not managed to get back into my Garuda system.
All my other Linux installations are on separate disks with their own boot manager. No interference there. I actually invoke the BIOS boot manager to select from which disk to boot.

I'm pretty sure @jonathon covered that in great detail for you. Unfortunately if the installed OS's can see the other OS's, breakages are likely to occur during updates.

Generally we try to avoid offering advice on multi-boot scenarios because this is really not a Garuda issue. If you choose to install in a multi-boot manner you are the one who is responsible for managing your system.

I was merely offering a suggestion to avoid all the multi-boot pitfalls that people may encounter. A hardware solution is the most problem free manner of booting multiple OS's on one system.

Not to be rude, but if you choose to use a boot manager with multiple OS's, then you choose to complicate your install, and that is your responsibility to troubleshoot (not Garuda's).

1 Like

Moving back to the issue:

Match the Garuda boot setup to the one used for Ubuntu. If Ubuntu uses MBR+BIOS then use MBR+BIOS for Garuda to make things easy.

No special setup is needed, but I'd go for a variation on the classic:

Mountpoint Filesystem Size
swap swap Same as RAM
/boot ext4 512MB
/ btrfs 40GB (or more)
/home btrfs remaining

It's not a "popular" layout but separating /home from / means reinstallation without affecting personal files is trivial, swap partition same size as RAM provides for trivial hibernation support, and ext* boot means you can enable saving the previously selected boot option in GRUB.

I've specifically put swap at the start of the table to help avoid catastrophic data loss if you accidentally dd to the wrong disk. As long as you write less than swap size or stop it in time and have a partition table backup (or can just remember how your partitions were set out) you can re-create the partition table and continue as if nothing had happened (well... after restoring the boot loader etc., but that's pretty easy).

1 Like

The error message does not correspond with the command. Are you sure you haven't used /dev/sde2?
We need the actual terminal input and output, to understand the real problem.

Garuda on BIOS installations does not require a /boot partition.
Are you sure you have sde2 mounted at /boot in your system's fstab?

Post your system's /etc/fstab please.

If you want to chroot again, try without /boot partition, just sde3 as / to /mnt.

I think you misunderstand, using Gnome GUI and terminal and chroot.

Just post terminal info.

1 Like
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=572A-5687                            /boot          vfat    defaults,noatime 0 2
UUID=596af91a-fe87-415d-9545-c6711cedc266 /              btrfs   subvol=@,defaults,noatime,space_cache,autodefrag,compress=zstd,ssd 0 1
UUID=596af91a-fe87-415d-9545-c6711cedc266 /home          btrfs   subvol=@home,defaults,noatime,space_cache,autodefrag,compress=zstd,ssd 0 2
UUID=596af91a-fe87-415d-9545-c6711cedc266 /root          btrfs   subvol=@root,defaults,noatime,space_cache,autodefrag,compress=zstd,ssd 0 2
UUID=596af91a-fe87-415d-9545-c6711cedc266 /srv           btrfs   subvol=@srv,defaults,noatime,space_cache,autodefrag,compress=zstd,ssd 0 2
UUID=596af91a-fe87-415d-9545-c6711cedc266 /var/cache     btrfs   subvol=@cache,defaults,noatime,space_cache,autodefrag,compress=zstd,ssd 0 2
UUID=596af91a-fe87-415d-9545-c6711cedc266 /var/log       btrfs   subvol=@log,defaults,noatime,space_cache,autodefrag,compress=zstd,ssd 0 2
UUID=596af91a-fe87-415d-9545-c6711cedc266 /var/tmp       btrfs   subvol=@tmp,defaults,noatime,space_cache,autodefrag,compress=zstd,ssd 0 2
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0

Hi petsam, I guess I made a bit of a mess with the partitioning. It's from the information I could gather on the web. For my very first attempt installing Garuda I used all the default options. It installed well but after the first reboot there was no way of getting back into it - no grub screen at all.

Anyway, here are some more infos. Booting from USB and issuing following commands:

╭─garuda@garuda in ~ 
 ╰─λ sudo mount /dev/sde3 /mnt

 ╭─garuda@garuda in ~ took 11ms
 ╰─λ sudo garuda-chroot /mnt/@
sh-5.1# sudo grub-install /dev/sde
Installing for i386-pc platform.
grub-install: warning: this GPT partition label contains no BIOS Boot Partition; embedding won't be possible.
grub-install: error: filesystem `btrfs' doesn't support blocklists.
sh-5.1# 


check with

sudo blkid

where /boot/efi/ is

I hink it is /dev/sde1

but check!

2 Likes

Boot from installer ISO and

  • Use Gparted to confirm this partition is not formated (no FS)
  • Use Gparted to assign bios_grub flag to /dev/sde1
  • Mount /dev/sde3 and create a /boot folder if not already exists
  • Mount /dev/sde2 and copy all contents in the (newly created) /boot/ folder in /dev/sde3
  • Edit /etc/fstab in /dev/sde3 to de-activate/delete /boot line for sde2
  • Chroot to /dev/sde3 and
  1. re-install grub-garuda, intel-ucode (if you have Intel CPU), amd-code (if you have AMD CPU), grub-btrfs
  2. Re-create kernel images (mkinitcpio -P)
  3. Install grub (grub-install --target=i386-pc /dev/sde)
  4. Exit chroot and reboot

If there are errors reported during the above, post here for guidance.

4 Likes

Hi petsam, thank you so much for your clear instructions. With your guide I have indeed managed to fix the problem and I'm back in.

My special thanks to petsam and jonathon for their patience and time to help me with their incredible expertise. I have learned a lot and hopefully get things working better in future ;-).

3 Likes

Hi jonathon, I have managed to get back into my system. Thank you so much for your time helping me with clear advise. If I need to re-install Garuda in future I will definitely follow your steps.

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.