Grub Item Not Showing Up

'Solus 4.2' Showing up here, but not in grub after reboot

I have used openSUSE ,
they too have a BTRFS filesystem,

╰─λ inxi -Fxxxza
System:    Kernel: 5.11.3-131-tkg-bmq x86_64 bits: 64 compiler: gcc v: 10.2.1 
           parameters: intel_pstate=passive BOOT_IMAGE=/@/boot/vmlinuz-linux-tkg-bmq 
           root=UUID=af593bd0-9376-4175-83b8-a4f1462be0f3 rw [email protected] quiet splash rd.udev.log_priority=3 
           vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 loglevel=3 
           Desktop: KDE Plasma 5.21.2 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 dm: SDDM Distro: Garuda Linux 
Machine:   Type: Laptop System: Dell product: Inspiron 15-3567 v: N/A serial: <filter> Chassis: type: 9 serial: <filter> 
           Mobo: Dell model: 0D53F5 v: A00 serial: <filter> UEFI: Dell v: 2.13.0 date: 08/13/2020 
Battery:   ID-1: BAT0 charge: 12.1 Wh condition: 13.5/41.4 Wh (33%) volts: 16.8/14.8 model: SMP DELL VN3N047 type: Li-ion 
           serial: <filter> status: Unknown 
CPU:       Info: Dual Core model: Intel Core i5-7200U bits: 64 type: MT MCP arch: Amber/Kaby Lake note: check family: 6 
           model-id: 8E (142) stepping: 9 microcode: DE L2 cache: 3 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 21623 
           Speed: 2786 MHz min/max: 400/3100 MHz Core speeds (MHz): 1: 2786 2: 2722 3: 1993 4: 2674 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel HD Graphics 620 vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:5916 
           class ID: 0300 
           Device-2: AMD Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 / M430 / Radeon 520 Mobile] vendor: Dell driver: radeon 
           v: kernel alternate: amdgpu bus ID: 01:00.0 chip ID: 1002:6660 class ID: 0380 
           Device-3: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo bus ID: 1-5:3 chip ID: 0bda:5769 class ID: 0e02 
           serial: <filter> 
           Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: loaded: ati,intel,radeon unloaded: modesetting 
           alternate: fbdev,vesa display ID: :0 screens: 1 
           Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") s-diag: 414mm (16.3") 
           Monitor-1: eDP1 res: 1366x768 hz: 60 dpi: 102 size: 340x190mm (13.4x7.5") diag: 389mm (15.3") 
           OpenGL: renderer: Mesa Intel HD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.3.4 direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell driver: snd_hda_intel v: kernel alternate: snd_soc_skl 
           bus ID: 00:1f.3 chip ID: 8086:9d71 class ID: 0403 
           Sound Server: ALSA v: k5.11.3-131-tkg-bmq 
Network:   Device-1: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter vendor: Dell driver: ath10k_pci v: kernel 
           port: e000 bus ID: 02:00.0 chip ID: 168c:0042 class ID: 0280 
           IF: wlp2s0 state: down mac: <filter> 
           Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell driver: r8169 v: kernel port: d000 
           bus ID: 03:00.0 chip ID: 10ec:8136 class ID: 0200 
           IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
           Device-3: Qualcomm Atheros type: USB driver: btusb bus ID: 1-8:5 chip ID: 0cf3:e009 class ID: e001 
           IF-ID-1: virbr0 state: down mac: <filter> 
Bluetooth: Device-1: Qualcomm Atheros type: USB driver: btusb v: 0.8 bus ID: 1-8:5 chip ID: 0cf3:e009 class ID: e001 
           Message: Required tool hciconfig not installed. Check --recommends 
Drives:    Local Storage: total: 931.51 GiB used: 189.73 GiB (20.4%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: MQ01ABD100 size: 931.51 GiB block size: physical: 4096 B 
           logical: 512 B speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: 3D scheme: GPT 
Partition: ID-1: / raw size: 100 GiB size: 100 GiB (100.00%) used: 22.25 GiB (22.2%) fs: btrfs dev: /dev/sda2 maj-min: 8:2 
           ID-2: /boot/efi raw size: 1024 MiB size: 1022 MiB (99.80%) used: 25.8 MiB (2.5%) fs: vfat dev: /dev/sda1 
           maj-min: 8:1 
           ID-3: /home raw size: 150 GiB size: 150 GiB (100.00%) used: 4.64 GiB (3.1%) fs: btrfs dev: /dev/sda3 maj-min: 8:3 
           ID-4: /var/log raw size: 100 GiB size: 100 GiB (100.00%) used: 22.25 GiB (22.2%) fs: btrfs dev: /dev/sda2 
           maj-min: 8:2 
           ID-5: /var/tmp raw size: 100 GiB size: 100 GiB (100.00%) used: 22.25 GiB (22.2%) fs: btrfs dev: /dev/sda2 
           maj-min: 8:2 
Swap:      Kernel: swappiness: 10 (default 60) cache pressure: 75 (default 100) 
           ID-1: swap-1 type: partition size: 6 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda7 maj-min: 8:7 
           ID-2: swap-2 type: zram size: 2.86 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram0 
           ID-3: swap-3 type: zram size: 2.86 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram1 
           ID-4: swap-4 type: zram size: 2.86 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram2 
           ID-5: swap-5 type: zram size: 2.86 GiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram3 
Sensors:   System Temperatures: cpu: 58.0 C mobo: 55.0 C gpu: radeon temp: 49.0 C 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 252 Uptime: 1h 20m wakeups: 2 Memory: 11.44 GiB used: 3.73 GiB (32.6%) Init: systemd v: 247 Compilers: 
           gcc: 10.2.0 clang: 11.1.0 Packages: pacman: 1684 lib: 498 Shell: fish v: 3.1.2 running in: konsole inxi: 3.3.01 

and snapshot option in Grub.

I mean to say that both Garuda's and openSUSE's grub are kind of similar.
But I didn't find the above in openSUSE.

Please help me out in this issue

Please no picture from terminal output.


and post

inxi -Fxxxza

as text!



Have you restored any timeshift snapshots before?
Afterwards, the grub menu can sometimes boot with configuration files from the snapshot instead of your main system.
See my post about this here:

I plan on making an announcement about this later today to help inform the community, given how many people seem to have this problem.


but I don't think this is the issue

@Austin that's pretty much the only reason why sudo update-grub would do nothing to the grub menu itself.
I would at least check the grub boot entry by hitting "e" for edit on "Garuda Linux."
If it is not booting to a timeshift snapshot in the boot entry, I only have one other idea.

Perhaps you are booting into the grub menu for OpenSuse instead of Garuda. That's all I can think of, although the theme should appear different, which should let you know which grub menu you are in.


Anyway, I would suggest booting in live medium and using Garuda Boot repair.

Also, you should follow @ThePoorPilot 's advice. I never faced same issue, but he did. So, it would be better to follow him, imo.


By the way, I have only Windows, Garuda and Solus in my pc.

I was just saying that openSUSE btrfs grub worked better.


I guess I'm baffled then. I don't know why Grub would fail to update with the Solus boot entry.

My only other theory is that perhaps you need to scroll down a bit farther in the Grub Menu. Maybe it's at the very bottom or above the Garuda boot entry in a place that is cut off.

Otherwise, I really have no idea.

You can try using the grub-install command to reinstall grub to a different drive/partition, just for testing purposes.

By definition, if you thought correctly, you would have known what the problem is.
There is no sense to deny a suggestion from someone you ask for advise.
But, keep on doing it. It's fun for the rest of us. :stuck_out_tongue_winking_eye:


Have you got this issue when dual-booting with any Linux?
The Grub though does show the 'Windows' menu entry.
Maybe the is some bug

I've got an old build of Manjaro on another drive and I have no problems.

I also have two builds of Windows and another drive with MacOS(hackintosh).

The only thing Grub doesn't recognize very well is the MacOS drive. Grub shows that I have three Windows builds. One of them is MacOS which is improperly labeled.

Maybe Solus falls under an incorrect identification (like MacOS does for me).

Once again, I don't know if you tried it, but I think it might be worth installing grub with sudo grub-install /dev/x on a different drive or on the drive you currently use

Until you confirm you have done what you should, we can't look for a bug, if you agree.

Confirm what you were asked to, if you are booting to a snapshot.
Last call...


Sounds like an airport announcement: Passengers booked with Garuda Indonesia, 01066, please immediately ..

1 Like

@Austin just recently posted a photo of his grub boot entry(see post 6) which confirms what he is dealing with is not my issue.

Maybe you didn't see the photo, but it is clear the boot entry is booting to /@/.

I do wish he had confirmed that earlier instead of saying it wasn't his issue, but there is no point in hassling him now.

On a different note, Austin has yet to get back on me on trying to install grub using the "grub-install" command. It's only been about a day, however


confirms he has a camera.
Clear troubleshooting needs clear answers to clear questions.

You are doing a great job and it's appreciated. (no irony)
Each idiosyncrasy on understanding others' inner minds is different. :grinning_face_with_smiling_eyes:


Hello there, sorry for all the confusion and delays. Actually I have my exams going on in my school, and I am not able to reply to your suggestions immediately, please do bear with me.
BTW, I am quite new to Linux, and I just know some basics

[[email protected] ~]# ls /boot/efi/EFI

boot  Dell  Garuda  Microsoft  systemd

[[email protected] ~]#

I had checked the EFI directory and I couldn't find Solus boot files.

And I think this would have been the issue, as my Fedora installation showed up in the grub! :grinning:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.