Grub is not styled on different install

Hello, I just installed garuda on my pc.
Previously I installed it on my laptop, it went well. The grub has garuda theme.
But when I installed in this pc, the grub just shown black thing with grey text. No garuda theming and stuffs. It's as if I installed garuda on gnome-boxes.

Why would these two different install from same gnome iso has different outcome?

One reason I can think of is because I don't have internet access on my laptop during install, because garuda live USB cannot connect to any wireless router. I used ethernet cable on my pc. (this is incorrect)

I could test reinstalling again without internet connection, and I probably would. But before I do that, I wanted to know if anyone has any idea on what might cause this or if it is better this way instead. I already spent gigabytes of data doing additional software install @[email protected] (im using metered connection)

The PC ran fine, I'm okay with using it. But I can't get the thought out of my head, "If the grub theming had an issue, what else could have issues on this install that I did not know about?"

Thanks for reading about my pointless worry. Hopefully someone can give me an insight as to why this happened.

System:
  Kernel: 5.19.9-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=2b96a3ae-a73e-430f-b4b2-933064264b80 rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3
  Desktop: GNOME v: 42.5 tk: GTK v: 3.24.34 wm: gnome-shell dm: GDM v: 42.0
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: ASRock model: B450M-HDV R4.0
    serial: <superuser required> UEFI: American Megatrends v: P4.50
    date: 03/12/2021
CPU:
  Info: model: AMD Ryzen 5 3500 bits: 64 type: MCP arch: Zen 2 gen: 3
    level: v3 built: 2020-22 process: TSMC n7 (7nm) family: 0x17 (23)
    model-id: 0x71 (113) stepping: 0 microcode: 0x8701021
  Topology: cpus: 1x cores: 6 smt: <unsupported> cache: L1: 384 KiB
    desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB L3: 16 MiB
    desc: 2x8 MiB
  Speed (MHz): avg: 2433 high: 3600 min/max: 2200/4120 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 2200 2: 2200
    3: 2200 4: 2200 5: 2200 6: 3600 bogomips: 43196
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT disabled
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
    disabled, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: NVIDIA TU117 [GeForce GTX 1650] driver: nvidia v: 515.65.01
    alternate: nouveau,nvidia_drm non-free: 515.xx+ status: current (as of
    2022-08) arch: Turing code: TUxxx process: TSMC 12nm built: 2018-22 pcie:
    gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 3 speed: 8 GT/s
    bus-ID: 09:00.0 chip-ID: 10de:1f82 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
    compositor: gnome-shell driver: X: loaded: nvidia unloaded: modesetting
    alternate: fbdev,nouveau,nv,vesa gpu: nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1016x286mm (40.00x11.26")
    s-diag: 1055mm (41.55")
  Monitor-1: DP-1 pos: primary,left res: 1920x1080 hz: 60 dpi: 93
    size: 527x296mm (20.75x11.65") diag: 604mm (23.8") modes: N/A
  Monitor-2: HDMI-0 pos: right res: 1920x1080 hz: 60 dpi: 166
    size: 294x166mm (11.57x6.54") diag: 338mm (13.29") modes: N/A
  Message: Unable to show GL data. Required tool glxinfo missing.
Audio:
  Device-1: NVIDIA driver: snd_hda_intel v: kernel bus-ID: 1-8:2 pcie: gen: 1
    chip-ID: 0c76:126e speed: 2.5 GT/s class-ID: 0300 lanes: 16 link-max:
    gen: 3 speed: 8 GT/s bus-ID: 09:00.1 chip-ID: 10de:10fa class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: ASRock
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 0b:00.4 chip-ID: 1022:1487 class-ID: 0403
  Device-3: JMTek LLC. USB PnP Audio Device type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Sound Server-1: ALSA v: k5.19.9-zen1-1-zen running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: PulseAudio v: 16.1 running: no
  Sound Server-4: PipeWire v: 0.3.58 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASRock driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: f000 bus-ID: 08:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp8s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IF-ID-1: anbox0 state: down mac: <filter>
Drives:
  Local Storage: total: 2.99 TiB used: 282.51 GiB (9.2%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 970 EVO Plus
    1TB size: 931.51 GiB block-size: physical: 512 B logical: 512 B
    speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 3B2QEXM7
    temp: 37.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000VX008-2E3164
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 5900 serial: <filter> rev: CV12 scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 vendor: V-Gen model: 01SM21NT256MT
    size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 5A0 scheme: GPT
  ID-4: /dev/sdc maj-min: 8:32 type: USB vendor: HP model: x778w
    size: 28.9 GiB block-size: physical: 512 B logical: 512 B type: N/A
    serial: <filter> rev: PMAP scheme: MBR
Partition:
  ID-1: / raw-size: 97.66 GiB size: 97.66 GiB (100.00%) used: 21.45 GiB
    (22.0%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-2: /boot/efi raw-size: 1000 MiB size: 996 MiB (99.60%) used: 26.2 MiB
    (2.6%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 390.62 GiB size: 383.43 GiB (98.16%) used: 239.33
    GiB (62.4%) fs: ext4 dev: /dev/nvme0n1p7 maj-min: 259:7
  ID-4: /var/log raw-size: 97.66 GiB size: 97.66 GiB (100.00%) used: 21.45
    GiB (22.0%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-5: /var/tmp raw-size: 97.66 GiB size: 97.66 GiB (100.00%) used: 21.45
    GiB (22.0%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.55 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  ID-2: swap-2 type: partition size: 11.72 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p6 maj-min: 259:6
Sensors:
  System Temperatures: cpu: 49.8 C mobo: N/A gpu: nvidia temp: 50 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info:
  Processes: 263 Uptime: 6m wakeups: 0 Memory: 15.55 GiB used: 2.45 GiB
  (15.7%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: pm: pacman pkgs: 1399
  libs: 347 tools: pamac,paru Shell: fish v: 3.5.1 default: Bash v: 5.1.16
  running-in: gnome-terminal inxi: 3.3.21
Garuda (2.6.7-1):
  System install date:     2022-09-19
  Last full system update: 2022-09-19
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       Probably (Run as root to verify)
  Snapshots:               Snapper
  Failed units:            anbox-container-manager.service 
McFly: Importing shell history for the first time. This may take a minute or two...done.

UPDATE:

I just tested in virtual machine. Looks like the "Internet connection during install" is correct.

Now I just want to know, "Which one is better?". Like, which one is more likely to have potential technical issue in the future? Can we manually fix grub theme? and is the one without garuda theming boot faster? Or it actually doesn't matter?

UPDATE2:

actually no!!, Tried again with internet connection in virtual machine and it's styled. HMMM, sounds like it's time to gamble.

  1. Welcome to the forum! :wink:

  2. Have you tried inspecting the values in "garuda boot options"? Is the checkmark "enable theme" checked? If not check it, choose /usr/share/grub/themes/garuda-dr460nized/theme.txt and hit apply.

  3. if 2 was already checked, have you tried rebuilding the grub config via sudo update-grub

  4. is the line GRUB_TERMINAL_OUTPUT=console commented in your /etc/default/grub? (has a leading #), if not, add the # and run sudo update-grub

4 Likes

Hello, before I reply your message, I already reinstalled and problem still exit. I didn't continue setup assistant as I'm trying to avoid spending more internet.

the booting window is also kinda inconsistent now. Earlier it shows big font, now it's small.
also before grub screen it says this:

error: out of memory
error: out of memory
error: out of memory
error: out of memory
error: out of memory
error: out of memory
error: out of memory
error: out of memory
error: out of memory
error: out of memory
error: out of memory
error: out of memory
error: out of memory

Press any key to continue...

Now to reply your message..

  1. Enable theme is checked. There is no dragonized theme, only starfield. It has exact same settings as my laptop which has the theme work and had no issues.

  2. GRUB_TERMINAL_OUTPUT=console is already commented

.......

ok now the error:out of memory is not there anymore. but the grub also changed.
It's the same small font dos looking view but it's now white and aligned center.

..
anyway as I write this sentence, I intend to reinstall garuda once more. but by selecting non-Uefi entry for my liveusb. (wait no nvm im not gonna do that)

I used UEFI on my laptop

Maybe you could try reinstalling grub-theme-garuda, i.e. the package providing (amongst other things) this background:

Which should be in my understanding the default for gnome.
While from Garuda Dr460nized it should be the grub-theme-garuda-dr460nized package, providing this background:

5 Likes

The issue is related to the video hardware/software being used, and almost definitely unrelated to Garuda ISO or system setup/configuration.

Different systems (HW) have different behavior, with video HW.

Try harder! :joy:
Reading technical whitepaper (or Archwiki and similar), should really help you fighting that idea out of your head :wink: .

7 Likes

Looks like I was googling with wrong keyword, I found the solution here:

by running
sudo grub-install
the grub theme is fixed.

but,... it's still doesn't show splash with garuda icon like in my laptop and just load my desktop instead. Which uhh I think it's better, I will take faster boot time than good looking one.

You are right, I should try harder. This issue is grub only and won't affect anything else. I should have just continue using my PC normally and only fix problem as they arises.

Once again, thank you everyone for visiting this thread.

1 Like

What ISO image did you use? What's the exact file name? This should not be happening in the first place.

1 Like

I'm using garuda-gnome-linux-zen-220822.iso

43811d1b622469ffa8d32115635ff2ffbf696845588cf9b03dcb0d3512452e58 garuda-gnome-linux-zen-220822.iso

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.