Grub gone crazy

I don't know why, but one day I booted my laptop and instead of seeing the grub menu my laptop got stuck and opened BIOS menu. After trying some options I've discovered the problem might lie in the Grub (I had got old Ubuntu Grub and Windows boot normally).

I digged out my pendrive with Garuda Live and tried to find some solution. After looking a little on this forum I made the following steps:

  • chroot-ed into my current installation on the disk
  • ran sudo grub-install and sudo update-grub
    Nothing has reported any errors, so I rebooted my laptop and, to my delight, I saw Garuda's Grub menu and been able to start my system :slight_smile:

However, there is one little problem. I may be a bit too grumpy, but in the past days the Grub menu started in less that one second, while now it is five or more seconds. It made me thinking I might not fixed the issue completely, so I made the above steps again on the current system (except chroot-ing of course :wink: ).

And I came back to the broken state :frowning: . It became even worse, because now my BIOS got so confused, it got reset to the factory defaults (which made MS Windows the only option to boot :angry: ). Fortunately, I tried to do again the fix and I'm back in the working state (although still with long to start Grub).

After that I saw here on the forum other people complaining about the Grub. Also I had an system update (garuda-update) a few minutes ago which downgraded the Grub. Well, good news is it didn't broke anything, but on the other side it didn't fixed anything too (5 seconds of boot...) :frowning:

Is it possible that whatever the previous Grub update has done is permanent?

  Kernel: 5.19.5-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=6a135e81-5d37-4390-8a10-a9eef293c0d9 rw [email protected]
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    systemd.unified_cgroup_hierarchy=1 loglevel=3
  Desktop: Cinnamon v: 5.4.9 tk: GTK v: 3.24.34 wm: Mutter vt: 7
    dm: LightDM v: 1.32.0 Distro: Garuda Linux base: Arch Linux
  Type: Laptop System: Acer product: Aspire A515-54G v: V1.24
    serial: <superuser required>
  Mobo: CML model: Doc_WC v: V1.24 serial: <superuser required>
    UEFI: Insyde v: 1.24 date: 07/07/2021
  ID-1: BAT1 charge: 39.1 Wh (100.0%) condition: 39.1/48.9 Wh (79.8%)
    volts: 16.1 min: 15.2 model: LGC AC14B8K type: Li-ion serial: <filter>
    status: full
  Info: model: Intel Core i5-10210U bits: 64 type: MT MCP
    arch: Comet/Whiskey Lake note: check gen: core 10 built: 2018
    process: Intel 14nm family: 6 model-id: 0x8E (142) stepping: 0xC (12)
    microcode: 0xF0
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 6 MiB desc: 1x6 MiB
  Speed (MHz): avg: 1450 high: 2100 min/max: 400/4200 scaling:
    driver: intel_pstate governor: powersave cores: 1: 800 2: 800 3: 2100
    4: 2100 5: 800 6: 800 7: 2100 8: 2100 bogomips: 33599
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: Enhanced IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
    filling, PBRSB-eIBRS: SW sequence
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel CometLake-U GT2 [UHD Graphics] vendor: Acer Incorporated
    ALI driver: i915 v: kernel arch: Gen-9.5 process: Intel 14nm
    built: 2016-20 ports: active: eDP-1 empty: HDMI-A-1 bus-ID: 0000:00:02.0
    chip-ID: 8086:9b41 class-ID: 0300
  Device-2: NVIDIA GP108M [GeForce MX250] vendor: Acer Incorporated ALI
    driver: nouveau v: kernel non-free: 515.xx+ status: current (as of 2022-07)
    arch: Pascal code: GP10x process: TSMC 16nm built: 2016-21
    bus-ID: 0000:02:00.0 chip-ID: 10de:1d13 class-ID: 0302
  Device-3: Quanta HD User Facing type: USB driver: uvcvideo bus-ID: 1-5:3
    chip-ID: 0408:a061 class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.4 driver: X: loaded: intel,nouveau
    unloaded: modesetting alternate: fbdev,nv,vesa gpu: i915 display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 mapped: eDP1 model: AU Optronics 0x61ed built: 2018
    res: 1920x1080 hz: 60 dpi: 143 gamma: 1.2 size: 340x190mm (13.39x7.48")
    diag: 395mm (15.5") ratio: 16:9 modes: 1920x1080
  Message: Unable to show GL data. Required tool glxinfo missing.
  Device-1: Intel Comet Lake PCH-LP cAVS vendor: Acer Incorporated ALI
    driver: snd_hda_intel v: kernel
    alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 0000:00:1f.3
    chip-ID: 8086:02c8 class-ID: 0403
  Sound Server-1: ALSA v: k5.19.5-zen1-1-zen running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: PulseAudio v: 16.1 running: no
  Sound Server-4: PipeWire v: 0.3.56 running: yes
  Device-1: Intel Comet Lake PCH-LP CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 0000:00:14.3 chip-ID: 8086:02f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Acer Incorporated ALI driver: r8169 v: kernel port: 3000
    bus-ID: 0000:03:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp3s0 state: down mac: <filter>
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode]
    driver: intel_nvme_remap v: N/A port: 5060 bus-ID: 0000:00:17.0
    chip-ID: 8086:282a rev: class-ID: 0104
  Local Storage: total: 953.87 GiB used: 118.48 GiB (12.4%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKNW010T8
    size: 953.87 GiB block-size: physical: 512 B logical: 512 B type: SSD
    serial: <filter> rev: 002C temp: 29.9 C scheme: GPT
  ID-1: / raw-size: 476.38 GiB size: 476.38 GiB (100.00%) used: 118.43 GiB
    (24.9%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) used: 54.7 MiB
    (56.9%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 476.38 GiB size: 476.38 GiB (100.00%) used: 118.43
    GiB (24.9%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-4: /var/log raw-size: 476.38 GiB size: 476.38 GiB (100.00%) used: 118.43
    GiB (24.9%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-5: /var/tmp raw-size: 476.38 GiB size: 476.38 GiB (100.00%) used: 118.43
    GiB (24.9%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 7.59 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 44.0 C pch: 46.0 C mobo: N/A gpu: nouveau
    temp: 41.0 C
  Fan Speeds (RPM): N/A
  Processes: 270 Uptime: 43m wakeups: 1 Memory: 7.59 GiB used: 3.12 GiB
  (41.1%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: apt: 0 pacman: 1881 lib: 476
  Shell: Bash v: 5.1.16 running-in: gnome-terminal inxi: 3.3.20
Garuda (2.6.6-1):
  System install date:     2021-12-22
  Last full system update: 2022-08-31
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       Probably (Run as root to verify)
  Snapshots:               Snapper
  Failed units:            

Well I too have the longer boot-time. I don't mind, because I usually only boot my system once a day. The UEFI-logo is presented for a few seconds before Grub gives any options booting-wise.

No idea what's going on there.

Dunno, but if I had to pick one thing only, I'd guess that when GRUB was downgraded, the replacement defaulted to it's, well, default, of 5 seconds.

Just a guess. I'm in Windows on this machine. :upside_down_face:

1 Like

Just search in forum
TNE, grub, sort by latest.
Downgrade to last working grub until it was fixed .



It is a BIOS setting that allows that. You can change it if you want to reclaim the time.

1 Like

When I said "five or more seconds" I meant it takes that much time for the Grub menu to appear on my screen, not to chose and run a system :stuck_out_tongue_winking_eye: And, no, my BIOS has no setting for how long the UEFI logo is displayed.

About downgrading: I might sound right now like a dirty coward, but I wish someone else have done this procedure and found which version is right. Every time I changed something in my system that as a result it became broken I got goose bumps and... well, let's just say I really don't want to make use of all that backup I've just made :frowning:

Duh. The logo display is a time-consumer. You might have an inexpensive machine if your BIOS doesn't allow you to change that setting. Your machine can't display it if the BIOS doesn't allow it.

Well, no. The UEFI-setting was enabled beforehand, too. But then the UEFI-logo was shown for like one second, with "Press Del for Setup and F11 for Boot Order" underneath it. Now it's displayed far longer, without the "Press..." stuff underneath, afterwards.

This happened after I fixed the complete "directly to Bios" disaster of Grub, so it's clearly something still buggy there. I did not change any settings in Bios.

Hey all,
I also have the same problem... I have to wait more than 5 seconds before grub is appearing and i can choose wich os i will start... :flushed: :flushed: :flushed:

The version in the repos right now.

A full garuda-update should downgrade the version in your UEFI, assuming your bootloader name is "Garuda".


Try garuda-update in terminal.

1 Like

Thanks, that did the trick for me :



1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.